cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
446
Views
0
Helpful
8
Replies
Highlighted
Beginner

Switchport mode access and switchport voice vlan

Hi,

interface GigabitEthernet3/31
switchport mode access
switchport nonegotiate
switchport voice vlan 30

 

Why is it possible to hv 2 VLAN (data and voice) in the same port considering it is ACCESS and NOT TRUNK port?

Bcoz of Cisco technology OR this is quite standard for all other brand of switches?

I saw some switches got terms like HYBRID port, is it the same?

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Hall of Fame Expert

Hi,

It is called "Multi-vlan access port. Have a look at this link and see section "Multi-vlan access port" for detail explanation.

 

https://www.learncisco.net/courses/icomm-ccna-voice/cisco-uc-solution-maintenance/switch-configuration.html

HTH

View solution in original post

Highlighted
VIP Expert

"Why is it possible to hv 2 VLAN (data and voice) in the same port considering it is ACCESS and NOT TRUNK port?"

Because, "logically", the port is intended as an edge port for VoIP (e.g. VoIP phone) and data (e.g. PC/workstation) hosts.

Other vendors probably offer a similar feature. BTW, on older Cisco switches, i.e. before you had a "voice" VLAN to define on an "access" port, you would define the port as a trunk but you might also disable many specific "trunk" port features to effectively create the same kind of "edge" port.

"I saw some switches got terms like HYBRID port, is it the same?"

Don't know, but it's not uncommon for different vendors to use different terms for the same functional technology, especially if vendor has the technology before there's a "standards" version.

View solution in original post

Highlighted

to add to what Joe mentioned:

1 - generally speaking, I think a lot of folks consider an edge port to be an end user port. Not a strict definition, but as Joe says at the edge of the network, IE - access layer, and not at core/distribution layer.

2 - no, it does not mean that you must, but generally using cdp for cisco phones, or lldp for avaya phones, helps in tracking and troubleshooting, or poe allocation. Also note that in some environments where security and compliance is a big topic, these L2 protocols might be disabled and not allowed to be turned on.

3 - personally I do not

4 - it can, but does not necessarily have to have both. It can be just a data vlan, or configured for voice and data. 

View solution in original post

8 REPLIES 8
Highlighted
VIP Mentor

if i understand the quesiton you looking 2 VLAN to be in the access port ? not trunk

 

cisco do support Access Data and voice in the same port as below example : ( this is for where edge device connecting)

 

for uplink, you need to allow this 2 VLAN in the Trunk to reach other switches.

 

 

 

interface GigabitEthernet3/31
switchport mode access
switchport nonegotiate
switchport voice vlan 30

switchport access vlan 20 - for data

 

BB
*** Rate All Helpful Responses ***
Highlighted
Engager

 

I think Cisco calls it Mini-trunk. It is established via CDP, so your device must be able to use CDP, like Cisco IP phones and switches.  I think there are 4 options with that mini-trunk.  You can find them in CCNP Switch, OCG book from Cisco Press. (If I find saved picture, I attach it).

Basically, Cisco IP phone is like mini switch with 2 or 3 ports; one to switch, one to PC or device. So, trunk is established between switch and IP phone, then no trunk between IP phone and PC.  you must have Ip phone between switch and end-device and in correct port (it wont work otherwise).  One port shows icon of a switch; while other one icon of a PC.

 

Regards, ML
**Please Rate All Helpful Responses **

Highlighted
Hall of Fame Expert

Hi,

It is called "Multi-vlan access port. Have a look at this link and see section "Multi-vlan access port" for detail explanation.

 

https://www.learncisco.net/courses/icomm-ccna-voice/cisco-uc-solution-maintenance/switch-configuration.html

HTH

View solution in original post

Highlighted
VIP Expert

"Why is it possible to hv 2 VLAN (data and voice) in the same port considering it is ACCESS and NOT TRUNK port?"

Because, "logically", the port is intended as an edge port for VoIP (e.g. VoIP phone) and data (e.g. PC/workstation) hosts.

Other vendors probably offer a similar feature. BTW, on older Cisco switches, i.e. before you had a "voice" VLAN to define on an "access" port, you would define the port as a trunk but you might also disable many specific "trunk" port features to effectively create the same kind of "edge" port.

"I saw some switches got terms like HYBRID port, is it the same?"

Don't know, but it's not uncommon for different vendors to use different terms for the same functional technology, especially if vendor has the technology before there's a "standards" version.

View solution in original post

Highlighted
Enthusiast

the phone tags voice traffic (with vlan 30) but does not for the PC that is plugged into the phone (regardless of what the access vlan number is). That's why it is not defined as a trunk port. For cisco phones, CDP helps determine. For other vendors, LLDP helps determine.

Highlighted

Hi,

 

1)Is "edge port" a Cisco proprietary technology-only Cisco switches or other switch also using? 

2)Does it means the configuration of voice and data vlan MUST use CDP(both sides CDP enabled)? fyi, I am connecting to Avaya IP phones but sh cdp doesnt see them.

3)Any example of "edge port" /"voice + data vlan" config in other brands switch?

4)"edge port" is an access port with voice + data vlan,correct?

 

Thank you so much!!!!!!

 

 

Highlighted

#1 No. An "edge port", I believe, is a generic term (or perhaps from RSTP) that means the port connects to some device, or devices, at the edge of the network. In other words, traffic will be sourced/terminated at this port (unlike a "transit" port that has traffic flowing to/from further away devices - e.g. a switch to switch connection).

#2 No. CDP (or LLDP) is not required. I've run non-Cisco phones connected to such data/voice ports. What CDP provides (as might LLDP) is informing something like a VoIP phone what VLAN to use for its voice traffic. A couple of ways to do that include "hard coding" the voice VLAN into the VoIP phone or using DHCP to inform the phone what VLAN to use.

#3 An example of another vendor supporting this kind of port: https://kb.juniper.net/InfoCenter/index?page=content&id=KB11062

#4 Yes and no. See answer to #1, above.
Highlighted

to add to what Joe mentioned:

1 - generally speaking, I think a lot of folks consider an edge port to be an end user port. Not a strict definition, but as Joe says at the edge of the network, IE - access layer, and not at core/distribution layer.

2 - no, it does not mean that you must, but generally using cdp for cisco phones, or lldp for avaya phones, helps in tracking and troubleshooting, or poe allocation. Also note that in some environments where security and compliance is a big topic, these L2 protocols might be disabled and not allowed to be turned on.

3 - personally I do not

4 - it can, but does not necessarily have to have both. It can be just a data vlan, or configured for voice and data. 

View solution in original post

Content for Community-Ad