cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

176
Views
0
Helpful
5
Replies
Highlighted
Beginner

Switchport was running with reduced speed of 100 Mbps instead of 1000 Mbps

The switchport (to which one of the physical NIC of ESXi Server is connected) was running with reduced speed of 100 Mbps instead of 1000 Mbps, although the speed was set to auto at both end. There was no error or speed-duplex mismatch alert on the switchport. Issue resolved after the switchport was bounced.

 

- Is any other alert gets generated automatically when the switchport negotiates at a lower speed?

- If not, is there any configuration to generate this kind of alert on its own?

 

Running on Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSALK9-M), Version 03.08.06.E RELEASE SOFTWARE (fc4)

!
interface GigabitEthernet1/6/24
description ## XXXXXXXXXXXXXXXXXXXXXXXXXXX #
switchport access vlan 4
switchport mode access
switchport priority extend trust
auto qos trust
storm-control broadcast level 15.00
qos trust extend
spanning-tree portfast edge
spanning-tree guard root
service-policy input AutoQos-4.0-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
end

Everyone's tags (3)
5 REPLIES 5
Highlighted
VIP Mentor

Re: Switchport was running with reduced speed of 100 Mbps instead of 1000 Mbps

try below commands on the switch

 

speed 1000

speed nonegotiate

 

if still now working

 

can you post-show interface g x/x 

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Switchport was running with reduced speed of 100 Mbps instead of 1000 Mbps

From VMware side it was suggested to use auto negotiation as a standard practice.

 

XXXXXXXXX#sh int Gi1/6/24
GigabitEthernet1/6/24 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet Port, address is 0462.7344.5d97 (bia 0462.7344.5d97)
Description: ## XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX $#
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 7/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX
input flow-control is on, output flow-control is on
Auto-MDIX on (operational: on)
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters 3w0d
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 512928
Queueing strategy: Class-based queueing
Output queue: 0/40 (size/max)
5 minute input rate 29325000 bits/sec, 2982 packets/sec
5 minute output rate 3765000 bits/sec, 1337 packets/sec
3249254212 packets input, 4292784185479 bytes, 0 no buffer
Received 57433 broadcasts (1479 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
1400191099 packets output, 712991715204 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Highlighted
VIP Mentor

Re: Switchport was running with reduced speed of 100 Mbps instead of 1000 Mbps

Hello,

 

you could run the EEM script below. The script will run every 60 seconds (you can change that interval) and check if the interface runs at auto/100, if that is the case, a syslog message will be generated, and the interface will be bounced:

 

event manager applet INTERFACE_SPEED
event timer watchdog time 60
action 1.0 cli command "enable"
action 2.0 cli command "show interfaces status | inc Gi1/6/24"
action 3.0 string match "*a-100*" "$_cli_result"
action 4.0 if $_string_result eq "1"
action 5.0 syslog msg "Interface speed of GigabitEthernet1/6/24 has changed to a-100"
action 6.0 cli command "conf t"
action 7.0 cli command "interface GigabitEthernet1/6/24"
action 8.0 cli command "no shut"
action 9.0 end

Highlighted
VIP Advocate

Re: Switchport was running with reduced speed of 100 Mbps instead of 1000 Mbps

@Georg Pauwen  I think you missed "Shut" command in the EEM

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted
VIP Mentor

Re: Switchport was running with reduced speed of 100 Mbps instead of 1000 Mbps

Good catch ! You are absolutely right. So the script would look like this:

 

event manager applet INTERFACE_SPEED
event timer watchdog time 60
action 1.0 cli command "enable"
action 2.0 cli command "show interfaces status | inc Gi1/6/24"
action 3.0 string match "*a-100*" "$_cli_result"
action 4.0 if $_string_result eq "1"
action 5.0 syslog msg "Interface speed of GigabitEthernet1/6/24 has changed to a-100"
action 6.0 cli command "conf t"
action 7.0 cli command "interface GigabitEthernet1/6/24"
action 8.0 cli command "shut"
action 9.0 cli command "no shut"
action 9.1 end

Content for Community-Ad