cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2092
Views
40
Helpful
45
Replies

Things to consider when implementing HSRP?

clybumat1
Level 1
Level 1

See below for an example of our topology.  I've been asked to install a secondary L3 switch and implement HSRP between the primary and secondary.

Currently we just have the single Primary switch which has SVI's for several different user VLANs.  The two example user switches just have a single connection to this switch - switchport access vlan 10 and switchport access vlan 20.  On the L3 switch side, the vlans are trunked on the interfaces (switchport trunk allowed vlan 10 etc)

We will be installing a secondary L3 switch for a redundant connection on each user switch.  This will need to be the standby router. 

My general instructions are "each SVI will need to be converted to an HSRP address"

What is my first step here?  I assume I need to determine a virtual IP address for the HSRP group.  Does this mean the IP address for each SVI will need to be converted to this virtual IP address?  What would be an example config for the SVIs on the Primary and Secondary switches?

Almost forgot - How will spanning-tree factor in with all of this?  Do I need to consider any changes to spanning-tree when implementing this config?

45 Replies 45

yeap it should work, could you please share your config of each L3 switch?

Thanks. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

PrimaryL3Switch#sho run
Building configuration...

Current configuration : 1515 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname PrimaryL3Switch
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 description TRUNK TO SECONDARY L3 SWITCH
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
!
interface GigabitEthernet0/1
 description LINK 1 TO VLAN 10 USER SWITCH
 switchport trunk allowed vlan 10
 switchport trunk encapsulation dot1q
!
!
interface Vlan1
 no ip address
 shutdown
!
interface vlan10
 mac-address 00e0.b044.2b01
 ip address 10.4.10.2 255.255.255.0
 standby 1 ip 10.4.10.1
 standby 1 priority 110
 standby 1 preempt
!
router eigrp 101
 network 10.4.10.0 0.0.0.255
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

SecondaryL3Switch#sho run
Building configuration...

Current configuration : 1490 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SecondaryL3Switch
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 description TRUNK TO PRIMARY L3 SWITCH
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
 description LINK 2 TO VLAN 10 USER SWITCH
 switchport trunk allowed vlan 10
 switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 00d0.bade.1301
 ip address 10.4.10.3 255.255.255.0
 standby 1 ip 10.4.10.1
 standby 1 priority 90
 standby 1 preempt
!
router eigrp 101
 network 10.4.10.0 0.0.0.255
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Hi

It should be 

interface vlan 10  instead inter vlan 141

interface Vlan141
 mac-address 00d0.bade.1301
 ip address 10.4.10.3 255.255.255.0
 standby 1 ip 10.4.10.1
 standby 1 priority 90
 standby 1 preempt

The correct info on both L3 should be:

interface Vlan 10




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

It is interface vlan 10.  That was an error that I have since corrected.

oh ok, 

it looks fine, the HSRP should work properly, 

it should not affect but include the switchport mode trunk under this interface:

interface GigabitEthernet0/1
switchport mode trunk

Everything looks good other than that. 

if you run show standby vlan 10 on the secondary L3 switch you got the same result? standby router unknown?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

For testing purposes remove the eigrp process and try to ping the ip .2 and .3




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

I tried this and I cannot ping the .2 and .3.  I can ping the 10.4.10.1 from each L3 Switch.

Are you using the .2 and .3 on other devices?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

No.  I wonder if this is a Packet Tracer bug.. I'm always suspect of it when doing anything other than basic configs.

Maybe a packet tracer bug. Could you remove hsrp and configure vrrp instead. The command are the same expect the 1st word that's vrrp instead of hsrp


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

It doesn't look like packet tracer supports VRRP.

Ok. I'm using Packet tracer. But HSRP should be supported on version 6.

Which version are you running?


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

As far as I see, sometimes Packet tracer requires that you enter standby version 2 under the interface config


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

It will not accept that command.  The only available commands are:

<0-4095> group number

ip Enable HSRP and set the virtual IP address

preempt Overthrow lower priority Active routers

priority Priority level

timers Hello and hold timers

track Priority Tracking

Ok then I'm sorry I can't help more on packet tracer. If you're using other tools, or real devices, you'll that's working.

I can't even try packet tracer as it won't work on my laptop (linux machine)

Thanks

PS: Please don't forget to rate and mark as correct answer if this answered your question


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card