Showing results for 
Search instead for 
Did you mean: 

Traceroute coming back with !N !N !N


I am trying to hit network with a 172.21.29.x (external network). I can't ping, when I run a traceroute i get the following

9300#traceroute 172.21.x.x
Type escape sequence to abort.
Tracing the route to 172.21.x.x
VRF info: (vrf in name/id, vrf out name/id)
1 10.76.x.151 2 msec 2 msec 2 msec
2 ( !N !N !N is the centurylink where our internet comes into the building. I've tried adding 172.21.x.x as the next hop and added to access list but it still doesn't work. Any help would be greatly appreciated.

access-list 50 permit 185.158.x.x
access-list 50 permit 172.21.x.x
access-list 50 permit 154.12.x.x
access-list 50 permit 176.10.x.x
access-list 50 permit 185.158.x.x

7 Replies 7

Rising star
Rising star

Apparently RFC1918 address (172.21.x.x) is going out the Internet. ISPs drop all RFC1918. That's why traceroute is reporting !N  (Network is not reachable).


Do you have a VPN Tunnel or other connection to this Remote Subnet? Maybe in a different VRF? As rais already said: This Private Range IP is not routed in the internet. You can never reach this Subnet over the internet except you have a VPN.

Your request make no sense. Maybe you can make a visio draw from your network.

I don't believe there is, so here's what we are doing, we are trying to use cisco voip phones on our network, we have a cisco 9300 that allows traffic between our network and theirs. According to them we should be able to get to there ip's 172.21.x.x, even though I told them I can't see them. They push it back to us because of that N! result for the ping. I don't have a network drawing  


Maybe a network drawing helps you too I do not complete understand your setup (and I guess you have the same problem), but this packet should never go to your ISP.

every ISP router not accept ping/treceroute to protect router form DDoS. 

Rising star
Rising star

You said this is the connection to internet, that normally implies that you have either a default-route or a full bgp table. It can't be a default-route, because then the router shouldn't return the !N output. Who is responsible for Is it you? If so, can you share the output of "show ip route". and "show ip route 172.21.x.x" As noted, this is an rfc1918 address, so you don't need to mask it. 

S* [1/0] via is variably subnetted, 2 subnets, 2 masks
C is directly connected, GigabitEthernet0/2
L is directly connected, GigabitEthernet0/2 is variably subnetted, 2 subnets, 2 masks
C is directly connected, GigabitEthernet0/1
L is directly connected, GigabitEthernet0/1 is variably subnetted, 2 subnets, 2 masks
C is directly connected, Vlan1
L is directly connected, Vlan1

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: