cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
294
Views
5
Helpful
7
Replies
Highlighted
Beginner

Traffic -Internet links

Dears,

 

I am going to have the attached setup for one of my new project. I would like to know whether the planned design will work with our requirements or not. 

 

1) As attached we are going to have 3xADSL 100mb link ( 100mb download with 25 upload) which are going to be terminated on a cisco 2900 series router. All the 3 links will be having different IPs on each circuits.

2) All the hosts which are on the 10.10.5.0/24 network would be uploading(only) the contents to same server (94.*.*.*) on the internet on an individual link.

3) No load balancing is required between internet links as 10.10.5.5 use ADSL1, 10.10.5.10 use ADSL2 & 10.10.5.20 use ADSL 3.

 

Planned router config is as follows.Please check and shed some light on this.

 

==============================================================================================================

 

interface fastEthernet0/0/0
 description ADSL1
 bandwidth 10000
 ip address 91.*.*.* 255.255.255.*
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface fastEthernet0/0/1
 description ADSL2
 bandwidth 100000
 ip address 91.*.*.* 255.255.255.*
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description ADSL3
 bandwidth 100000
 ip address 91.*.*.* 255.255.255.*
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/0
 description LAN
 bandwidth 100000
 ip address 10.10.5.200 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!

ip nat inside source list ROUTE_ADSL1 interface FastEthernet0/0/0 overload
ip nat inside source list ROUTE_ADSL2 interface fastEthernet0/0/1 overload
ip nat inside source list ROUTE_ADSL3 interface GigabitEthernet0/1 overload


ip route 0.0.0.0 0.0.0.0 91.*.*.*
ip route 0.0.0.0 0.0.0.0 91.*.*.*
ip route 0.0.0.0 0.0.0.0 91.*.*.*


ip access-list extended ROUTE_ADSL1
 permit ip host 10.10.5.5 any
 

ip access-list extended ROUTE_ADSL2
permit ip host 10.10.5.10 any

ip access-list extended ROUTE_ADSL3
permit ip host 10.10.5.20 any

 

 

Thanks 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7 REPLIES 7
Highlighted

Hi,Just check , You can't

Hi,

Just check , You can't have multiple default route in routing table.

Configure PBR to send sepecific traffic to specific links and configure one default route and another floating static for redundancy.

Hope that Helps..

 

-GI

 

Rate if it Helps

Highlighted
Beginner

Thanks Ganesh for your

Thanks Ganesh for your reponse on this.

Basically we will be having only upload traffic to a same destined IP from the lan segment( 10.10.5.0/24). 

We will be having continous 75Mbps upload video/audio traffic hence i have to use all three internet links same time since each link has only 25Mbps upload capacity.

Plan is to send traffic from 10.10.5.5 towards ADSL1 , 10.10.5.10 towards ADSl2 & 10.10.5.20 towards Adsl3.failover/Load balacing not required but have to use all the three links in the same time.

 

Is there any way i can achive this?


Thanks for your time on this

 

 

 

Highlighted

Thanks Ganesh for your

Thanks Ganesh for your reponse on this.

Basically we will be having only upload traffic to a same destined IP from the lan segment( 10.10.5.0/24). 

We will be having continous 75Mbps upload video/audio traffic hence i have to use all three internet links same time since each link has only 25Mbps upload capacity.

Plan is to send traffic from 10.10.5.5 towards ADSL1 , 10.10.5.10 towards ADSl2 & 10.10.5.20 towards Adsl3.failover/Load balacing not required but have to use all the three links in the same time.


Is there any way i can achive this?

Thanks for your time on this

 

Hi Shibu,

Yes you can definitely achieve this via PBR, Check out below link with example.

You can then try and do the below pattern configuration.

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/15-0SY/configuration/guide/15_0_sy_swcg/policy_based_routing_pbr.html

https://glennmatthys.wordpress.com/2012/04/24/policy-based-routing-example-route-one-subnet-via-isp-a-and-another-via-isp-b/

Hope it Helps..

-GI

Rate if It Helps ..

Highlighted
Beginner

Thanks Ganesh. will try out

Thanks Ganesh. will try out this option & let you know the outcome.

In the meanwhile is there any way i can upload on all three links from a single host rather than 3 hosts to a single destination?

Can i upload to all three links from a single host at a time?  10.10.5.5 to 94.*.*.*

 

Thanks for your time.

 

 

 

 

 

 

 

 

Highlighted

Thanks Ganesh. will try out

Thanks Ganesh. will try out this option & let you know the outcome.

In the meanwhile is there any way i can upload on all three links from a single host rather than 3 hosts to a single destination?

Can i upload to all three links from a single host at a time?  10.10.5.5 to 94.*.*.*


Thanks for your time.

Hi,

Uploading from single source to multiple destinations, are the destination are different ip series, If it is different destination then drop species destination route towards different links and start uploading.

If it is same destination and you want to use over three different links that will be asymmetric routing and re transmmission of TCP segment over links.I believe even TCP handshake also will not happen properly.

Hope it Helps..

-GI

Rate if it Helps..

Highlighted
Beginner

Thanks Ganesh for your


Thanks Ganesh for your response.

I am trying to find out the best options to move forward on this requirement.  I have one more option  in mind as below.

I mean rather than pushing traffic from my side to internet i am thinking the other way around. Pulling method from internet to my server. For this purpose i will arrange usable Ips from each link & will nat my server ip to all three of the links IPs.

Will distribute the natted Ip with the required link and ask them to pull the data from their side.  Attach is the diagram which i am planning.


Do you think this is a doable solution? will it work ? 


Thanks for your time.

Highlighted

Thanks Ganesh for your

Thanks Ganesh for your response.

I am trying to find out the best options to move forward on this requirement.  I have one more option  in mind as below.

I mean rather than pushing traffic from my side to internet i am thinking the other way around. Pulling method from internet to my server. For this purpose i will arrange usable Ips from each link & will nat my server ip to all three of the links IPs.

Will distribute the natted Ip with the required link and ask them to pull the data from their side.  Attach is the diagram which i am planning.

Do you think this is a doable solution? will it work ? 

Thanks for your time.

Hi,

I have personally never tested these type of scenario and batting same private ip address with different public ips in same network device, Normally it gives error when i tried this type of configuration in firewalls not sure about how router would behave when you do multiple nat statement for single private ip.

Hope it Helps..

-GI

Rate if it Helps

 
Content for Community-Ad