01-29-2013 09:07 PM - edited 03-07-2019 11:23 AM
Unable to limit traffic on catalyst 3750 gigabit ports it has fiber modules,
I want to limit traffic 2mb per port
I have tried srr-queue and policier but it is not working and there is no ratelimit command under any interface,
Applying policy to output is not supported of the interface
policy-map rate-limit
class class-default
police 2000000 8000 exceed-action drop
int gi1/0/3
service-policy input rate-limit
still when I start download it goes to 10 mbps
please if you have any idea about help me it is a bout 20 days I am working on it.
Solved! Go to Solution.
01-30-2013 08:36 AM
Hi Sayed,
few notations.
- output policing is not supported on this platform, that is a fact.
- the config you use seems correct
- is mls qos enabled?
- show policy-map interface is not supported and does not show any output
- use "sh mls qos int
- have you checked the stats of the interface the traffic is going to?
ie: user ----- gi1/0/3 3750 gi1/0/15 ---- network
If you check the counters (lower the load interval to 30 sec) on egress on Gi1/0/15 how much traffic do you see? (if you have other traffic try calculate the delta after you start the download).
Riccardo
01-30-2013 08:10 AM
Hi,
Have you enabled QoS globally via the "mls qos" command?
Can you please post the "sh mls qos interface gi1/0/3 statistics" command output.
Thanks & Regards,
Antonin
01-30-2013 09:01 PM
yea I have enabled mls qos globally
FiberSwitch#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled
FiberSwitch#sh mls qos interface gi1/0/4
GigabitEthernet1/0/4
Attached policy-map for Ingress: rate-limit
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based
01-30-2013 08:36 AM
Hi Sayed,
few notations.
- output policing is not supported on this platform, that is a fact.
- the config you use seems correct
- is mls qos enabled?
- show policy-map interface is not supported and does not show any output
- use "sh mls qos int
- have you checked the stats of the interface the traffic is going to?
ie: user ----- gi1/0/3 3750 gi1/0/15 ---- network
If you check the counters (lower the load interval to 30 sec) on egress on Gi1/0/15 how much traffic do you see? (if you have other traffic try calculate the delta after you start the download).
Riccardo
01-30-2013 09:02 PM
FiberSwitch#sh mls qos interface gi1/0/4
GigabitEthernet1/0/4
Attached policy-map for Ingress: rate-limit
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based
01-31-2013 12:51 AM
Hi Sayed,
the command to use is "sh mls qos interface gi1/0/4 stat"
you missed the final key.
Also, you flagged the question as answered. You verified that the policer is working or what?
Riccardo
01-31-2013 01:04 AM
FiberSwitch#sh mls qos interface gi1/0/4 stat
GigabitEthernet1/0/4
dscp: incoming
-------------------------------
0 - 4 : 1662856 0 0 0 4
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 0 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
0 - 4 : 2408295 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 0 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
cos: incoming
-------------------------------
0 - 4 : 1672031 0 0 0 0
5 - 7 : 0 0 0
cos: outgoing
-------------------------------
0 - 4 : 2412007 0 0 0 0
5 - 7 : 0 0 0
Policer: Inprofile: 1585779 OutofProfile: 72671
01-31-2013 01:09 AM
you see the policer is working and dropping some traffic.
Policer: Inprofile: 1585779 OutofProfile: 72671
Did you do the check I suggested on previous post?
01-31-2013 03:10 AM
But my download speed is a bove why it does't controle it, I have specified the policy 2mb but my download speed is above 10 mbps it seems that I should apply the policy to output of the interface which is not supported by by catalyst 3750 what should I do now.
01-31-2013 05:07 AM
how do you actually measure that?
please do the test I said so we have reliable data to look at: check the stats of the egress interface to see if we really have 10 mbps.
Riccardo
01-31-2013 11:31 PM
Same issue facing but I haven't seen any packets in output profile. please advice
policy-map test
class class-default
police 256000 8000 exceed-action drop
interface GigabitEthernet1/0/23
switchport access vlan 595
switchport mode access
spanning-tree portfast
service-policy input test
Switch2#sh mls qos interface gigabitEthernet 1/0/23 statistics
GigabitEthernet1/0/23 (All statistics are in packets)
dscp: incoming
-------------------------------
0 - 4 : 69321 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 0 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
0 - 4 : 60436 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 269 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 265 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
cos: incoming
-------------------------------
0 - 4 : 69920 0 0 0 0
5 - 7 : 0 0 0
cos: outgoing
-------------------------------
0 - 4 : 61232 0 269 0 0
5 - 7 : 0 262 4011
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 2 0 0
queue 1: 1593 4684 5051
queue 2: 269 0 0
queue 3: 0 0 54452
output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0
queue 2: 0 0 0
queue 3: 0 0 0
Policer: Inprofile: 1689 OutofProfile: 0
Switch2#
02-02-2013 03:59 AM
need advice
02-03-2013 06:36 PM
Waiting
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide