cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
405
Views
0
Helpful
8
Replies
Highlighted
Beginner

trouble communicating accross trunk

i have posted the configs from both switches. one switch is a 6503 the other is a 3750.  both switchs are layer 3.  i am unable to ping between them on vlan 254.  i can ping the directly connected vlan just not the vlans accross the trunk. any help would be appreciated.

thank you

config for 6503

version 12.2

hostname CR1-SW6503-1

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree backbonefast

--More--                           spanning-tree vlan 1 priority 0

spanning-tree vlan 10,20,22,30,110,120,130 priority 8192

spanning-tree vlan 11,21,71,111,121 priority 4096

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

!

redundancy

mode sso

main-cpu

  auto-sync running-config

!

vlan internal allocation policy ascending

vlan access-log ratelimit 2000

!

!

interface Port-channel1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,10,11,20-22,30,110,111,120,121,130

switchport mode trunk

!

interface GigabitEthernet1/1

no ip address

switchport

switchport access vlan 70

!

interface GigabitEthernet1/2

no ip address

switchport

switchport access vlan 70

!

interface GigabitEthernet3/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,10,11,20-22,30,110,111,120-122,130,252-254

switchport mode trunk

!

interface GigabitEthernet3/3

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,20-22,120-122

switchport mode trunk

!

interface GigabitEthernet3/4

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,10,11,30,99,110,111,120,130

switchport mode trunk

!

interface GigabitEthernet3/5

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,30,130

switchport mode trunk

!

interface GigabitEthernet3/23

no ip address

switchport

switchport access vlan 70

!

interface GigabitEthernet3/24

no ip address

load-interval 30

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,70,71,99,252-254

switchport mode trunk

!

interface Vlan1

ip address 10.2.200.253 255.255.0.0

ip policy route-map TO_ASA

standby 1 ip 10.2.200.254

standby 1 priority 110

standby 1 preempt

!

interface Vlan2

ip address 10.3.1.11 255.255.255.0

!

interface Vlan10

ip address 10.3.10.2 255.255.255.0

ip helper-address 10.2.200.92

ip policy route-map ASA

standby 10 ip 10.3.10.1

standby 10 priority 200

standby 10 preempt

!

interface Vlan11

description North  Data

ip address 10.3.11.2 255.255.255.0

ip helper-address 10.2.200.92

ip policy route-map ASA

standby 11 ip 10.3.11.1

standby 11 priority 210

standby 11 preempt

!

interface Vlan20

description  Data

ip address 10.3.20.2 255.255.255.0

ip helper-address 10.2.200.92

ip policy route-map ASA

standby 20 ip 10.3.20.1

standby 20 priority 200

standby 20 preempt

!

interface Vlan21

description  Data

ip address 10.3.21.2 255.255.255.0

ip helper-address 10.2.200.92

--More--                            ip policy route-map ASA

standby 21 ip 10.3.21.1

standby 21 priority 210

standby 21 preempt

!

interface Vlan22

description Data Center - Data

ip address 10.3.22.2 255.255.255.0

ip helper-address 10.2.200.92

ip policy route-map ASA

standby 22 ip 10.3.22.1

standby 22 priority 200

standby 22 preempt

!

interface Vlan30

description Training Center - Data

ip address 10.3.30.2 255.255.255.0

ip helper-address 10.2.200.92

standby 30 ip 10.3.30.1

standby 30 priority 200

standby 30 preempt

!

interface Vlan71

description DR Location VLAN

ip address 10.71.0.252 255.255.0.0

!

interface Vlan99

description CR4 - Internet

ip address 10.3.99.2 255.255.255.0

!

interface Vlan110

description South - Voice

ip address 10.3.110.2 255.255.255.0

ip helper-address 10.3.122.10

standby 110 ip 10.3.110.1

standby 110 priority 110

standby 110 preempt

!

interface Vlan111

description North - Voice

ip address 10.3.111.2 255.255.255.0

ip helper-address 10.3.122.10

standby 111 ip 10.3.111.1

standby 111 priority 210

standby 111 preempt

!

interface Vlan120

description  Voice

ip address 10.3.120.2 255.255.255.0

ip helper-address 10.3.122.10

--More--                            standby 120 ip 10.3.120.1

standby 120 priority 200

standby 120 preempt

!

interface Vlan121

description  Voice

ip address 10.3.121.2 255.255.255.0

ip helper-address 10.3.122.10

standby 121 ip 10.3.121.1

standby 121 priority 210

standby 121 preempt

!

interface Vlan122

description  - Voice

ip address 10.3.122.2 255.255.255.0

ip helper-address 10.3.122.10

standby 122 ip 10.3.122.1

standby 122 priority 200

standby 122 preempt

!

interface Vlan130

description  Voice

ip address 10.3.130.2 255.255.255.0

ip helper-address 10.3.122.10

standby 130 ip 10.3.130.1

standby 130 priority 200

standby 130 preempt

!

interface Vlan252

no ip address

!

interface Vlan253

no ip address

!

interface Vlan254

ip address 10.3.254.21 255.255.255.0

!

router eigrp 1

network 10.2.0.0 0.0.255.255

network 10.3.0.0 0.0.255.255

network 10.70.0.0 0.0.255.255

network 10.71.0.0 0.0.255.255

network 10.99.99.0 0.0.0.3

no auto-summary

!

router rip

network 10.0.0.0

no auto-summary

!

ip classless

--More--                           ip route 0.0.0.0 0.0.0.0 10.2.0.247

ip route 10.4.0.0 255.255.0.0 10.2.0.247

ip route 10.5.0.0 255.255.0.0 10.2.0.247

ip route 10.6.0.0 255.255.0.0 10.2.0.247

ip route 10.7.0.0 255.255.0.0 10.2.0.247

ip route 10.8.0.0 255.255.0.0 10.2.0.247

ip route 10.9.0.0 255.255.0.0 10.2.0.247

ip route 10.12.0.0 255.255.0.0 10.2.0.247

ip route 10.13.0.0 255.255.0.0 10.2.0.247

ip route 10.14.0.0 255.255.0.0 10.2.0.247

ip route 10.15.0.0 255.255.0.0 10.2.0.247

ip route 10.16.0.0 255.255.0.0 10.2.0.247

ip route 10.17.0.0 255.255.0.0 10.2.0.247

ip route 10.19.0.0 255.255.0.0 10.2.0.247

ip route 10.21.0.0 255.255.0.0 10.2.0.247

ip route 10.22.0.0 255.255.0.0 10.2.0.247

ip route 10.23.0.0 255.255.0.0 10.2.0.247

ip route 10.24.0.0 255.255.0.0 10.2.0.247

ip route 10.29.0.0 255.255.0.0 10.2.0.247

ip route 10.31.0.0 255.255.0.0 10.2.0.247

ip route 10.33.0.0 255.255.0.0 10.2.0.247

ip route 10.41.0.0 255.255.0.0 10.2.0.247

ip route 10.42.0.0 255.255.0.0 10.2.0.247

ip route 10.43.0.0 255.255.0.0 10.2.0.247

ip route 10.44.0.0 255.255.0.0 10.2.0.247

ip route 10.51.0.0 255.255.0.0 10.2.0.247

ip route 10.133.0.0 255.255.0.0 10.2.0.229

ip route 10.135.0.0 255.255.0.0 10.2.0.229

ip route 10.149.0.0 255.255.0.0 10.2.0.229

ip route 10.150.14.0 255.255.255.0 10.2.0.229

ip route 10.150.16.0 255.255.254.0 10.2.0.229

ip route 10.150.18.0 255.255.255.0 10.2.0.229

ip route 10.150.19.0 255.255.255.0 10.2.0.229

ip route 192.168.5.0 255.255.255.0 10.2.0.229

ip route 192.168.13.0 255.255.255.0 10.2.0.229

ip route 192.168.15.0 255.255.255.0 10.2.0.229

ip route 192.168.17.0 255.255.255.0 10.2.0.229

ip route 192.168.19.0 255.255.255.0 10.2.0.229

ip route 192.168.20.0 255.255.255.0 10.2.0.229

ip route 192.168.27.0 255.255.255.0 10.2.0.229

ip route 192.168.95.117 255.255.255.255 10.2.0.229

ip route 192.168.95.118 255.255.255.255 10.2.0.229

no ip http server

!

!

!

ip access-list extended ASA_ACL

deny   tcp host 10.2.0.5 any eq smtp

--More--                            deny   tcp host 10.2.0.15 any eq smtp

deny   tcp host 10.2.0.17 any eq smtp

deny   tcp host 10.2.0.131 any eq smtp

deny   tcp host 10.2.0.5 any eq www

deny   tcp host 10.2.0.17 any eq www

permit ip 10.2.0.0 0.0.255.255 any

!

logging 10.2.0.55

access-list 115 permit ip 10.3.0.0 0.0.255.255 any

access-list 116 permit ip 10.3.0.0 0.0.255.255 10.1.0.0 0.0.0.255

!

route-map TO_ASA permit 10

match ip address TO_ASA_ACL

set ip default next-hop 10.2.0.229

!

route-map ASA permit 5

match ip address 116

set ip default next-hop 10.2.0.247

!

route-map ASA permit 10

match ip address 115

set ip default next-hop 10.2.0.229

!

!

!

!

dial-peer cor custom

!

!

!

!

!

ntp clock-period 17180079

ntp source Vlan1

ntp update-calendar

ntp server 128.59.59.177

ntp server 17.254.0.26

ntp server 128.118.25.3

end

config for 3750

version 12.2

hostname CR3-SW3750-1

switch 1 provision ws-c3750-48p

switch 2 provision ws-c3750-48p

switch 3 provision ws-c3750-48p

switch 4 provision ws-c3750-48p

switch 5 provision ws-c3750-48p

switch 6 provision ws-c3750-48p

switch 7 provision ws-c3750-48p

switch 8 provision ws-c3750-48p

system mtu routing 1500

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

spanning-tree extend system-id

spanning-tree uplinkfast

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet1/0/1

description Uplink

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,10,11,30,99,110,111,120,130,252-254

switchport mode trunk

!

interface GigabitEthernet1/0/2

--More--                           !

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

i

!

interface GigabitEthernet2/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet2/0/2

!

interface GigabitEthernet2/0/3

!

interface GigabitEthernet2/0/4

!

!

interface GigabitEthernet3/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet3/0/2

!

interface GigabitEthernet3/0/3

!

interface GigabitEthernet3/0/4

!

interface GigabitEthernet4/0/1

!

interface GigabitEthernet4/0/2

!

interface GigabitEthernet4/0/3

!

interface GigabitEthernet4/0/4

!

interface GigabitEthernet5/0/1

!

interface GigabitEthernet5/0/2

!

interface GigabitEthernet5/0/3

!

interface GigabitEthernet5/0/4

!

interface GigabitEthernet6/0/1

description Uplink

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,10,11,30,99,110,111,120,130,252-254

switchport mode trunk

!

interface GigabitEthernet6/0/2

!

interface GigabitEthernet6/0/3

--More--                           !

interface GigabitEthernet6/0/4

!

!

--More--                           interface GigabitEthernet7/0/1

!

interface GigabitEthernet7/0/2

!

interface GigabitEthernet7/0/3

!

interface GigabitEthernet7/0/4

!

interface FastEthernet8/0/29

description ISP 2 INTERNET LINE

switchport access vlan 253

switchport mode access

!

interface FastEthernet8/0/30

description  INTERNET LAN

switchport access vlan 254

switchport mode access

spanning-tree portfast

!

interface FastEthernet8/0/31

description WAN 1 ISP 1

switchport access vlan 252

switchport mode access

spanning-tree portfast

!

interface FastEthernet8/0/32

description WAN 2 ISP 2

switchport access vlan 253

switchport mode access

spanning-tree portfast

!

!

interface GigabitEthernet8/0/1

!

interface GigabitEthernet8/0/2

!

interface GigabitEthernet8/0/3

!

interface GigabitEthernet8/0/4

!

interface Vlan1

description Legacy Network

no ip address

!

interface Vlan2

description Switch Management

ip address 10.3.1.31 255.255.255.0

!

interface Vlan252

no ip address

!

interface Vlan253

no ip address

!

interface Vlan254

ip address 10.3.254.20 255.255.255.0

!

!

router eigrp 1

eigrp stub connected

network 10.3.1.0 0.0.0.255

network 10.3.254.0 0.0.0.255

!

ip default-gateway 10.3.1.11

ip classless

ip route 10.1.3.40 255.255.255.255 10.2.0.229

ip route 10.1.5.254 255.255.255.255 10.2.0.229

ip http server

!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

trouble communicating accross trunk

Has this ever worked? If this is new, I wonder if it was an order of events in the way it was created. The 2 switches should see that subnet as connected, so it's not a routing issue. I would remove the l3 svi and vlan and start over. Create the l2 vlan first, then create your l3 svi and see if you get a different result.

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

8 REPLIES 8
Highlighted
Advisor

trouble communicating accross trunk

Can you post "show int trunk" from both sides?

HTH, John *** Please rate all useful posts ***
Highlighted
Beginner

trouble communicating accross trunk

6503

Port      Mode         Encapsulation  Status        Native vlan

Gi3/1     on           802.1q         trunking      1

Gi3/2     on           802.1q         trunking      1

Gi3/3     on           802.1q         trunking      1

Gi3/4     on           802.1q         trunking      1

Gi3/24    on           802.1q         trunking      1

Port      Vlans allowed on trunk

Gi3/1     1-2,10-11,20-22,30,110-111,120-122,130,252-254

Gi3/2     1-2,22,122

Gi3/3     1-2,20-22,120-122

Gi3/4     1-2,10-11,30,99,110-111,120,130

Gi3/24    1,70-71,99,252-254

Port      Vlans allowed and active in management domain

Gi3/1     1-2,10-11,20-22,30,110-111,120-122,130,254

Gi3/2     1-2,22,122

Gi3/3     1-2,20-22,120-122

Gi3/4     1-2,10-11,30,99,110-111,120,130

Gi3/24    1,70-71,99,254

Port      Vlans in spanning tree forwarding state and not pruned

Gi3/1     1-2,10-11,20-22,30,110-111,120-122,130,254

Gi3/2     1-2,22,122

Gi3/3     1-2,20-22,120-122

Gi3/4     1-2,10-11,30,99,110-111,120,130

Gi3/24    1,70-71,99,254

3750

Gi1/0/1     on               802.1q         trunking      1

Gi2/0/1     on               802.1q         trunking      1

Gi5/0/1     auto             n-802.1q       trunking      1

Gi6/0/1     on               802.1q         trunking      1

Port        Vlans allowed on trunk

Gi1/0/1     1-2,10-11,30,99,110-111,120,130,252-254

Gi2/0/1     1-4094

Gi5/0/1     1-4094

Gi6/0/1     1-2,10-11,30,99,110-111,120,130,252-254

Port        Vlans allowed and active in management domain

Gi1/0/1     1-2,10-11,30,99,110-111,120,130,254

Gi2/0/1     1-2,10-11,20-22,30,70-71,90,99,110-111,120-122,130,254

Gi5/0/1     1-2,10-11,20-22,30,70-71,90,99,110-111,120-122,130,254

Gi6/0/1     1-2,10-11,30,99,110-111,120,130,254

Port        Vlans in spanning tree forwarding state and not pruned

Gi1/0/1     1-2,11,99,111,254

Gi2/0/1     1-2,10-11,20-22,30,70-71,90,99,110-111,120-122,130,254

Gi5/0/1     1-2,10-11,20-22,30,70-71,90,99,110-111,120-122,130,254

Port        Vlans in spanning tree forwarding state and not pruned

Gi6/0/1     10,30,99,110,120,130,254

Highlighted
Advisor

trouble communicating accross trunk

If you specifically source vlan254, does it still not ping?

ping <3750 vlan 254 ip> source vlan254

HTH, John *** Please rate all useful posts ***
Highlighted
Beginner

trouble communicating accross trunk

on each device i can ping their directly connected ip.  but i cant ping each others across the trunk.

Highlighted
Advisor

trouble communicating accross trunk

Can you post "show int vlan 254" from both sides?

HTH, John *** Please rate all useful posts ***
Highlighted
Beginner

trouble communicating accross trunk

6503

Vlan254 is up, line protocol is up

  Hardware is EtherSVI, address is 001c.b0b7.f0c0 (bia 001c.b0b7.f0c0)

  Internet address is 10.3.254.21/24

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 01:41:00, output 00:00:03, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

  L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes

  L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast

  L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicast)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     2272 packets output, 281287 bytes, 0 underruns

     0 output errors, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

3750

Vlan254 is up, line protocol is up

  Hardware is EtherSVI, address is 001f.261e.aec3 (bia 001f.261e.aec3)

  Internet address is 10.3.254.20/24

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 0/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:07, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     2962 packets input, 177720 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     1628 packets output, 136438 bytes, 0 underruns

     0 output errors, 0 interface resets

     0 output buffer failures, 0 output buffers swapped out

Highlighted
Advisor

trouble communicating accross trunk

Has this ever worked? If this is new, I wonder if it was an order of events in the way it was created. The 2 switches should see that subnet as connected, so it's not a routing issue. I would remove the l3 svi and vlan and start over. Create the l2 vlan first, then create your l3 svi and see if you get a different result.

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

Highlighted
Beginner

trouble communicating accross trunk

i havent had a chance to add an ip to the svi yet but i am atleast able to ping across the trunk now.  thank you John.

Content for Community-Ad