cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
476
Views
0
Helpful
5
Replies
BashedRoot
Beginner

Troubleshooting with VLANs, Slow data speed

Hi folks. I have a 3750 as my primary switch to the uplink and sub-switches, 2950s.

 

I have a Dell PE 610 connected on one of the 2950 switches that's crawling on download speeds. Tested by wget on a few Centos mirrors.

 

My output for the VLAN is below

 

Fa0/6                        connected    98         a-full  a-100 10/100BaseTX

 

I tried also speed 100, full duplex, etc. I'm not sure why it's crawling. I'd appreciate help troubleshooting this.

 

Everything else on the 2950 seems ok from what I see.

5 REPLIES 5
Dennis Mink
Advisor

why do you think its the port?  where you downloading from? what else is in the path? is it withing the same subnet?

Please remember to rate useful posts, by clicking on the stars below.

I'm not sure where the culprit it, whether the NIC on the server, the port on the switch.

 

I tried about 10 different Centos.org mirrors from the U.S. All under 1Mbps, despite the switch speed being 100.

 

What should, or would be the optimal settings for a VLAN for performance? For whatever reason, when I put duplex auto, it always shows up as a-full instead?

The way to test it, If you suspect a port issue, is to set up an FTP server and client on the same switch and the same vlan. and see what through put you get when you pump a file across. Meanwhile you will need to do a sh int fax/y and check the 5 minute input or output rate.  

if your port is at 100 full, just should theoretically be able to get close to that speed.

 

if your throughputs are OK in this scenario, you will need to go up into the OSI layer. or perhaps put your FTP client/server each on a separate switch. then go across a Layer 3 boundary etch.

 

 

 

Please remember to rate useful posts, by clicking on the stars below.

Do you know why it shows a-full for duplex instead of auto when I do duplex auto?

 

What would be the optimal setting for duplex on 100mbit uplink?

 

I'm trying another port # to see if it fixes it. Maybe a bad port on the switch.

even though you set a device to for instance auto auto, when you do sh int x/y  it will show what has been negotiated.

 

when you run cisco devices, you can safely leave auto/auto on and it will negootiate the highest possible settings.

 

uplinks, so point to point connections:  will always need to run fullduplex. because you cannot get collisions on a p2p link.

Please remember to rate useful posts, by clicking on the stars below.