cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
5593
Views
0
Helpful
9
Replies
Mark Dayton
Beginner

Trunk between 3560x and Procurve 1820

Hi,

Please can someone help me to figure out why this configuration doesn't work.

As soon as I make port 24 on the HP a member of the trunk setup on the HP pings go down and comms are lost.

Port 22 on the Cisco 3560X is connected to port 24 on the HP 1820.

Trunk 1 config as

Untagged VLAN1 (default)

Tagged VLAN126 (garage)

Tagged VLAN127 (tanks)

Tagged VLAN200 (dmz)

Tagged VLAN1000 (guest)

 

Cisco port 22 config:

interface GigabitEthernet0/22

description Link to HP1820

switchport trunk encapsulation dot1q

switchport mode trunk

Name: Gi0/22
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Rick Morris
Frequent Contributor

Based on the output, you are pruning all the VLANS.

If you need to communicate on those vlans, across the trunk, then you will need to add those vlans to the trunk.

View solution in original post

9 REPLIES 9
Deepak Kumar
VIP Advocate

Hi,

Please configure HP Trunk as:

!

VLAN 1

Untagged 22

!

VLAN 126

Tagged 22

!

VLAN 127

Tagged 22

!

VLAN 200

Tagged 22

!

VLAN 1000

Tagged 22

And Configure Cisco Switch trunk as:

interface GigabitEthernet0/22

description Link to HP1820

switchport trunk encapsulation dot1q

switchport mode trunk

Regards,

Deepak Kumar

www.deepuverma.in

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

Deepak that is exactly how i have this configured. As soon as i attach the trunk to the port we lose all comms. I left it for about 30 seconds and it didnt come live.

Just to expand on this, we use VLAN1 as the management vlan on subnet 192.168.128.0/24

The Cisco has an IP of 192.168.128.3 and the Procurve has an IP of 192.168.128.86.

When we make the HP a member of the trunk I can no longer ping 192.168.128.86

Rajeev Sharma
Cisco Employee

Hey Mark,

Does the port comes up after link is connected and configuration is applied?

Regards,

RS.

Hozaifa Samad
Beginner

Hey Mark,

Have you tried adding the allowed statement on you Cisco interface?

"switchport trunk allowed vlan 126,127,200,1000"

Also make sure you do not have LACP running on the HP as it has an auto aggregation feature.

"interface 24 no lacp"

Hi Hozaifa,

There is no CLI on the 1820 but the trunk is setup as Static not Dynamic not should not use LACP

Dynamic—Dynamic trunks use the Link Aggregation Control Protocol (LACP, IEEE
standard 802.3ad). An LACP-enabled port automatically detects the presence of other
aggregation-capable network devices in the system and exchanges Link Aggregation Control
Protocol Data Units (LACPDUs) with links in the trunk. The PDUs contain information about
each link and enable the trunk to maintain them.
Static—Static trunks are assigned to a bundle by the administrator. Members do not exchange
LACPDUs. A static trunk does not require a partner system to be able to aggregate its member
ports. This is the default port type
I have also tried the following commands on port 22 on the Cisco, although the commands are accepted when I re-check the config the commands are not listed under port 22.
switchport trunk native vlan 1
switchport trunk allowed vlan add 126,127,200,1000
Thanks
Rick Morris
Frequent Contributor

Based on the output, you are pruning all the VLANS.

If you need to communicate on those vlans, across the trunk, then you will need to add those vlans to the trunk.

View solution in original post

Thanks, all working now. I must have got mistaken and thought that vlan 1 needed to be untagged to act as native vlan. Tagged ALL the vlans on the trunk now and works perfectly.

I am have similar issue. HP 2610 Procurve connected to cisco c3560. The DHCP server is connected to the cisco switch, all vlans on the cisco switch get correct IP addresses from the DHCP pools(scopes) and internet access . The HP switch is connected from port 25 to port 48 on the cisco.  The HP's  port 25 and Cisco port 48 are both are untagged in vlan 1(default vlan). I am able to get DHCP and internet access from the ports on thhe HP only untagged for VLAN1, however i can not IP address or Internet for the ports untagged to other VLANS on HP switch. No sure what i am missing. I can ping the HP switch from Cisco and vice versa.I can also  ping the DHCP from the HP switch. below is my config on HP switch. please let me what i am missing. 

Startup configuration:

; J9087A Configuration Editor; Created on release #R.11.72

hostname "mose"
time timezone -360
time daylight-time-rule Continental-US-and-Canada
mirror-port 6
ip default-gateway 10.76.0.2
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "kenya"
untagged 1-26
ip address 10.76.0.3 255.255.255.0
ip helper-address 10.76.12.15
tagged 27-28
exit
vlan 12
name "Servers"
ip address 10.76.12.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 200
name "ArubaAP"
ip address 10.76.200.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 100
name "HP530AP"
ip address 10.76.100.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 50
name "Wired_Clients"
ip address 10.76.50.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 28
name "Printers"
ip address 10.76.28.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 27-28
exit
ip route 10.76.12.0 255.255.255.0 10.76.0.2
ip route 10.76.50.0 255.255.255.0 10.76.0.2
ip route 10.76.100.0 255.255.255.0 10.76.0.2
ip route 10.76.200.0 255.255.255.0 10.76.0.2
ip ssh
password manager
password operator

 cisco switch


CISCO3560>enable
Password:
CISCO3560#show conf
Using 4784 out of 524288 bytes
!
! Last configuration change at 02:49:38 CST Thu Jan 25 2018
! NVRAM config last updated at 02:49:46 CST Thu Jan 25 2018
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname CISCO3560
!
enable secret 5 $1$dkVB$yAcic9FxTI7m7VtX2Ojdo1
enable password 7 022B24490A0D06701D
!
username Ntabo privilege 15 secret 5 $1$4YYh$BIcKFe9H0PLVQKQBBTjhO1
no aaa new-model
clock timezone CST -6
clock summer-time CDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
no ip subnet-zero
ip routing
!
ip ssh version 2
!
!
crypto pki trustpoint TP-self-signed-2826797568
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2826797568
revocation-check none
rsakeypair TP-self-signed-2826797568
!
!
crypto ca certificate chain TP-self-signed-2826797568
certificate self-signed 01 nvram:CISCO3560ras#6C01.cer
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
interface FastEthernet0/1
speed 100
!
interface FastEthernet0/2
switchport access vlan 12
speed 100
!
interface FastEthernet0/3
switchport access vlan 12
!
interface FastEthernet0/4
switchport access vlan 12
speed 100
!
interface FastEthernet0/5
switchport access vlan 12
!
interface FastEthernet0/6
switchport access vlan 12
!
interface FastEthernet0/7
switchport access vlan 12
!
interface FastEthernet0/8
switchport access vlan 12
!
interface FastEthernet0/9
switchport access vlan 12
!
interface FastEthernet0/10
switchport access vlan 12
!
interface FastEthernet0/11
switchport access vlan 50
!
interface FastEthernet0/12
switchport access vlan 50
!
interface FastEthernet0/13
switchport access vlan 50
!
interface FastEthernet0/14
switchport access vlan 50
!
interface FastEthernet0/15
switchport access vlan 50
!
interface FastEthernet0/16
switchport access vlan 50
!
interface FastEthernet0/17
switchport access vlan 50
!
interface FastEthernet0/18
switchport access vlan 50
!
interface FastEthernet0/19
switchport access vlan 50
!
interface FastEthernet0/20
switchport access vlan 50
!
interface FastEthernet0/21
power inline static
switchport access vlan 100
switchport mode access
speed 100
!
interface FastEthernet0/22
switchport access vlan 100
!
interface FastEthernet0/23
switchport access vlan 100
!
interface FastEthernet0/24
switchport access vlan 100
!
interface FastEthernet0/25
switchport access vlan 100
!
interface FastEthernet0/26
switchport access vlan 100
!
interface FastEthernet0/27
switchport access vlan 100
!
interface FastEthernet0/28
switchport access vlan 100
!
interface FastEthernet0/29
switchport access vlan 100
!
interface FastEthernet0/30
switchport access vlan 100
!
interface FastEthernet0/31
switchport access vlan 200
speed 100
!
interface FastEthernet0/32
switchport access vlan 200
!
interface FastEthernet0/33
switchport access vlan 200
!
interface FastEthernet0/34
switchport access vlan 200
!
interface FastEthernet0/35
switchport access vlan 200
!
interface FastEthernet0/36
switchport access vlan 200
!
interface FastEthernet0/37
switchport access vlan 200
!
interface FastEthernet0/38
switchport access vlan 200
!
interface FastEthernet0/39
switchport access vlan 200
!
interface FastEthernet0/40
switchport access vlan 200
!
interface FastEthernet0/41
switchport access vlan 28
!
interface FastEthernet0/42
switchport access vlan 28
!
interface FastEthernet0/43
switchport access vlan 28
!
interface FastEthernet0/44
switchport access vlan 28
!
interface FastEthernet0/45
switchport access vlan 28
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
ip address 10.76.0.2 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan12
ip address 10.76.12.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan28
ip address 10.76.28.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan50
ip address 10.76.50.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan100
ip address 10.76.100.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan200
ip address 10.76.200.1 255.255.255.0
ip helper-address 10.76.12.15
!
ip default-gateway 10.76.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.76.0.1
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 30 0
logging synchronous
line vty 0 4
password 7 013E090F4E2B5756781B0F
no login
transport input telnet ssh
line vty 5 15
password 7 12340A1C072B5D5D737C65
no login
!
ntp clock-period 36029530
ntp server 128.138.140.44
!
end

CISCO3560#