cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
155
Views
0
Helpful
8
Replies
Highlighted
Beginner

Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

Hi,

I am trying to connect a 9200 switch stack to our existing 3850 core switch via fiber. I have no idea why, but I am unable to get this to work; I'm getting no blinking lights on either end of the connection.

I am using a 1GB GLC-SX-MMD at both ends of the connection; the 3850 end is connected to GigabitEthernet1/1/2 and the 9200 is connected to TenGigabitEthernet 1/1/1.

 

I've had the fiber cable checked and it all works fine (SFP ports too) so I'm baffled as to why I cannot get it to work, though it did work when I directly connected the stack master to the 3850.

The configuration on both ports is:

switchport trunk native vlan 105
switchport mode trunk


The transceivers are fine and are detected by both switches and there is nothing else physically wrong so it seems to be a configuration error but I have no idea what.

 

I don't know where to go next and am very frustrated as to why it's not working. 

If anyone can give me some pointers it would be appreciated :)

 

8 REPLIES 8
VIP Mentor

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

Hello,

 

are both interfaces up/up ? Try and swap the transmit/receive ends at one side of the connection (pull the fiber cable out of the transceiver and reinsert it with the tx/rx connectors swapped)...

VIP Advisor

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

We need more information - when you mentioned not working is that show down/down ?

or any other error ?

 

make sure you have created VLAN 105 in the Vlan database.

 

please post 

below output to understand the issue

 

show inter GigabitEthernet1/1/2

show inter tenGigabitEthernet 1/1/1

 

show run inter tenGigabitEthernet 1/1/1

show run GigabitEthernet 1/1/2

show vlan

 

 

BB
*** Rate All Helpful Responses ***
Hall of Fame Guru

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

Let me ask the most-basic of all question: What firmware are both switches running?
Enthusiast

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

Are you configuring the Tengig1/1/1 port instead of the Gig1/1/1 port.

I think in the Catalyst 9200, if you use the Tengig1/1/1 port with 1G SFP you have enable and add the configs under Gig 1/1/1 interface.

Let me know how it goes
Beginner

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

Hi all. Apologies for the late response. So I have done some more troubleshooting and the fiber is fine when only one 9200 switch is connected. The moment I added the member switch to the 9200 stack, the connection stopped working.

I now seem to be having difficulty getting the 9200 stack to work. Both stack members have the Cisco IOS XE Software, Version 16.09.03 (Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 16.9.3

 

What I did was I connected the stack master to ensure, powered off the member switch, provisioned the member switch, powered on the member switch.

When I do a 'sh ip int brief' it returns the list of ports for both switches, but when I do a 'show switch' I get the following for the member switch:

 

Switch        Role            Mac Address            Priority    H/W version     Current State
  2            Member         0000.0000.0000         0                                    Provisioned

 

I've done a bit of research but have been unable to find anything. Is it a software version issue? Or have I done the steps incorrectly? Appreciate the help as always.

 

 

 

Hall of Fame Expert

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

Hello pinko,

something is not working as the second member is unknown so there is not communication between members.

How have you built the C9200 stack?

are you using the stackwise cables?

what models are you using?

The fixed configuration C9200L support stackwise 80 the C9200 support stackwise 160

see the table in the link below

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9200/hardware/install/b-c9200-hig/b-c9200l-hig_chapter_01.html

 

release notes are here

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9200/software/release/16-10/release_notes/ol-16-10-9200.html?dtid=osscdc000283#concept_lmr_yb1_r2b

 

Hope to help

Giuseppe

 

VIP Advisor

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

adding to other post can you post show switch, also give us more information how you have configured this Switch stack.

 

as per provisioned means :

 

Provisioned

Ports are assigned in the stack running-configuration, but no switch with the port numbers Fa3/0/1, G3/0/1, and so on, is detected in the stack. If a switch that previously joined a stack is removed, the port numbers remain in the running-configuration, and the missing switch is shown as Provisioned.

The Provisioned state might be caused by a switch that is no longer connected to the stack or be the result of manually preprovisioning the related ports. 

BB
*** Rate All Helpful Responses ***
Hall of Fame Guru

Re: Trunk Not Working Between Cisco 9200 and Cisco 3850 SFP Ports

CSCvi56567

CreatePlease to create content
Content for Community-Ad