cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

943
Views
0
Helpful
9
Replies
Highlighted
Beginner

Tunnel latency on 3560

Hi all,

I need to establish a tunnel between 2 Routers / switch

For the test, I've established a tunnel between 2 3560 switches (3560-ipservicesk9-mz.122-55.SE.bin)

Here's the config

SW1 :

interface Tunnel0

description tunnel vers OTT

ip address 10.0.0.2 255.255.255.252

tunnel source Vlan1

tunnel destination 192.168.6.13

tunnel mode ipip

interface Vlan1

ip address 192.168.6.6 255.255.255.0

interface Vlan190

ip address 192.168.190.2 255.255.255.0ip route 192.168.0.0 255.255.128.0 192.168.6.1

ip route 192.168.195.0 255.255.255.0 Tunnel0

SW2 :

interface Tunnel0

description tunnel vers STE

ip address 10.0.0.1 255.255.255.252

tunnel source Vlan1

tunnel destination 192.168.6.6

tunnel mode ipip

interface Vlan1

ip address 192.168.6.13 255.255.255.0

interface Vlan195

ip address 192.168.195.1 255.255.255.0

ip route 192.168.0.0 255.255.128.0 192.168.6.1

ip route 192.168.190.0 255.255.255.0 Tunnel0

The problem:

I made 3500 pings:

min/avg/max/mdev = 0.864/3.245/174.494/6.263

the timevalue of the ping isn't regular at all....

a ftp transfer may be at 5Mb or 50Mb

-> not stable

any idea ?

Everyone's tags (3)
9 REPLIES 9
Highlighted
Engager

Re: Tunnel latency on 3560

The icmp ping process involves (a lot of) processor tasks which do not get constant priority.

It is therefore not a good method to test round-trip-times for other protocols.

Also, the first reply typicaly takes longer because the arp-cache has to be built.

After that, the variation of delay's is a lot less.

If want to test ftp transfer, you should rather connect two ftp machines to your testbench.

This will provide a more constant response and delay for your traffic.

regards,

Leo

Highlighted
Beginner

Re: Tunnel latency on 3560

Ok, thanks for the quick answer, I didn't know about icmp traffic.

At the origin, my test was by ftp, and I got strange behavior :

Sometimes, transfer speed at 10.5 MB, sometimes 1.5MB and lot of times between these two.

So I made the test ping.

Highlighted
Beginner

Re: Tunnel latency on 3560

Are the 2 switches directly connected? Where the testing machines patched directly to the switches? Could there have been any other traffic on these switches that might have affected your testing?

icmp can as mentioned above in the thread give bad/strange responses, especially when talking about network equipment. Because when you ping a switch/router that needs to be handles by the CPU. But traffic passing through the device is mostly handled in the hardware.

Highlighted
Beginner

Re: Tunnel latency on 3560

yes,

3 switch directly connected,

2 macines each one on its switch

and the problem stays with ftp

thanks

Highlighted
Cisco Employee

Re: Tunnel latency on 3560

GRE and IPIP tunnels on the 3560 switch are only supported in software so the traffic is CPU switched which greatly rate limits the speed of the transfer.  This is a hardware limitation with those 3560 and 3750 switches.

-Matt

Highlighted
Beginner

Re: Tunnel latency on 3560

Ok,

So it is normal...

Any others idea for interconnect 2 remote sites with VLAN and cisco telephony on the main site ?

The ISP who interconnect my sites can route only 1 type of address (10.110.X.X) and my sites are in 192.168.X.X

Highlighted
Cisco Employee

Re: Tunnel latency on 3560

You could create a point-to-point l3 vlan using a 10.110.x.x subnet between the two sites and route between them.  Do you have to have layer 2 connectivity between the sites?

-Matt

Highlighted
Beginner

Re: Tunnel latency on 3560

Hello,

I don't realy know what a point-to-point l3 vlan is.

Could you give me an example ?

Thanks

Highlighted
Beginner

Re: Tunnel latency on 3560

Hi,

If you mean setting an IP like 10.110.59.2/24 to a router and 10.110.63.2 to another and define the route between each other, it's what I've test first.

The problem is than the source IP in the packet stays 192.168.X.X so the packet is dropped by the ISP; so I need SNAT and DNAT.

thanks

CreatePlease to create content
Content for Community-Ad