cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1819
Views
0
Helpful
11
Replies
Beginner

UDLD err-disable on copper wire

Hi,

I have a problem between two switches with etherchannel configured:

  Model number                    : WS-C2960S-24TS-L

  System image file is "flash:/c2960s-universalk9-mz.122-58.SE2/c2960s-universalk9-mz.122-58.SE2.bin"

  Gi1/0/23  ETH-CH_1_SW-EDGE01 err-disabled trunk        auto   auto 10/100/1000BaseTX

  Gi1/0/24  ETH-CH_2_SW-EDGE01 connected    trunk      a-full a-1000 10/100/1000BaseTX

  Po1       Trunk_SW-EDGE01    connected    trunk      a-full a-1000

  Gi1/0/23  ETH-CH_1_SW-EDGE02 notconnect   trunk        auto   auto 10/100/1000BaseTX

  Gi1/0/24  ETH-CH_2_SW-EDGE02 connected    trunk      a-full a-1000 10/100/1000BaseTX

  Po1       Trunk_SW-EDGE02    connected    trunk      a-full a-1000

sw-edge02#sh int status err-disabled

Port      Name               Status       Reason               Err-disabled Vlans

Gi1/0/23  ETH-CH_1_SW-EDGE-0 err-disabled udld

interface Port-channel1

description Trunk_SW-EDGE01

switchport trunk native vlan 999

switchport trunk allowed vlan 1-299,301-4094

switchport mode trunk

switchport nonegotiate

no keepalive

spanning-tree link-type point-to-point

spanning-tree vlan 1-4094 port-priority 0

end

interface GigabitEthernet1/0/23

description ETH-CH_1_SW-EDGE-01

switchport trunk native vlan 999

switchport trunk allowed vlan 1-299,301-4094

switchport mode trunk

switchport nonegotiate

spanning-tree vlan 1-4094 port-priority 0

channel-group 1 mode on

end

interface GigabitEthernet1/0/24

description ETH-CH_2_SW-EDGE-01

switchport trunk native vlan 999

switchport trunk allowed vlan 1-299,301-4094

switchport mode trunk

switchport nonegotiate

udld port disable

spanning-tree vlan 1-4094 port-priority 0

channel-group 1 mode on

end

interface Port-channel1

description Trunk_SW-EDGE02

switchport trunk native vlan 999

switchport trunk allowed vlan 1-299,301-4094

switchport mode trunk

switchport nonegotiate

no keepalive

spanning-tree link-type point-to-point

spanning-tree vlan 1-4094 port-priority 0

end

interface GigabitEthernet1/0/23

description ETH-CH_1_SW-EDGE02

switchport trunk native vlan 999

switchport trunk allowed vlan 1-299,301-4094

switchport mode trunk

switchport nonegotiate

spanning-tree vlan 1-4094 port-priority 0

channel-group 1 mode on

end

interface GigabitEthernet1/0/24

description ETH-CH_2_SW-EDGE02

switchport trunk native vlan 999

switchport trunk allowed vlan 1-299,301-4094

switchport mode trunk

switchport nonegotiate

spanning-tree vlan 1-4094 port-priority 0

channel-group 1 mode on

end

I allready change the wire without success, and allreday restart sw-edge02.

With "udld port disable" the link is working correctly.

Do you have an idea ? (I allready read this thread https://supportforums.cisco.com/message/3787690#3787690).

Best regards.

PD:

I have two anothers switchs working with SFP Cable:

Gi0/25    ETH-CH_1_SW-CORE02 connected    trunk      a-full a-1000 1000BaseCX SFP Cable

Gi0/27    ETH-CH_2_SW-CORE02 connected    trunk      a-full a-1000 1000BaseCX SFP Cable

Po1       Trunk_SW-CORE02    connected    trunk      a-full a-1000

Model number                    : WS-C3560G-24TS-S

System image file is "flash:c3560-ipbase-mz.122-50.SE1/c3560-ipbase-mz.122-50.SE1.bin"

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Community Legend

UDLD err-disable on copper wire

UDLD in copper, works marvelously -- when it works.  But when it doesn't, the port goes into err-disable more than a fibre optic port.  Hence, the main reason why UDLD for copper lines don't work.


If you and everyone else is fine, then go-ahead.  I'm just speaking based from my experience. 

11 REPLIES 11
Rising star

UDLD err-disable on copper wire

take udld err disable out of the configs. its for fiber only.

Cisco Employee

UDLD err-disable on copper wire

Vmiller,

Tough UDLD is designed for fiber , but it also works fine with copper.

It detects the ports failure on errdisable it. (I.e Mean to say one side is up and other side is down) the UDLD detects on copper as well.

HTH

Regards

Inayath

Hall of Fame Community Legend

UDLD err-disable on copper wire

Hi Inayath,

While I agree that UDLD is supported for copper and fibre, I have seen the side-effects of configuring UDLD on copper ports several times that I've learned to avoid it like a plague.

Hall of Fame Community Legend

UDLD err-disable on copper wire

Never, under any circumstances, enable UDLD on a copper link.

What you are seeing is the very reason why.

Cisco Employee

UDLD err-disable on copper wire

Leo.... PM.

Hall of Fame Community Legend

UDLD err-disable on copper wire

Hi Inayath,

PM received.  Replied. 

Beginner

Re: UDLD err-disable on copper wire

Hi,

Thanks you all for the answer.

I used to suffer a problem in a switch port years ago, the switch was only sent packet without receive any packet. (was not a wired problem). At this time we only choose to not use this port anymore.

In my mind the udld was the solution for this problem.

I read what UDLD was not necessary in copper wire because negociation already do the job, but for the etherchannel I use "switchport nonegotiate", and I would like be able to detect a cable problem.

For etherchannel do you use "switchport nonegotiate" ?

Do you really think desactivate the udld is the only solution ? (Someone know why is not working as excepted?).

Thought this config has working some time at the beginning, (before the first reboot).

Best regards

Highlighted
Hall of Fame Community Legend

UDLD err-disable on copper wire

UDLD in copper, works marvelously -- when it works.  But when it doesn't, the port goes into err-disable more than a fibre optic port.  Hence, the main reason why UDLD for copper lines don't work.


If you and everyone else is fine, then go-ahead.  I'm just speaking based from my experience. 

Beginner

Re: UDLD err-disable on copper wire

Thanks for you answer.

Not really like it, but if it's not working, not working, anyone already open a ticket to cisco about this ?

Cisco Employee

Re: UDLD err-disable on copper wire

Vincent,

ere are some keep things to remembers

-UDLD is disabled globally and enabled in readiness on fiber ports by default.

-Because UDLD is an infrastructure protocol that is necessary between switches only, UDLD

is disabled by default on copper ports. Copper ports tend to be used for host access.

-You can enable UDLD globally for all fiber ports or on a port-by-port basis. A port

configuration overrides the global configuration parameter.

Ref UDLD enabling on the Copper: http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/udld.html

Please go through the link above as it will clear the doubt.

I hope this clears up the confusion

Regards

Inayath

Hall of Fame Community Legend

UDLD err-disable on copper wire

anyone already open a ticket to cisco about this

You mean report what you are seeing as a bug?  I don't think so.  UDLD is working, hence your ports went into error-disable.

Could you shed some light as to why you want to enable UDLD on you copper link? 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards