cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

282
Views
10
Helpful
15
Replies
Beginner

unable to connecting two switches on different network

I am linking two different network layer 3 switches, I have made "ip routing" to link different vlans.

the ports connecting two switches i made to work as trunk, also tried to make same vlans on both switches and added the connecting port to same vlan but unable to ping them.

when I run cdp neibhours, it shows switch with domain name but no more details shown.Below are highlights of configuration..

 

DSL_Swtich#ping 150.1.3.1 (another switch 3650)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.3.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
DSL_Swtich#
DSL_Swtich#
DSL_Swtich#ping 150.1.3.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.3.1, timeout is 2 seconds:
....
Success rate is 0 percent (0/4)
DSL_Swtich#show cdp nei
DSL_Swtich#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
Manar_HQ.manarhq.com
Gig 1/0/47 138 R S I WS-C3650- Gig 2/0/28
SERVER-SW Gig 1/0/46 128 S I WS-C2960X Gig 1/0/44
DSL_Swtich#

Capture.PNG

another switch side is :

pinging server switch 

Capture 2.PNG

Kindly assist what show i make configuration to connect both swtich ping each other..

regards
Jawad

Everyone's tags (1)
2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Advisor

Re: unable to connecting two switches on different network

Hello

As I have stated previously you need to make some changes to you current setup to make this work correctly.
Note..the assumption here is all subnets are /24 address ranges

Sw1

int x/x
Description ports link connecting switch2
swutchport mode access
switchport access vlan 70

 

 

ip route 192.168.10.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.20.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.30.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.40.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.50.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.60.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.1.0 .255.255.255.0 vlan 70 150.1.3.1


Sw2

int x/x
Description ports link connecting switch 1
swutchport mode access
switchport access vlan 70

 

ip route 172.16.0.0 .255.255.255.0 vlan 70 150.1.3.2
ip route 192.168.100.0 .255.255.255.0 vlan 70 150.1.3.2
ip route 192.168.200.0 .255.255.255.0 vlan 70 150.1.3.2
ip route 192.168.250.0 .255.255.255.0 vlan 70 150.1.3.2

 

 

Lastly you need your pc and server to have ip addressing allocated to them from any of the vlans that reside on the switch they are connected with the correct subnet masks and default gateways of the L3 interface of the vlan its assigned to as presently they dont relate to any vlan you have defined



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: unable to connecting two switches on different network

I am thankful to all of you.

 

I want to add some info for the future visitor that:

1. I make manual route to 2nd network by adding route add in PC/Server to 150.1.x.x 

2. If I make route from switch to switch for whole network it will create traffic load as many clients don't need to forward on another network. ( to save unsual network traffic)

It means the network was approx ready remaining routing between VLANS...

 

I am again thankful to everyone.....

15 REPLIES 15
VIP Mentor

Re: unable to connecting two switches on different network

Hello,

 

post the full configurations of both switches...

VIP Mentor

Re: unable to connecting two switches on different network

Hello,

 

both of the below should work:

 

3650_1

--

ip routing

!

interface GigabitEthernet0/0

switchport mode access

switchport access vlan 150

spanning-tree portfast

!

interface Vlan150

ip address 150.1.3.1 255.255.255.0

 

3650_2

--

ip routing

!

interface GigabitEthernet0/0

switchport mode access

switchport access vlan 150

spanning-tree portfast

!

interface Vlan150

ip address 150.1.3.2 255.255.255.0

 

----------------------------

 

3650_1

--

ip routing

!

interface GigabitEthernet0/0

switchport mode trunk

spanning-tree portfast edge

!

interface Vlan150

ip address 150.1.3.1 255.255.255.0

 

3650_2

--

ip routing

!

interface GigabitEthernet0/0

switchport mode trunk

spanning-tree portfast edge

!

interface Vlan150

ip address 150.1.3.2 255.255.255.0

Beginner

Re: unable to connecting two switches on different network

dear @Georg Pauwen .

the subnet you mentioned we r not using i.e 255.255.255.0, we are on /16 subnet 255.255.0.0

the second thing is I have made the same configuration both are trunk and in same vlans.spanning tree i did not make.

Ip routing is also working on both sides.


what is the reason if i run spanning tree?

tell me the commands for which u need the configurations?

thanks in advance..

VIP Mentor

Re: unable to connecting two switches on different network

Hello,

 

is this a lab or are these real switches ? Typically for a switch to switch connection, you would need a cross cable...

VIP Advisor

Re: unable to connecting two switches on different network

Hello


@Georg Pauwen wrote:

is this a lab or are these real switches ? Typically for a switch to switch connection, you would need a cross cable...


 

This is true for very old switches, but for a long time mosts switch have been MDIX compatible so a straight through cable should work fine with the switches noticing the cable pins and change accordingly



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Enthusiast

Re: unable to connecting two switches on different network

 

what do u have  configured on SVI ? 150.1.3.1 should be set on SVI interface, like interface vlan x ip add 150.1.3.1 xxxx no shut 

 

the other side should have SVI in the same vlan X, and both SVI must be UP UP. 

vlan x should be in database and be allowed on the trunk

 

check SVIs , check trunks allow vlan x, check vlan database foir vlan x 

Beginner

Re: unable to connecting two switches on different network

Dear @MartinLo 

Both svi's are working and interface and protocol are up..

Trunks are allowed on both ports and vlan are same too.

In VLAN database both are showing fine..

:(

VIP Advisor

Re: unable to connecting two switches on different network

Hello

You still need to tell each switch(router) how to get to the other vlans (subnets), either via and IGP or static routes and they must be sharing a common subnet for connectivity.

 

Example:
Sw1

interface Vlan3
ip address 3.3.3.3 255.255.255.0

interface Vlan5
ip address 5.5.5.5 255.255.255.0

 

interface Vlan12
ip address 10.1.12.1 255.255.255.0

ip route 2.2.2.0 255.255.255.0 Vlan12 10.1.12.2
ip route 4.4.4.0 255.255.255.0 Vlan12 10.1.12.2

vlan3,5,12


interface FastEthernet0/19
description link to sw2
switchport access vlan 12
switchport mode access
spanning-tree portfast

Sw2

interface Vlan2
ip address 2.2.2.254 255.255.255.0

interface Vlan4
ip address 4.4.4.254 255.255.255.0

interface Vlan12
ip address 10.1.12.2 255.255.255.0

ip route 3.3.3.0 255.255.255.0 Vlan12 10.1.12.1
ip route 5.5.5.0 255.255.255.0 Vlan12 10.1.12.1

vlan2,4,12


interface FastEthernet0/19
description link to sw1
switchport access vlan 12
switchport mode access
spanning-tree portfast



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: unable to connecting two switches on different network

Dear @paul driver 

Did you mean to say IP Default gateway on both sides
i cant make this because ISP routers are connected on these switches and i m afraid if internet will stop,,

 

VIP Advisor

Re: unable to connecting two switches on different network

Hello

No ,you will have ip routing enabled on both switches.

 

The two switchs will have common vlan shared between them - in my example its vlan 12 and then the port interconnecting the two switchs will be an access port in vlan 12.

The on either switch you will have the l2/l3 vlans again in my example :

Sw1 - vlan 3-5
Sw2 - vlan 2-4

Lastly you will to populate the routing tables of both switches to allow bidirectional communication, in my example i have used static routes pointing to the share vlan which is vlan 12

Sw1
ip route 2.2.2.0 255.255.255.0 vlan 12 10.1.12.2
ip route 4.4.4.0 255.255.255.0 vlan 12 10.1.12.2

Sw2
ip route 3.3.3.0 255.255.255.0 vlan 12 10.1.12.1
ip route 5.5.5.0 255.255.255.0 vlan 12 10.1.12.1

Thats it...

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: unable to connecting two switches on different network

How will be the command i should run on switches
NOTE: I am working on physical switches and both support AUTO MDIX..

 

network 1

vlan 172   IP address 172.16.0.53 255.255.0.0  (Local Network)

vlan 70     IP address 150.1.3.2 255.255.0.0 (remote network)

port for remote network is trunk and included in vlan 70

 

 

network 2

vlan 70    IP address 150.1.3.1 255.255.0.0 (on another network using as SVI)

 

both ips are working and pinging now

from DSL_Switch i can ping all ip's on another network 150's ip but from client side i cant even ping swtich's SVI ip?

 

if you need configuration i can provide. tell me what info you need more..

also assist how i will make ip route between these network?

 

best regards

VIP Advisor

Re: unable to connecting two switches on different network

Hello

FYI- the example I provided was for two switchs physically interconnected between each other both with ip routing and different l3 subnets

 

Just so no confusion is being made here - Can you post the topology of you network and the current configuration of both switches please.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: unable to connecting two switches on different network

hello, below are details of both network

Network 1

 

4.1.PNG

 

4.PNG

 

 

Network 2

 

1.PNG2.2.PNG2.PNG

Vlan 150 is not in use and nothing is associated with that LAN.

 

Topology

 

topology.PNG

I can ping from switch to switch any ip but from client to switch or client to another remote client is unsuccessful.

VIP Advisor

Re: unable to connecting two switches on different network

Hello

As I have stated previously you need to make some changes to you current setup to make this work correctly.
Note..the assumption here is all subnets are /24 address ranges

Sw1

int x/x
Description ports link connecting switch2
swutchport mode access
switchport access vlan 70

 

 

ip route 192.168.10.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.20.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.30.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.40.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.50.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.60.0 .255.255.255.0 vlan 70 150.1.3.1
ip route 192.168.1.0 .255.255.255.0 vlan 70 150.1.3.1


Sw2

int x/x
Description ports link connecting switch 1
swutchport mode access
switchport access vlan 70

 

ip route 172.16.0.0 .255.255.255.0 vlan 70 150.1.3.2
ip route 192.168.100.0 .255.255.255.0 vlan 70 150.1.3.2
ip route 192.168.200.0 .255.255.255.0 vlan 70 150.1.3.2
ip route 192.168.250.0 .255.255.255.0 vlan 70 150.1.3.2

 

 

Lastly you need your pc and server to have ip addressing allocated to them from any of the vlans that reside on the switch they are connected with the correct subnet masks and default gateways of the L3 interface of the vlan its assigned to as presently they dont relate to any vlan you have defined



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards