cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Community

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


1108
Views
0
Helpful
11
Replies
Highlighted
Beginner

Unable to Ping brand new 9300

I ave a brand new 9300 with very little configuration on it.  When I get new switches I give them a bogus IP, configure a trunk port, and connect them to my network.  Once I have connectivity I use VTP, and begin configuring the switch.  

 

I did that with my 9300 and it will not connect up (no Ping).  What am I missing?

 

Interface VLan1 has valid ip and subnet mask, and is enabled.  Port is set for trunk.

 

I'm stumped.  This should be simple!

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Expert

Re: Unable to Ping brand new 9300

Does that help clear things?  

Yes, very helpful.

Can you make sure vlan 1 is up and running?

sh int vlan 1 or sh ip int brief vlan1

your ip on the 9300 switch is 10.1.0.223/24 What is the IP on the core you are trying to ping?

Can you try pinging the core IP and source it from vlan1

ping x.x.x.x source vlan1

 

Can you post the port config on the core where the 9300 is connected?

HTH

11 REPLIES
VIP Expert

Re: Unable to Ping brand new 9300

Can you post "sh run" and point out the ports you are using?

HTH

Beginner

Re: Unable to Ping brand new 9300

Here is the sho run with some minor things redacted...I've been plugged into gi 2/0/24

 

 

Current configuration : 6529 bytes

!

! Last configuration change at 14:34:57 UTC Tue Apr 3 2018 by admin

!

version 16.6

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no platform punt-keepalive disable-kernel-core

!

hostname Servers_9300

!

!

vrf definition Mgmt-vrf

 !

 address-family ipv4

 exit-address-family

 !

 address-family ipv6

 exit-address-family

!

no logging console

!

no aaa new-model

switch 1 provision c9300-24t

switch 2 provision c9300-24t

!

!ip domain name xx.xxxx.xxx.xxx

!

!cpp system-default

!

!

diagnostic bootup level minimal

spanning-tree mode rapid-pvst

spanning-tree extend system-id

!

username xxxxx privilege 15 secret 5 xxxxxxxxxxxxxxx

!

redundancy

 mode sso

!

!

!

class-map match-any system-cpp-police-topology-control

  description Topology control

class-map match-any system-cpp-police-sw-forward

  description Sw forwarding, L2 LVX data, LOGGING

class-map match-any system-cpp-default

  description DHCP Snooping, EWLC control, EWCL data

class-map match-any system-cpp-police-sys-data

  description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, Gold Pkt, RPF Failed

class-map match-any system-cpp-police-punt-webauth

  description Punt Webauth

class-map match-any system-cpp-police-l2lvx-control

  description L2 LVX control packets

class-map match-any system-cpp-police-forus

  description Forus Address resolution and Forus traffic

class-map match-any system-cpp-police-multicast-end-station

  description MCAST END STATION

class-map match-any system-cpp-police-multicast

  description Transit Traffic and MCAST Data

class-map match-any system-cpp-police-l2-control

  description L2 control

class-map match-any system-cpp-police-dot1x-auth

  description DOT1X Auth

class-map match-any system-cpp-police-data

  description ICMP redirect, ICMP_GEN and BROADCAST

class-map match-any system-cpp-police-stackwise-virt-control

  description Stackwise Virtual

class-map match-any system-cpp-police-control-low-priority

  description General punt

class-map match-any non-client-nrt-class

class-map match-any system-cpp-police-routing-control

  description Routing control

class-map match-any system-cpp-police-protocol-snooping

  description Protocol snooping

!

policy-map system-cpp-policy

 class system-cpp-police-data

  police rate 600 pps

 class system-cpp-police-sys-data

  police rate 100 pps

 class system-cpp-police-sw-forward

  police rate 1000 pps

 class system-cpp-police-multicast

  police rate 500 pps

 class system-cpp-police-multicast-end-station

  police rate 2000 pps

 class system-cpp-police-punt-webauth

  police rate 1000 pps

 class system-cpp-police-l2-control

  police rate 2000 pps

 class system-cpp-police-stackwise-virt-control

  police rate 8000 pps

 class system-cpp-police-routing-control

  police rate 5400 pps

 class system-cpp-police-control-low-priority

  police rate 200 pps

 class system-cpp-police-l2lvx-control

  police rate 1000 pps

 class system-cpp-police-topology-control

  police rate 13000 pps

 class system-cpp-police-dot1x-auth

  police rate 1000 pps

 class system-cpp-police-protocol-snooping

  police rate 2000 pps

 class system-cpp-police-forus

  police rate 1000 pps

 class system-cpp-default

  police rate 1000 pps

!

 

!

interface GigabitEthernet0/0

 vrf forwarding Mgmt-vrf

 no ip address

 speed 1000

 negotiation auto

 

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

 switchport mode trunk

 no cdp enable

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface TenGigabitEthernet1/1/1

!

interface TenGigabitEthernet1/1/2

!

interface TenGigabitEthernet1/1/3

!

interface TenGigabitEthernet1/1/4

!

interface TenGigabitEthernet1/1/5

!

interface TenGigabitEthernet1/1/6

!

interface TenGigabitEthernet1/1/7

!

interface TenGigabitEthernet1/1/8

!

interface FortyGigabitEthernet1/1/1

!

interface FortyGigabitEthernet1/1/2

!

interface GigabitEthernet2/0/1

!

interface GigabitEthernet2/0/2

!

interface GigabitEthernet2/0/3

!

interface GigabitEthernet2/0/4

!

interface GigabitEthernet2/0/5

!

interface GigabitEthernet2/0/6

!

interface GigabitEthernet2/0/7

!

interface GigabitEthernet2/0/8

!

interface GigabitEthernet2/0/9

!

interface GigabitEthernet2/0/10

!

interface GigabitEthernet2/0/11

!

interface GigabitEthernet2/0/12

!

interface GigabitEthernet2/0/13

!

interface GigabitEthernet2/0/14

!

interface GigabitEthernet2/0/15

!

interface GigabitEthernet2/0/16

!

interface GigabitEthernet2/0/17

!

interface GigabitEthernet2/0/18

!

interface GigabitEthernet2/0/19

!

interface GigabitEthernet2/0/20

!

interface GigabitEthernet2/0/21

!

interface GigabitEthernet2/0/22

!

interface GigabitEthernet2/0/23

!

interface GigabitEthernet2/0/24

 switchport mode trunk

interface GigabitEthernet2/1/1

!

interface GigabitEthernet2/1/2

!

interface GigabitEthernet2/1/3

!

interface GigabitEthernet2/1/4

!

interface TenGigabitEthernet2/1/1

!

interface TenGigabitEthernet2/1/2

!

interface TenGigabitEthernet2/1/3

!

interface TenGigabitEthernet2/1/4

!

interface TenGigabitEthernet2/1/5

!

interface TenGigabitEthernet2/1/6

!

interface TenGigabitEthernet2/1/7

!

interface TenGigabitEthernet2/1/8

!

interface FortyGigabitEthernet2/1/1

!

interface FortyGigabitEthernet2/1/2

!

interface Vlan1

 ip address 10.1.0.223 255.255.255.0

!

ip forward-protocol nd

ip http server

ip http secure-server

ip ssh time-out 60

ip ssh version 2

!

!

!

control-plane

 service-policy input system-cpp-policy

!

!

line con 0

 exec-timeout 0 0

 login local

 stopbits 1

line vty 0 4

 login local

 transport input ssh

line vty 5 15

 login

!

!

wsma agent exec

!

wsma agent config

!

wsma agent filesys

!

wsma agent notify

!

!

End

 

VIP Expert

Re: Unable to Ping brand new 9300

2/0/24 is a trunk port.  If you are connecting your PC or laptop to this port, it needs to be an access port

 

interface GigabitEthernet2/0/24

 switchport mode trunk

 

interface GigabitEthernet2/0/24

 switchport mode access

 switchport access vlan x

HTH

Beginner

Re: Unable to Ping brand new 9300

I'm connecting it to another trunk port on a cisco 3650.  

VIP Expert

Re: Unable to Ping brand new 9300

So, what port connects to your PC and what is its IP?

Do you see the PC's mac address on the switch?

sh mac address-table

HTH

Beginner

Re: Unable to Ping brand new 9300

I console directly into the switch from a PC.  No network connectivity there.

 

I have the switched plugged into a network cable that goes to our Core.  Both ports the one on the new switch, and the one on the Core are configured for Trunking.  I then SSH into the Core and try to ping the switch and can't.  

 

I also can't ping the Core from the new switch (via my consoled in PC).

 

Does that help clear things?  

 

Thanks for your help!

VIP Expert

Re: Unable to Ping brand new 9300

Does that help clear things?  

Yes, very helpful.

Can you make sure vlan 1 is up and running?

sh int vlan 1 or sh ip int brief vlan1

your ip on the 9300 switch is 10.1.0.223/24 What is the IP on the core you are trying to ping?

Can you try pinging the core IP and source it from vlan1

ping x.x.x.x source vlan1

 

Can you post the port config on the core where the 9300 is connected?

HTH

Beginner

Re: Unable to Ping brand new 9300

So this morning I fired up the switches, and tried pinging from Source VLan1 and it worked!  Now it is responding to pings from the core as well as from the switch to the core.

 

Thanks for your help on this.  Not sure what the issue was but it seems to be working!

Re: Unable to Ping brand new 9300

Re: Unable to Ping brand new 9300

So this morning I fired up the switches, and tried pinging from Source VLan1 and it worked!  Now it is responding to pings from the core as well as from the switch to the core.

 

Thanks for your help on this.  Not sure what the issue was but it seems to be working!

 

 

I have the same issue..can you please show me how to do it..

 

Beginner

Re: Unable to Ping brand new 9300

I had the same issue. ... Just no comment on the buggy ios-es. Fuji 16.9.1 is mine.

I enabled ip routing. all is up - svi is up, interface is up. network of svi 127 is 10.127.1.0/24

interface Vlan127
ip address 10.127.1.9 255.255.255.0

#

initially that is what I had only in the routing table:


10.0.0.0/32 is subnetted, 1 subnets
L 10.127.1.9 is directly connected, Vlan127

which as you see is not correct at all.

 

After the restart of the stack I get the right routing table and ping is working.

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.127.1.0/24 is directly connected, Vlan127
L 10.127.1.9/32 is directly connected, Vlan127

 

I guess even if you havent enabled ip routing but just have a single mgmt vlan, you need to restart the stack.

Beginner

Re: Unable to Ping brand new 9300

I had the same problem and a reload solved the problem!

CreatePlease to create content
Content for Community-Ad