cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
15506
Views
5
Helpful
38
Replies
siddiquiomer
Beginner

unable to ping the SVI VLAN

i am stuck in a issue! unable to ping the SVI


i am design a small network for a office.


1 router 2811


1 switch 3750-e


-----------------


Router is connected to the mpls cloud with ospf.



here re the config.



Router#


int fa0/0


ip 10.10.10.1 255.255.255.252


des connected to switch


no shut


!


int fa0/1


ip 20.20.20.1 255.255.255.252


des connected to MPLS cloud


no shut


!


-----


SWITCH#config t
Vlan 201
exit
int vln 201
ip address 22.0.68.251 255.255.255.0
des USER VLAN
no shut
int fa1/0/48
no switchport
ip address 10.10.10.2 255.255.255.252
no shut
!
ip routing
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!


!


!


int fa1/0/1


switchport


switchport mode access


switchport access vlan 201


no shut


+++++++++++++++++++++++++++++++


SVI VLAN201 is UP


i connect my laptop and give ip 22.0.68.1 255.255.255.0 and default gateway 22.0.68.251
but can not ping SVI VLAN 201 (22.0.68.251) ?



and from the SWITCH i can not ping the 20.20.20.2?



please help.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Omer,

you posted me the similar config earlier when it wasn't working

Your Post

i have foollowing config in my router

router ospf 1

log-adjacency-changes

redistribute static subnets route-map REDSTAT

passive-interface default

no passive-interface FastEthernet0/1

network 10.10.10.1 0.0.0.0 area 0

network 20.20.20.1 0.0.0.3 area 0

!

access-list 1 permit 22.0.68.0 0.0.0.255

but its not working - what should i aslo do on the headoffice router?

Was it working that time?

View solution in original post

Omer,

Create the new Layer 3 VLAN on your switch & then have a routing on your router to point back to the routed interface of your switch. This is how it should be

On your router

ip route 100.100.100.0 255.255.255.0 10.10.10.2

You are already redistributing your static routes into the OSPF. Make sure to add this network into your route-maps to have them redistributed into OSPF.

Thanks

Vivek

View solution in original post

38 REPLIES 38
Reza Sharifi
Hall of Fame Expert

Is ip routing enabled on the switch ?

Sent from Cisco Technical Support iPhone App

Hi,

It should not be a problem.

- make sure that you've had vlan-201 in vlan database. "show vlan"

- make sure that fe1/0/1 is assigned to vlan-201. "sh int f1/0/1 switchport"

- make sure that ip/sunet/gateway are set correctly on hosts.

- make sure that you enable "ip routing" for acting as L3

HTH

Toshi

Sent from Cisco Technical Support iPhone App

glen.grant
Advisor

  Where are you plugging the laptop into ?  Did   you configure another switchport for vlan 201 and make it an access port ?   If you are trying to ping anything up on the router then you are going to need static routes pointing back  for all subnets on the switch on your router otherwise it does not know how to send the  request back .  If the SVI is up   then there is no reason you should not be able to ping it as you are not even being routed as you are on the the same subnet .   Make sure all PC firewalls are turned off during your testing.

Vivek Ganapathi
Enthusiast

One more thing apart from the above said.

i don't see a reverse route to the 22.0.x network from the router.

thank you all for your input.

i have my faulty laptop due to this i was unable to ping SVI

1- now from the router i can not ping vlan 201 (22.0.68.251)

2- unable to ping 22.0.68.251 from the head offic

please guide how to intorudce resever route for 22.0.x.x

Hello Omer,

Do the below configuration on your router

ip route 22.0.68.0 255.255.255.0 10.10.10.2

NOTE :The above configuration is based on the configs you pasted. If they are different do it accordingly.

i have foollowing config in my router

router ospf 1

log-adjacency-changes

redistribute static subnets route-map REDSTAT

passive-interface default

no passive-interface FastEthernet0/1

network 10.10.10.1 0.0.0.0 area 0

network 20.20.20.1 0.0.0.3 area 0

!

access-list 1 permit 22.0.68.0 0.0.0.255

but its not working - what should i aslo do on the headoffice router?

You should provide us a topology diagram to better understand your setup. Rather than giving bits & pieces of information on every other post, could you please paste the configs of all your devices (removing sensitive information) ? When i say all your devices, i mean Router & the switch.

Thanks

Vivek

SWitch-1

ip routing

!

interface Vlan201

description USER VLAN

ip address 22.0.68.251 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

interface FastEthernet1/0/47

no switchport

ip address 10.10.10.2 255.255.255.252

!

+++

from switch-1

ping 50.50.50.33 (Head office)

Sending 5, 100-byte ICMP Echos to 50.50.50.33, timeout is 2 seconds:

!!!!!

but when ping from Computer

Request time out ?

========================================

Router-1

interface FastEthernet0/1

description *** MPLS

  bandwidth 2048

ip address 20.20.20.1 255.255.255.252

!

interface FastEthernet0/1

description *** Switch-1

   ip address 10.10.10.1 255.255.255.252

!

outer ospf 1

log-adjacency-changes

redistribute static

passive-interface default

no passive-interface FastEthernet0/1

network 22.0.68.0 0.0.0.255 area 0

network 10.0.10.1 0.0.0.0 area 0

network 20.20.20.0 0.0.0.3 area 0

!

ip route 0.0.0.0 0.0.0.0 20.20.20.2 (PE)

ip route 22.0.68.0 255.255.255.0 10.10.10.2

!

++++++++++++++++++++++++++++++++++++++++++++++

Headend (head office)

bgp 100

network 22.0.68.0 mask 255.255.255.0

++++++++++++++++++++++++++++++++++++++++++++++

botom line i can not ping the user segment from the head office

and i can not ping the headoffice ip 50.50.50.33 from the computer connectd to switch1.

but from the switch-1 i can ping head office ip address 50.50.50.33

please guide.

SWitch-1

ip routing

!

interface Vlan201

description USER VLAN

ip address 22.0.68.251 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

interface FastEthernet1/0/47

no switchport

ip address 10.10.10.2 255.255.255.252

!

+++

from switch-1

ping 50.50.50.33 (Head office)

Sending 5, 100-byte ICMP Echos to 50.50.50.33, timeout is 2 seconds:

!!!!!

but when ping from Computer

Request time out ?

========================================

Router-1

interface FastEthernet0/1

description *** MPLS

  bandwidth 2048

ip address 20.20.20.1 255.255.255.252

!

interface FastEthernet0/1

description *** Switch-1

   ip address 10.10.10.1 255.255.255.252

!

outer ospf 1

log-adjacency-changes

redistribute static

passive-interface default

no passive-interface FastEthernet0/1

network 22.0.68.0 0.0.0.255 area 0

network 10.0.10.1 0.0.0.0 area 0

network 20.20.20.0 0.0.0.3 area 0

!

ip route 0.0.0.0 0.0.0.0 20.20.20.2 (PE)

ip route 22.0.68.0 255.255.255.0 10.10.10.2

!

++++++++++++++++++++++++++++++++++++++++++++++

Headend (head office)

bgp 100

network 22.0.68.0 mask 255.255.255.0

++++++++++++++++++++++++++++++++++++++++++++++

botom line i can not ping the user segment from the head office

and i can not ping the headoffice ip 50.50.50.33 from the computer connectd to switch1.

but from the switch-1 i can ping head office ip address 50.50.50.33

please guide.

Explain me between where you are using OSPF firstly. Based on the no passive-interface Fa0/1 (This is suppose to be between MPLS & you ? ) I do not notice an OSPF config between switch-1 & router.

Provide me the relevant lines of config between your head-office & Branch. That BGP advertising looks like you are advertising that network off to someone. Some questions for you

  • How are you learning routes from Branches to your headoffice?
  • Which is the routing protocol used between you and MPLS.

I even noticed that your configuration parameters suddenly changed from previous post to this one. You had a redistribution of static subnets with some route-map. Now, it has vanished You busy troubleshooting, ya ?

Vivek.

Message was edited by: Vivek Ganapathi

  • How are you learning routes from Branches to your headoffice?
  • HEADOFFICE GBP - SERVICE PROVIDER OSPF - BRANCH OSPF
  • Which is the routing protocol used between you and MPLS.
  • OSPF

I REMOVE THE REDISTRIBUTION , instead i used static route.

i am using ospf firstly.

if config is worng let me know

i will remove the 22.0.68.0 from the headoffice.

I updated the post. Please check again.