cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
972
Views
0
Helpful
13
Replies

unmanaged and non cisco hardware on c3750e-pd

i have 3 c3750e-pd-sf switches. they talk very well to each other, and to printers, or desktops, ... but they refuse to talk to any unmanaged, or non cisco switches (trendnet tegs24tg, netgear fs726tp, trendnet green gb8pt), or my routers (tp-link ac1900, netgear nighthawk). if the ports are not in trunking mode they amber light down the port, if in trunking, even with only vlan1 on the switch, they will not pass data.

 

i do not care about the old switches as they are going away  with this upgrade (but might need a local in a spot or two due to limited connections), but they are acting the same way as for my routers.

 

these switches are to be in two locations with a hot spare. one in the basement and one in the garage, connected via two 10g mm fiber (vlan 1,102 and vlan 103,1000).

 

vlan1 is LAN general traffic

vlan102 is servers backbone

vlan103 is cameras

vlan1000 is WAN

 

my cisco certs are....  well 25yrs ago, and my old hardware... (2501, c2900, ect) long scrapped.

 

thanks

----------------------------- config----------------

c3750b#wr t

Building configuration...

 

Current configuration : 5449 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname c3750b

!

enable secret 5 XXXX

enable password XXX

!

no aaa new-model

clock timezone UTC -6

switch 3 provision ws-c3750e-48pd

system mtu routing 1500

udld aggressive

 

ip subnet-zero

ip domain-list kausi.com

ip domain-name kausi.com

ip name-server 8.8.8.8

ip name-server 208.67.200.200

ip name-server 8.26.56.26

ip name-server 8.8.4.4

ip name-server 208.67.220.220

ip name-server 156.154.70.22

!

!

mls qos map cos-dscp 0 8 16 24 32 46 46 56

!

crypto pki trustpoint TP-self-signed-190796032

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-190796032

revocation-check none

rsakeypair TP-self-signed-190796032

!

!

crypto pki certificate chain TP-self-signed-190796032

certificate self-signed 01

XXXX

quit

!

!

!

errdisable recovery cause link-flap

errdisable recovery interval 60

!

!

macro global description cisco-global | cisco-global

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

vlan dot1q tag native

!

!

interface Loopback0

ip address 172.31.255.200 255.255.0.0

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet3/0/1

!

interface GigabitEthernet3/0/2

!

interface GigabitEthernet3/0/3

!

interface GigabitEthernet3/0/4

!

interface GigabitEthernet3/0/5

!

interface GigabitEthernet3/0/6

!

interface GigabitEthernet3/0/7

!

interface GigabitEthernet3/0/8

!

interface GigabitEthernet3/0/9

!

interface GigabitEthernet3/0/10

!

interface GigabitEthernet3/0/11

!

interface GigabitEthernet3/0/12

!

interface GigabitEthernet3/0/13

!

interface GigabitEthernet3/0/14

!

interface GigabitEthernet3/0/15

!

interface GigabitEthernet3/0/16

!

interface GigabitEthernet3/0/17

!

interface GigabitEthernet3/0/18

!

interface GigabitEthernet3/0/19

!

interface GigabitEthernet3/0/20

!

interface GigabitEthernet3/0/21

!

interface GigabitEthernet3/0/22

!

interface GigabitEthernet3/0/23

!

interface GigabitEthernet3/0/24

!

interface GigabitEthernet3/0/25

!

interface GigabitEthernet3/0/26

!

interface GigabitEthernet3/0/27

!

interface GigabitEthernet3/0/28

!

interface GigabitEthernet3/0/29

!

interface GigabitEthernet3/0/30

!

interface GigabitEthernet3/0/31

!

interface GigabitEthernet3/0/32

!

interface GigabitEthernet3/0/33

!

interface GigabitEthernet3/0/34

!

interface GigabitEthernet3/0/35

!

interface GigabitEthernet3/0/36

!

interface GigabitEthernet3/0/37

!

interface GigabitEthernet3/0/38

!

interface GigabitEthernet3/0/39

!

interface GigabitEthernet3/0/40

!

interface GigabitEthernet3/0/41

!

interface GigabitEthernet3/0/42

!

interface GigabitEthernet3/0/43

!

interface GigabitEthernet3/0/44

!

interface GigabitEthernet3/0/45

!

interface GigabitEthernet3/0/46

!

interface GigabitEthernet3/0/47

!

interface GigabitEthernet3/0/48

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

!

interface GigabitEthernet3/0/49

!

interface GigabitEthernet3/0/50

!

interface GigabitEthernet3/0/51

!

interface GigabitEthernet3/0/52

!

interface TenGigabitEthernet3/0/1

!

interface TenGigabitEthernet3/0/2

!

interface Vlan1

description LAN

ip address 172.16.255.200 255.255.0.0

!

interface Vlan102

description server_link

ip address 172.17.255.200 255.255.0.0

!

interface Vlan103

description cameras

no ip address

!

interface Vlan1000

description WAN

ip address 192.168.73.200 255.255.255.0

!

ip default-gateway 172.16.255.254

ip classless

ip default-network 172.16.0.0

ip route 0.0.0.0 0.0.0.0 172.16.255.254

ip route 172.16.0.0 255.255.0.0 172.16.255.254

ip route 192.168.73.0 255.255.255.0 192.168.73.1

ip http server

ip http secure-server

!

snmp-server community kausiro RO

snmp-server community kausirw RW

snmp-server location XXX mn

snmp-server contact me

snmp-server enable traps license

!

control-plane

!

!

line con 0

line vty 0 4

password XXX

login

length 0

line vty 5 15

password XXX

login

length 0

!

ntp server 206.146.8.2

end

 

c3750b#

 

1 ACCEPTED SOLUTION

Accepted Solutions

SOLVED!!!!

NO SPAN VLAN #

 

why it is being, i do not know, but killing spanning on the vlan works.

View solution in original post

13 REPLIES 13

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - I haven't looked at your config , but to get a first glance of what is going on : prepare a port as you intend to use it for a connection with one of the foreign switches. Physically connect the port. After 20, 30 and 1 minute , issue show logging on the Cisco switch. Look for errors. As stated have this at a repeated interval because sometimes spanning-tree errors can come later (for instance).

 M.

ty will do, sadly spanning tree can be a royal pain. most of the time i disable it.

nope. just says the port is up, but the web display says it is "satus:port is disabled" and the led is amber.

nope. just states that it is up. the web management states "status: Port is disabled" and the led is amber.

 

very frustrating since i just willy nilly plugged a cable in for the other c3750e switch, and they work. but a non cisco device??? NO!

updated config, still not working:

 

c3750b#wr t
Building configuration...

Current configuration : 5831 bytes
!
! Last configuration change at 01:55:56 UTC Mon Jan 2 2006
!
version 15.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c3750b
!
boot-start-marker
boot-end-marker
!
enable secret 5 [snip]
!
username gaarith secret 5 [snip]
aaa new-model
!

aaa session-id common
clock timezone UTC -6 0
switch 3 provision ws-c3750e-48pd
system mtu routing 1500
!

ip domain-list kausi.com
ip domain-name kausi.com
ip name-server 8.8.8.8
ip name-server 208.67.200.200
ip name-server 8.26.56.26
ip name-server 8.8.4.4
ip name-server 208.67.220.220
ip name-server 156.154.70.22
!

udld aggressive

mls qos map cos-dscp 0 8 16 24 32 46 46 56
!
crypto pki trustpoint TP-self-signed-190796032
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-190796032
revocation-check none
rsakeypair TP-self-signed-190796032
!
!
crypto pki certificate chain TP-self-signed-190796032
certificate self-signed 01
[snip]
quit
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
errdisable recovery cause link-flap
errdisable recovery interval 60
!

vlan internal allocation policy ascending
vlan dot1q tag native
!

interface Loopback0
ip address 172.31.255.200 255.255.0.0
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet3/0/1
!
interface GigabitEthernet3/0/2
!
interface GigabitEthernet3/0/3
!
interface GigabitEthernet3/0/4
!
interface GigabitEthernet3/0/5
!
interface GigabitEthernet3/0/6
!
interface GigabitEthernet3/0/7
!
interface GigabitEthernet3/0/8
!
interface GigabitEthernet3/0/9
!
interface GigabitEthernet3/0/10
!
interface GigabitEthernet3/0/11
!
interface GigabitEthernet3/0/12
!
interface GigabitEthernet3/0/13
!
interface GigabitEthernet3/0/14
!
interface GigabitEthernet3/0/15
!
interface GigabitEthernet3/0/16
!
interface GigabitEthernet3/0/17
!
interface GigabitEthernet3/0/18
!
interface GigabitEthernet3/0/19
!
interface GigabitEthernet3/0/20
!
interface GigabitEthernet3/0/21
!
interface GigabitEthernet3/0/22
!
interface GigabitEthernet3/0/23
!
interface GigabitEthernet3/0/24
!
interface GigabitEthernet3/0/25
!
interface GigabitEthernet3/0/26
!
interface GigabitEthernet3/0/27
!
interface GigabitEthernet3/0/28
!
interface GigabitEthernet3/0/29
!
interface GigabitEthernet3/0/30
!
interface GigabitEthernet3/0/31
!
interface GigabitEthernet3/0/32
!
interface GigabitEthernet3/0/33
!
interface GigabitEthernet3/0/34
!
interface GigabitEthernet3/0/35
!
interface GigabitEthernet3/0/36
!
interface GigabitEthernet3/0/37
!
interface GigabitEthernet3/0/38
!
interface GigabitEthernet3/0/39
desc testing
switchport trunk allowed vlan 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/0/40
!
interface GigabitEthernet3/0/41
desc testing
switchport access vlan 101
!
interface GigabitEthernet3/0/42
!
interface GigabitEthernet3/0/43
!
interface GigabitEthernet3/0/44
!
interface GigabitEthernet3/0/45
!
interface GigabitEthernet3/0/46
!
interface GigabitEthernet3/0/47
!
interface GigabitEthernet3/0/48
desc testing
switchport access vlan 101
switchport trunk allowed vlan 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/0/49
!
interface GigabitEthernet3/0/50
!
interface GigabitEthernet3/0/51
!
interface GigabitEthernet3/0/52
!
interface TenGigabitEthernet3/0/1
!
interface TenGigabitEthernet3/0/2
!
interface Vlan1
description LAN
ip address 172.16.255.200 255.255.0.0
!
interface Vlan101
description LAN
no ip address
!
interface Vlan102
description server_link
ip address 172.17.255.200 255.255.0.0
!
interface Vlan103
description cameras
no ip address
!
interface Vlan1000
description WAN
ip address 192.168.73.200 255.255.255.0
!
ip default-gateway 172.16.255.254
ip forward-protocol nd
!
ip http server
ip http secure-server
ip default-network 172.16.0.0
ip route 0.0.0.0 0.0.0.0 172.16.255.254
ip route 172.16.0.0 255.255.0.0 172.16.255.254
ip route 192.168.73.0 255.255.255.0 192.168.73.1
ip ssh pubkey-chain
username gaarith
!
!
!
snmp-server community kausiro RO
snmp-server community kausirw RW
snmp-server location chisago mn
snmp-server contact me
snmp-server enable traps license
!

line con 0
line vty 0 4
password
length 0
line vty 5 15
password
length 0
!
ntp server 132.163.96.1
ntp server 129.6.15.28
!
end

c3750b#

 

 - I suspect, STP inconsistencies - issue show spanning-tree interface , for the particular interface to get the STP status.

 M.

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
Have you set tried disabling negotiation on the interfaces it may be these non cisco switches don’t support it, when applicable try hardcoding the interface speed/duplex settings?

Lastly for the unmanaged switches they won’t support trunking so they need to be connected via with a port of administrative mode of access.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

There are several things about this config that I do not understand. There are multiple vlan interfaces and some ip route statements. But I do not see ip routing enabled. The multiple vlan interfaces have IP addresses assigned, but there are no access ports in those vlans (in the more recent config there is one access port in one vlan) and the trunk carries only vlan 1. So what is the purpose of the multiple vlan interfaces. And what is the purpose of this command "vlan dot1q tag native"?

 

I wonder if the issues may be related to the way that spanning tree is set up

spanning-tree mode rapid-pvst

I wonder if the devices would work better with standard spanning tree?

 

Can you give us an example of one of your routers that does not communicate with the switch? What device, what port is it connected to, the output of show interface status and of show interface switchport <port#>

HTH

Rick

richard:

i am at work so i have no access to the switches, but i will give info now.

both switches are config the same except ips.

both as fresh factory, the first config, and the second do not talk to the
listed devices.

the vlan dot1 native was a recommended thing i came acress.

the other setting are a work in progress as i remember from 20+ yrs ago.

the trunking lines were trying to figure out the issues and will be removed
it not needed.

i may have to trunk the fibers betrween the two switched, but would reather
vlan only.


the goals are:
reduce network hardware
improve bandwith and performance

layout is c3750b tie via dual vlaned 10g mm to c3750g.

all ports to be vlan set for the device.


i will do my best to update all these sugestions when i get home and fire
them up.

ok, update.

 

did the suggestions thus far:

and no change.

no logs entries, even for spanning tree

link is up, but port led is still amber and "disabled"
need to look into the administrative mode.... just remembered about that one (paul driver)

 

here is my current config:

 

Building configuration...

Current configuration : 5673 bytes
!
! Last configuration change at 18:41:16 UTC Sun Jan 1 2006 [ lol, i need to change]
!
version 15.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c3750b
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
username gaarith secret 5
aaa new-model
!
!
aaa session-id common
clock timezone UTC -6 0
switch 1 provision ws-c3750e-48pd
system mtu routing 1500
!
!
ip domain-list kausi.com
ip domain-name kausi.com
ip name-server 8.8.8.8
ip name-server 208.67.200.200
ip name-server 8.26.56.26
ip name-server 8.8.4.4
ip name-server 208.67.220.220
ip name-server 156.154.70.22
!
!
udld aggressive

mls qos map cos-dscp 0 8 16 24 32 46 46 56
!
crypto pki trustpoint TP-self-signed-190796032
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-190796032
revocation-check none
rsakeypair TP-self-signed-190796032
!
!
crypto pki certificate chain TP-self-signed-190796032
certificate self-signed 01
[snip]
quit
!
spanning-tree mode pvst
spanning-tree extend system-id
errdisable recovery cause link-flap
errdisable recovery interval 60
!
!
vlan internal allocation policy ascending
no vlan dot1q tag native
!
!
interface Loopback0
ip address 172.31.255.200 255.255.0.0
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet1/0/1
!
[snip all the same]
!
interface GigabitEthernet1/0/25
speed 1000
duplex full
spanning-tree bpdufilter disable
spanning-tree bpduguard disable
spanning-tree guard none
!
interface GigabitEthernet1/0/26
!
[snip all the same]
!
interface GigabitEthernet1/0/48
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface TenGigabitEthernet1/0/1
!
interface TenGigabitEthernet1/0/2
!
interface Vlan1
description LAN
ip address 172.16.255.200 255.255.0.0
!
interface Vlan101
description LAN
no ip address
!
interface Vlan102
description server_link
ip address 172.17.255.200 255.255.0.0
!
interface Vlan103
description cameras
no ip address
!
interface Vlan1000
description WAN
ip address 192.168.73.200 255.255.255.0
!
ip default-gateway 172.16.255.254
ip forward-protocol nd
!
ip http server
ip http secure-server
ip default-network 172.16.0.0
ip route 0.0.0.0 0.0.0.0 172.16.255.254
ip route 172.16.0.0 255.255.0.0 172.16.255.254
ip route 192.168.73.0 255.255.255.0 192.168.73.1
ip ssh pubkey-chain
username gaarith
!
!
!
snmp-server community kausiro RO
snmp-server community kausirw RW
snmp-server location chisago mn
snmp-server contact me
snmp-server enable traps license
!
!
!
line con 0
line vty 0 4
password
length 0
line vty 5 15
password
length 0
!
ntp server 132.163.96.1
ntp server 129.6.15.28
!
end

c3750b#

%SPANTREE-6-PORT_STATE: Port Gi1/0/25 instance 1 moving from blocking to listening
%SPANTREE-6-PORT_STATE: Port Gi1/0/25 instance 1 moving from listening to blocking

 

look what i captured..... 

 

does this help?

SOLVED!!!!

NO SPAN VLAN #

 

why it is being, i do not know, but killing spanning on the vlan works.

Thanks for the update. Glad that my suggestion was helpful. And glad that you have got it working.

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: