cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2862
Views
0
Helpful
4
Replies
Highlighted
Beginner

Upgrade IOS 6807-XL

Hello Guys

 

I am trying to find a Cisco  document to know how make an IOS Upgrade but I don't find a Cisco's Website that explain it. Do you guys know the cisco's website?

 

I have found others cisco's website that explain how to make IOS upgrade but not for this model. 

 

My 6807-XL has:

One Supervisor Engine 2T 10GE

IOS s2t54-ipservicesk9-mz.SPA.151-2.SY5.bin

Rommon 12.2(50r)SYS3

And I want to upgrade to the las IOS available : s2t54-ipservicesk9-mz.SPA.152-1.SY7.bin

 

1. Do I have to upgrade my rommon to the last 12.2(50r)SYS4?

2. Which are the steps to upgrade my IOS?

3. Do I have to upgrade IOS and also IOS Boot? or Is enough upgrading IOS?

 

I hope you guys help me

4 REPLIES 4
Highlighted
Hall of Fame Expert

Hi,

So, it depends on the cards you have in the chassis.  See link and look under 

Restrictions for 15.2(1)SY4

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/15-2SY/release_notes/15_2_release_notes.html

 

If it applies to you, you would need to upgrade rommon as well, if not simply load the new IOS you want to upgrade to into the flash, change the boot variable, save and reload the chassis. This should all be done in a maintenance window as reloading the chassis will cause downtime.

HTH 

 

Highlighted

Hello Thanks for your replay.

 

I saw you link and the most of the individual parts requiere 15.0(1)SY but It doesn't say something about rommon version only in Restrictions for 15.2(1)SY4 but that rommon doesn't exist for 6807-XL so I suppose my new IOS is 15.2(1)SY7 is supported for my current rommon pyramid_rm2.srec.122-50r.SYS3 right?

 

 

Highlighted
Hall of Fame Community Legend


@mdrangell22 wrote:

Do I have to upgrade my rommon to the last 12.2(50r)SYS4?


My recommendation is upgrade the ROMmon (if possible). 


@mdrangell22 wrote:

2. Which are the steps to upgrade my IOS?

 


IMPORTANT:  Read the Release Notes

  1. Copy the IOS into the supervisor card; 
  2. Compare the MD5 hash value of the IOS (in the supervisor card) against the MD5 hash value found in the Cisco website; 
  3. Make sure the config-registry is 0x2102;
  4. Change the boot variable string to point to the new IOS;
  5. Add a boot variable string to point to the old IOS;
  6. Save the config
  7. Reboot.
Highlighted

Hello

 

I only want to upgrade rommon if it is required , so i need to know if 15.2(1)SY7  will work with 12.2(50r)SY3.

 

Do you know If I need to upgrade IOS BOOT too or It is enough with IOS SOFTWARE? See photo

 

 

Content for Community-Ad