cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
480
Views
0
Helpful
9
Replies
IBE
Beginner
Beginner

Upgrade IOS Catalyst 4500 (IOS and ROMmon)

Hello,

I have a couple of 4500x ('WS-C4500X-16') configured with VSS

IOS version is cat4500e-universalk9.SPA.03.07.00.E.152-3.E.bin (3.7.xE)

ROMmon version is 15.0(1r)SG11

I planned to upgrade the ios to version 3.11..4E

my question is should I upgarde the ROMmon to the latest version (15.0(1r)SG15) (is it a must to go to this version to be syncro with the ios version)

Thanks
9 REPLIES 9
Leo Laohoo
VIP Community Legend

The ROMMON needs to be upgraded first and then the IOS. 

Here is a step-by-step process about upgrading a 4500 VSS IOS including upgrading the ROMMON (LINK).

Is it a must to upgrade the ROMmon or just advised.

VSS is possible through the version 15.0(1r)SG11 and i do not need the functionality for the later ROMmon version

Leo Laohoo
VIP Community Legend


@IBE wrote:

Is it a must to upgrade the ROMmon or just advised.


Read the Release Notes and decide.

Can I presume that no one has read the process that I have linked in my previous response?  

ROMMON upgrade does not take a lot.  The ROMMON upgrade and the IOS upgrade can be done in one reboot -- If someone read the steps I have disclosed.  

IBE
Beginner
Beginner

@Leo Laohoo thanks for your reply.

I readed the process and i understand the rommon upgarde is easy but I'm on a Very sensitive environnement and I would like to avoid any risque and make sur rollback is easy. for this reason I asked if it is a must or not. 

 

Leo Laohoo
VIP Community Legend


@IBE wrote:

I readed the process and i understand the rommon upgarde is easy but I'm on a Very sensitive environnement and I would like to avoid any risque and make sur rollback is easy. for this reason I asked if it is a must or not. 


And what does the Release Notes say?  Is ROMMON upgrade necessary or not?

@Leo Laohoo there isn't specific ROMMON requirement.

If nothing specific is stated, then the upgrade is not required??? guess yes

Leo Laohoo
VIP Community Legend


@IBE wrote:

@Leo Laohoo there isn't specific ROMMON requirement.

If nothing specific is stated, then the upgrade is not required??? guess yes


Really?  

The Release Notes for 3.11.X can be found HERE.  Under Upgrading the System Software, what does it say?

 

on the release note all I found about ROM is

"If you are upgrading to Cisco IOS XE Release 3.9.xE and plan to use VSS, you must upgrade your ROMMON to IOS Version 15.0(1r)SG11."

witch is my version now

Leo Laohoo
VIP Community Legend


@IBE wrote:

on the release note all I found about ROM is

"If you are upgrading to Cisco IOS XE Release 3.9.xE and plan to use VSS, you must upgrade your ROMMON to IOS Version 15.0(1r)SG11."

witch is my version now


The final ROMMON version is SG16.  I recommend upgrading to that.