cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

447
Views
0
Helpful
15
Replies
Highlighted
Beginner

upgrading from router 2800 to L3 switch 3750G

Hi all,

I wan to migrate from a router 2800 to L3 switch 3750G , the thing is that we have several vlans and we use a router sometimes with each interface configure with correspoinding vlan subnet ip to route traffic between vlans there is no static or dynamic routing only directly connected interfaces on router routing traffic to each other

How would i configure a L3 switch interface for simillar functionality , below is my current router configuration

!

ip domain name yourdomain.com

multilink bundle-name authenticated

!

vtp mode transparent

!

!

interface FastEthernet0/0

description Thompson Interface

ip address 192.168.252.1 255.255.255.0

speed auto

full-duplex

no cdp enable

no mop enabled

!

interface FastEthernet0/1

description CA Interface

ip address 128.128.85.1 255.255.0.0

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1/0

ip address 10.99.32.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/3/0

ip address 10.99.156.1 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

no cdp run

amcmrtr10-e6#                   sh ip int brie

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            192.168.252.1   YES NVRAM  up                    up

FastEthernet0/1            128.128.85.1    YES NVRAM  up                    up

FastEthernet0/1/0          10.99.32.1      YES NVRAM  up                    up

FastEthernet0/3/0          10.99.156.1     YES manual up                    up

amcmrtr10-e6#sh cdp nei

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

SWITCH1          Fas 0/1            171          S I      WS-C2950- Fas 0/23

DS1_MGMT_SW      Fas 0/3/0          138          S I      WS-C2960- Gig 0/2

Switch           Fas 0/1/0          167          S I      WS-C2960- Fas 0/24

amcmrtr10-e6#

15 REPLIES 15
Advisor

upgrading from router 2800 to L3 switch 3750G

I don't see vlans configured on the router. Generally you'd have subinterfaces configured with dot1 commands under each interface that told the router what to tag the traffic with.

I do see however that you have a switch connected to each interface except fa0/0 which I'm assuming is the wan interface. That being said, it looks like you have things physically segmented as opposed to having vlans. Is that the case?

Let's look at it from the perspective of you having vlans 1, 2, and 3. The way that you'd configure your switch would be like:

ip routing

vlan 2

vlan 3

int vlan 1

ip address x.x.x.x 255.255.255.0

int vlan 2

ip address x.x.x.x 255.255.255.0

int vlan 3

ip address x.x.x.x 255.255.255.0

int fa0/1 (wan interface)

no switchport

ip address 192.168.252.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0

If you have no vlans and are physically segmenting as it seems, you could mirror this configuration by making all of your switchports that your uplinks connect to as routed ports:

int fa0/1

no switchport

ip address 192.168.252.1 255.255.255.0

int fa0/3

no switcport

ip address 128.128.85.1 255.255.0.0

etc.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Beginner

Re: upgrading from router 2800 to L3 switch 3750G

no there are no sub interfaces with dot 1q encapsulation , the router is not doing intervlan routing with trunk interfaces and also the router interfaces are connecting to 4 switches and ports on the switch are access and trunk ports

I know what you mean by intervlan routing or router on a stick configuration but this new company that i work for now has legacy network infrastructure , so i am confused now

Configure like below if i know vlan numbers

conf t

ip routing

vlan 2

int vlan 2

ip add x.x.x.x x.x.x.x

no shut

int gig x/x

switchport access vlan 2

no shut

vlan 3

ip add y.y.y.y y.y.y.y

no shut

int gig y/y

switchport access vlan 3

no shut

----------------------------------------------

This is if there are no vlans on other end

conf t

ip routing

int gig x/x

no switchport

ip add x.x.x.x x.x.x.x

no shut

int gig y/y

no switchport

ip add y.y.y.y y.y.y.y

no shut

Beginner

upgrading from router 2800 to L3 switch 3750G

i just checked all 4 router interfaces connect to 4 switches , all where all switchports are in vlan 1 , so its 4 isolated networks being routed into each each other using a router

so my question is if i do no switchport on 4 switch 3750 interfaces and give ip adress same of that or router and enable ip routing will switch do routing between the 4 networks again or not ?

Thanks,

Suhail

Enthusiast

upgrading from router 2800 to L3 switch 3750G

Yes Switch will Dot Routing in that case also.

Hostaname ABC

ip routing

vtp mode transparent

vlan 252

vlan 85

vlan 32

vlan 156

int vlan 252

ip address 192.168.252.1 255.255.255.0

no shut

int vlan 85

ip address 128.128.85.1 255.255.0.0

no shut

int vlan 32

ip address 10.99.32.1 255.255.255.0

no shut

int vlan 156

ip address 192.168.156.1 255.255.255.0

no shut

interface fa 0/22

Switchport access vlan 156

Des Connected To DS1_MGMT_SW

interface fa 0/23

switchport access vlan 252

Des Connected To SWITCH1

interface fa 0/24

switchport access vlan 32

Des Connected To Switch

Do Rate Helpful Posts...

Jawad
Beginner

upgrading from router 2800 to L3 switch 3750G

well this is how i configured today , but some of the services did not work at the application level and would it also be due to the following commands missing on switch :

ip cef

no mop enable

speed auto

ip forward-protocol nd

Below is how i configured in terfaces were up routinf table was identical to that of router , please advice

-----------------------------------------------

conf t

ip routing

vtp mode transparent

!

!

interface GigabitEthernet1/0/1

description Thompson Interface

no switchport

ip address 192.168.252.1 255.255.255.0

no shut

!

interface GigabitEthernet1/0/2

description CA Interface

no switchport

ip address 128.128.85.1 255.255.0.0

no shut

!

interface GigabitEthernet1/0/3

no switchport

ip address 10.99.32.1 255.255.255.0

no shut

!

interface GigabitEthernet1/0/4

no switchport

ip address 10.99.156.1 255.255.255.0

no shut

!

Switch#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    128.128.0.0/16 is directly connected, GigabitEthernet1/0/2

     10.0.0.0/24 is subnetted, 2 subnets

C       10.99.32.0 is directly connected, GigabitEthernet1/0/3

C       10.99.156.0 is directly connected, GigabitEthernet1/0/4

C    192.168.252.0/24 is directly connected, GigabitEthernet1/0/1

Switch#

Switch#

Switch#

Switch#sh

*Mar  1 00:04:34.743: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/4, changed state to up

*Mar  1 00:04:35.758: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/4, changed

state to upip int brie

Interface              IP-Address      OK? Method Status                Protocol

Vlan1                  unassigned      YES NVRAM  administratively down down

GigabitEthernet1/0/1   192.168.252.1   YES NVRAM  up                    up

GigabitEthernet1/0/2   128.128.85.1    YES NVRAM  up                    up

GigabitEthernet1/0/3   10.99.32.1      YES NVRAM  up                    up

GigabitEthernet1/0/4   10.99.156.1     YES NVRAM  up                    up

GigabitEthernet1/0/5   unassigned      YES unset  down                  down

GigabitEthernet1/0/6   unassigned      YES unset  down                  down

Switch#     sh cdp nei

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

amcmthxms01-e6   Gig 1/0/1         151              S I   WS-C2960- Fas 0/13

SWITCH1          Gig 1/0/2         161              S I   WS-C2950- Fas 0/23

SW-Cta1-D7-CW    Gig 1/0/3         165              S I   WS-C2960- Gig 0/2

Switch           Gig 1/0/4         171              S I   WS-C2960- Fas 0/24

Switch#

Enthusiast

upgrading from router 2800 to L3 switch 3750G

Have u tried to Ping.  Do tracroute.

Jawad
Beginner

Re: upgrading from router 2800 to L3 switch 3750G

The pings are failing to directly connected interfaces, i dont understand as to why  !!!!!!!!!!!!!!!1

Switch#     sh cdp nei

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

amcmthxms01-e6   Gig 1/0/1         151              S I   WS-C2960- Fas 0/13

SWITCH1          Gig 1/0/2         161              S I   WS-C2950- Fas 0/23

SW-Cta1-D7-CW    Gig 1/0/3         165              S I   WS-C2960- Gig 0/2

Switch           Gig 1/0/4         171              S I   WS-C2960- Fas 0/24

Switch#

Switch#sh cdp nei det

-------------------------

Device ID: amcmthxms01-e6

Entry address(es):

Platform: cisco WS-C2960-24TT-L,  Capabilities: Switch IGMP

Interface: GigabitEthernet1/0/1,  Port ID (outgoing port): FastEthernet0/13

Holdtime : 153 sec

Version :

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)SEE2, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Fri 28-Jul-06 04:33 by yenanh

advertisement version: 2

Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF000000000000001B53C4F180FF0000

VTP Management Domain: ''

Native VLAN: 401

Duplex: full

Management address(es):

-------------------------

Device ID: SWITCH1

Entry address(es):

  IP address: 128.128.64.64

Platform: cisco WS-C2950-24,  Capabilities: Switch IGMP

Interface: GigabitEthernet1/0/2,  Port ID (outgoing port): FastEthernet0/23

Holdtime : 144 sec

Version :

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA1b, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Tue 24-Aug-04 00:12 by yenanh

advertisement version: 2

Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF000000000000001319F5D500FF0000

VTP Management Domain: ''

Native VLAN: 85

Duplex: full

Management address(es):

  IP address: 128.128.64.64

-------------------------

Device ID: SW-Cta1-D7-CW

Entry address(es):

  IP address: 10.99.156.118

Platform: cisco WS-C2960-48TC-L,  Capabilities: Switch IGMP

Interface: GigabitEthernet1/0/3,  Port ID (outgoing port): GigabitEthernet0/2

Holdtime : 175 sec

Version :

Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(50)SE5, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Tue 28-Sep-10 13:44 by prod_rel_team

advertisement version: 2

Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF00000000000018339D426A00FF0000

VTP Management Domain: ''

Native VLAN: 1

Duplex: full

Management address(es):

  IP address: 10.99.156.118

-------------------------

Device ID: Switch

Entry address(es):

  IP address: 10.99.32.9

Platform: cisco WS-C2960-24TT-L,  Capabilities: Switch IGMP

Interface: GigabitEthernet1/0/4,  Port ID (outgoing port): FastEthernet0/24

Holdtime : 120 sec

Version :

Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(35)SE5, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Thu 19-Jul-07 20:06 by nachen

advertisement version: 2

Protocol Hello:  OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF000000000000001E49CD0200FF0000

VTP Management Domain: ''

Native VLAN: 1

Duplex: full

Management address(es):

  IP address: 10.99.32.9

Switch#$                                                   ping 10.99.32.9

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.99.32.9, timeout is 2 seconds:

...

Success rate is 0 percent (0/3)

Switch#ping 10.99.156.118

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.99.156.118, timeout is 2 seconds:

..

Success rate is 0 percent (0/2)

Switch#ping 128.128.64.64

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 128.128.64.64, timeout is 2 seconds:

..

Success rate is 0 percent (0/2)

Switch#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    128.128.0.0/16 is directly connected, GigabitEthernet1/0/2

     10.0.0.0/24 is subnetted, 2 subnets

C       10.99.32.0 is directly connected, GigabitEthernet1/0/3

C       10.99.156.0 is directly connected, GigabitEthernet1/0/4

C    192.168.252.0/24 is directly connected, GigabitEthernet1/0/1

Switch#

Switch#

Beginner

Re: upgrading from router 2800 to L3 switch 3750G

Assistance required please

VIP Advisor

Re: upgrading from router 2800 to L3 switch 3750G

Hello

Follow Johns example.

Also on the access switches make sure ip routing is disabled , and they have a routed port to the corresponding L3

Svi address.

res

Paul

Please don't forget to rate this post if it has been helpful.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Enthusiast

Re: upgrading from router 2800 to L3 switch 3750G

First of all

That your CDP Neighbours

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

amcmthxms01-e6   Gig 1/0/1         151              S I   WS-C2960- Fas 0/13

SWITCH1          Gig 1/0/2         161              S I   WS-C2950- Fas 0/23

SW-Cta1-D7-CW    Gig 1/0/3         165              S I   WS-C2960- Gig 0/2

Switch           Gig 1/0/4         171              S I   WS-C2960- Fas 0/24

Now First We Select Neighbour Switch 1

Your Local Interface is Gig 1/0/2 with ip128.128.85.1

Switch1 Inerface is Fas 0/23 with vlan ip is 128.128.64.64

on Switch1 Fas 0/23 (Make it Switch Port mode access, Switch port access vlan wahtever vlan its is)

ip default gateway to 128.128.85.1

Second We Select Neighbour SwitchSW-Cta1-D7-CW

Your Local Interface is Gig 1/0/3 with ip 10.99.32.1

SW-Cta1-D7-CW Inerface is Gig 0/2 with vlan ip is 10.99.156.118

Now in this case LOCAL IP 10.99.32.1/24 and your neigh Switch is in another subnet 10.99.156.118/watever subnet it is.

Third We Select Neighbour Switch

Your Local Interface is Gig 1/0/4 with ip 10.99.156.1

Switch Inerface is FA 0/24 with vlan ip is 10.99.32.9

Now in this case  local ip  is 10.99.156.1/24 and you neigh Switch is in another subnet 10.99.32.9/ watever subnet it is.

Swap Cable Gig 1/0/2 to Gig 1/0/3

Swap Cable Gig 10/3 to Gig 1/0/2

Make  Uplink Ports in L2 Switches in Switch Port mode access and switch port access vlan (whatever it is)

** Do Rate All Helpful Posts **

Jawad
Enthusiast

Re: upgrading from router 2800 to L3 switch 3750G

Dont Disable IP routing

Jawad
Enthusiast

Re: upgrading from router 2800 to L3 switch 3750G

Sorry mean to say dont disable ip routing in 3750 and do disable ip routing in all switches.

Jawad
Beginner

upgrading from router 2800 to L3 switch 3750G

orignal setup

==============

cisco 2800 f0/1 -------------- switch 1 --------------Windows 2003 servers

                                      switch 2

Internet  128.128.85.2            6   0013.c4c8.2ec0  ARPA   FastEthernet0/1

Internet  128.128.85.30           0   0022.648a.8776  ARPA   FastEthernet0/1   <<<<<<<<<<  ok win 2003 primary

Internet  128.128.85.32           0   0022.648a.8674  ARPA   FastEthernet0/1    <<<<<<<<<<<<<<  ok backup

Internet  192.168.252.1           -   001b.d5a6.5c94  ARPA   FastEthernet0/0

Internet  192.168.252.123         0   00c0.3a28.1653  ARPA   FastEthernet0/0

Internet  192.168.252.200         0   0012.79d1.37e3  ARPA   FastEthernet0/0

niels-cta1-e6-cw#$

after adding L3 switch

===================

cisco 2800 f0/1 ------L3 3750 vlan1 ---------------------------------------------switch 1 --------------Windows 2003 servers

                           ip same subnet as router                                switch 2

After i add a new L3 3750 switch in between  to extend vlan 1 the srp entries for windows 2003 servers goes incompleted , i even deleted and reset arp cache on windows 2003 but still incomplete arp also cleared the arp table on router still incomplete

Internet  128.128.64.64           0   0013.19f5.d500  ARPA   FastEthernet0/1

Internet  128.128.64.65           0   0013.1a38.0b00  ARPA   FastEthernet0/1

Internet  128.128.85.1            -   001b.d5a6.5c95  ARPA   FastEthernet0/1

Internet  128.128.85.2            0   0013.c4c8.2ec0  ARPA   FastEthernet0/1

Internet  128.128.85.30           0   Incomplete      ARPA                         <<<<<<<<<<<<<<

Internet  128.128.85.32           0   Incomplete      ARPA                                    <<<<<<<<<<<<<

Internet  192.168.252.1           -   001b.d5a6.5c94  ARPA   FastEthernet0/0

Internet  192.168.252.123         0   00c0.3a28.1653  ARPA   FastEthernet0/0

Internet  192.168.252.200         0   0012.79d1.37e3  ARPA   FastEthernet0/0

niels-cta1-e6-cw#

niels-cta1-e6-cw#

Any idea what could be causing this

VIP Advisor

upgrading from router 2800 to L3 switch 3750G

Hello,

Can you post the current config of the 3750 and L2 switch  and highlight the access ports of the server.

res

Paul

Please don't forget to rate this post if it has been helpful.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards