cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
8217
Views
0
Helpful
4
Replies
webserviceshb
Beginner

VDSL2 Bridge Config

Hi

In New Zealand we now have access to VDSL2. The telco provides two methods of connectivity:

Option1: PPPOE (user name and password) is supported with  VLAN  tagging (802.1q) with a VLAN ID of 10 is required on the WAN interface.

Option 2: (Bridge) Ethernet encapsulation or RFC 1483  encapsulation, VLAN tagging (802.1q) with a VLAN ID of 10 is required on  the WAN interface.

I would like to be able to use the Cisco 887VA as a bridge to a Cisco ISA550 behind it doign PPPoE.  That way, when the customer finally gets fibre access we can just remove the 887VA from the setup and everything still works.

I cannot seem to find any information about bridging the VDSL2 interface for these routers.  A google located how to bridge ADSL.  I have adapted the config so that I think it will work for VDSL.

Here is the config I have:

controller VDSL 0

operating mode vdsl2

!

interface Ethernet0

no ip address

!

interface Ethernet0.10

encapsulation dot1Q 10

bridge-group 1

!

interface Vlan1

no ip address

bridge-group 1

!

bridge 1 protocol ieee

Being a Cisco IOS novice, I would be very grateful for input from the community to let me know if I am heading in the right direction.

4 REPLIES 4
Subeh Sharma
Beginner

Hi,

The config looks fine but be sure to refer to the config here:
http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a807.shtml

This is for RFF1483 pure bridging which is what you're trying to achieve here.

Good luck!
Subeh


Sent from Cisco Technical Support iPhone App

paolo bevilacqua
Hall of Fame Master

An 887VA is expensive to be used as a bridge. Use the device provided by ISP.

amit.bhatki
Beginner

Hello Joel,

We had a similar issue till now. I am based in NZ too.

I got this working with the following config. ISP maxnet. router cisco 867vae.

I have a Mikrotik 750 behind the cisco which passes the PPPoE un/pass.

One thing to note in my config is that you cannot manage the router remotely.

This was resolved by adding one lan port into another vlan and giving it an ip address in the clients network.

Note my config does not have telnet/ssh enabled as of yet.

What are your thoughts?

For Paolo's comment>>>>cisco 867vae/887va  are expensive routers but we are left with no choice as the other gear  is quiet crap and unreliable.

comments are highlighted in bold

*************************************************

Building configuration...

Current configuration : 1331 bytes

!

! Last configuration change at 21:58:46 UTC Thu Jul 25 2013

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VDSLtest

!

boot-start-marker

boot-end-marker

!

!

enable password *********************

!

no aaa new-model

wan mode dsl

no ipv6 cef

ip source-route

no ip routing <<<<<<<

no ip cef

!

!

!

!

!

!

crypto pki token default removal timeout 0

!

!

!

!

username abc password 0 ************

!

!

controller VDSL 0

operating mode vdsl2

!

!

!

!

!

interface ATM0

no ip address

no ip route-cache

shutdown

no atm ilmi-keepalive

!

interface Ethernet0

no ip address

no ip route-cache

!

interface Ethernet0.10 <<<<<

encapsulation dot1Q 10

no ip route-cache

bridge-group 1<<<<<<<

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface GigabitEthernet0

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

!

interface Vlan1

no ip address

ip virtual-reassembly in

no ip route-cache

bridge-group 1<<<<<<<

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

bridge 1 protocol ieee<<<<<<<

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 60000 1000

end

****************************************************

Hi guys,

 

Not sure why nobody's taken what's been recorded 1 step further (or at least hasn't documented it as far as I can tell)

 

  • create a second vlan (2)
  • assign it the fast ethernet interface to which to bridge (I used 3)
  • assign vlan 2 to bridge-port 1.

Final appropriate config lines are:

 

 

interface FastEthernet3
switchport access vlan 2
no ip address
!
interface Vlan2
name ModemBridge
no ip address
ip virtual-reassembly in
no ip route-cache
bridge-group 1
!
interface Ethernet0
no encapsulation dot1Q
no bridge-group 1
!
interface Ethernet0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 1

 

I can't think why this wouldn't work but confess I'm only going to use it in anger tomorrow morning at a client site.

Hope this helps someone (since it's nearly 6 years since the initial query)