02-07-2023 04:56 AM
Hello,
How we can make vlan access list to permit traffic from host in vlan A to vlan B but deny traffic from host in vlan B to vlan A
Solved! Go to Solution.
02-10-2023 05:17 PM - edited 02-10-2023 05:34 PM
Now until I run lab and share config I will provide you some point
traffic must classify into
UDP <<- here you must allow traffic between VLAN's
TCP <<- you can use reflexive ACL or established keyword in acl
https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/sec_data_acl/configuration/15-mt/sec-data-acl-15-mt-book/sec-cfg-ip-filter.html
ICMP <<- this need allow only the echo-reply not echo from VLAN B to VLAN A
that how should your ACL config.
02-07-2023 04:58 AM
Yes sure.
02-08-2023 09:42 PM
how?
02-09-2023 08:35 AM
Assuming this is a "homework assignment", why don't you post what you think may work, and we can review it and help you actually LEARN.
02-09-2023 12:21 PM
Hello,
Let say on vlan 10 i have acl permit ip 10.100.10.0 0.0.0.255 10.100.20.0 0.0.0.255
Then on vlan 20 i have acl permit ip 10.100.20.0 0.0.0.255 10.100.10.0 0.0.0.255
I believe with both acl all hosts from vlan 10 can communicate with all hosts on vlan 20 and vice versa. My question is how we can permit vlan 10 to vlan 20 but deny vlan 20 to vlan 10.
02-09-2023 02:30 PM
Besides "permit" ACEs you can have "????" ACEs. (What's the question mark word?)
When you use ACLs they might be applied "??" and/or "???". (What's the question mark word?)
02-09-2023 05:08 PM
beside "permit"
Ext Access List configuration commands:
<1-2147483647> Sequence Number
default Set a command to its defaults
deny Specify packets to reject
exit Exit from access-list configuration mode
no Negate a command or set its defaults
permit Specify packets to forward
remark Access list entry comment
02-09-2023 05:53 PM - edited 02-09-2023 05:54 PM
Yes and you previously wrote: "My question is how we can permit vlan 10 to vlan 20 but deny vlan 20 to vlan 10."
Look at those ACE options and what your question asked.
02-09-2023 07:44 PM
Hello
Sorry i not get your point,can you give how exactly what acl should i use?
02-10-2023 08:33 AM
What are the networks prefixes for VLANs 10 (?) and 20 (?)?
02-10-2023 01:17 PM
Vlan 10 is 10.100.10.0/24 and Vlan 20 is 10.100.20.0/24
02-10-2023 01:25 PM
Sorry I was busy, I will share config with you tomorrow.
02-10-2023 02:52 PM
Okay, you can either block VLAN B being sent to VLAN A or block VLAN B entering VLAN A.
interface Vlan10
ip address 10.100.10.1 255.255.255.0
ip access-group 10 in
access-list 10 deny 10.100.20.0 0.0.0.255
access-list 10 permit any
!== or ==
interface Vlan20
ip address 10.100.20.1 255.255.255.0
ip access-group 120 out
access-list 120 deny ip any 10.100.10.0 0.0.0.255
access-list 120 permit ip any any
02-10-2023 03:32 PM - edited 02-10-2023 03:33 PM
Oh, forgot to mention, by default, all traffic passes. I.e. you don't need to create ACLs, by default, to allow traffic between two VLANs.
02-10-2023 04:59 PM
Hello
I believe with that acl the traffic will drop communication from vlan 10 to vlan 20, and from vlan 20 to vlan 10. Am i right?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide