cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16502
Views
20
Helpful
9
Replies

VLAN-Based QoS over different Catalyst switches

hectormiranda
Level 1
Level 1

Hello,

I have this scenario:

SW1 -- SW2 -- SW3 -- SW4 -- SW5 -- R1 - Central LAN

SW1, 2, 4 & 5 are Catalyst 3560, SW3 is Catalyst 2950. All Layer-2 capable. VLAN routing is performed in R1 at central location.

Each "--" link is fiber optic Gigabit point to point, some kilometers long.

In every Catalyst switch there's a bunch of different types of traffic injected from some PCs, video cameras and real time signaling machines.

Each type of traffic is contained in its specific VLAN, i.e. there's a VLAN for PCs, a VLAN for cameras and another VLAN for signaling machines.

We need to implement QoS to prioritize these VLANs and to provide them different amounts of bandwidth.

It's my first time with QoS so I decided to simply implement VLAN-Based QoS.

I have tried with some class-maps and policy-maps, but when I try to assign the service-policy input to the SVIs i receive errors regarding invalid police.

Can anybody teach me with a good example how this QoS solution can be accomplished?

Thanks in advance,

Hector Miranda

4 Accepted Solutions

Accepted Solutions

Reza Sharifi
Hall of Fame
Hall of Fame

Hello Hector,

Since most of your devices are 3560 switches, here is good place to start with.  It provides config guides with examples:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_25_se/configuration/guide/swqos.html

HTH

Reza

View solution in original post

andtoth
Level 4
Level 4

Hi Hector,

As the 3560 switches are similar in architecture to the 3750 switches, the following documentation will help you to get started.

Cisco Catalyst 3750 QoS Configuration Examples

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

Best regards,

Andras

View solution in original post

Hi Hector,

Your configuration seems to be correct.

Are you looking for confirmation only or do you experience any specific issues with this config? If so, please share some more details what is the actual problem and what are the symptoms.

The config is indeed correct.

Best regards,

Andras

View solution in original post

Hi Hector,

Thanks for the reply. Please don't forget to rate helpful posts and mark this post as answered.

Best regards,

Andras

View solution in original post

9 Replies 9

Reza Sharifi
Hall of Fame
Hall of Fame

Hello Hector,

Since most of your devices are 3560 switches, here is good place to start with.  It provides config guides with examples:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_25_se/configuration/guide/swqos.html

HTH

Reza

andtoth
Level 4
Level 4

Hi Hector,

As the 3560 switches are similar in architecture to the 3750 switches, the following documentation will help you to get started.

Cisco Catalyst 3750 QoS Configuration Examples

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

Best regards,

Andras

Thank you guys,

I have been reading a lot both documents this last weekend.

I've finally written this model configuration. This switch is a WS-C3560V2-48PS-E, with software version

12.2(50)SE1. This is the spanning-tree root and VTP domain server for the rest of the switches.

These are the existant VLANs and the bandwidth and precedence I want to set to the traffic into each one:

VLAN ID    VLAN NAME     BANDWIDTH    PRECEDENCE

-----------------------------------------------------------------------------------------

10             IPMux                 16 Mbps                5

20             Cameras              2 Mbps                 7

30             Scada                  6 Mbps                 6

40             Web                    600 Mbps              4

50             Other                   376 Mbps              0

So, I've written the following configuration file:

1) Enable QoS in global configuration mode:

mls qos

2) Create hierarchical policy-maps

policy-map bw376M

description ***************  VLAN 50 Other  ***************

class class-default

  police 376000000 8000 exceed-action drop

policy-map VLAN50

class class-default

  set precedence 0

  service-policy bw376M

!

policy-map bw600M

description ***************  VLAN 40 Web  ***************

class class-default

  police 600000000 8000 exceed-action drop

policy-map VLAN40

class class-default

  set precedence 4

  service-policy bw600M

!

policy-map bw6M

description ***************  VLAN 30 Scada  ***************

class class-default

  police 6000000 8000 exceed-action drop

policy-map VLAN30

class class-default

  set precedence 6

  service-policy bw6M

!

policy-map bw2M

description ***************  VLAN 20 Cameras  ***************

class class-default

  police 2000000 8000 exceed-action drop

policy-map VLAN20

class class-default

  set precedence 7

  service-policy bw2M

!

policy-map bw16M

description ***************  VLAN 10 IPMux  ***************

class class-default

  police 16000000 8000 exceed-action drop

policy-map VLAN10

class class-default

  set precedence 5

  service-policy bw16M

3) Configure each fastethernet access interface this way:

interface FastEthernet0/1

switchport mode access

mls qos vlan-based

!

interface FastEthernet0/13

switchport access vlan 10

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/19

switchport access vlan 20

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/25

switchport access vlan 30

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/37

switchport access vlan 40

switchport mode access

mls qos vlan-based

!

!

interface FastEthernet0/41

switchport access vlan 50

switchport mode access

mls qos vlan-based

!

!

4) Configure trunk interfaces this way:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos vlan-based

5) Assign the policy maps to the SVIs:

!

interface Vlan10

no ip address

service-policy input VLAN10

!

interface Vlan20

no ip address

service-policy input VLAN20

!

interface Vlan30

no ip address

service-policy input VLAN30

!

interface Vlan40

no ip address

service-policy input VLAN40

!

interface Vlan50

no ip address

service-policy input VLAN50

end of configuration

Is this correct? Or an I missing something?

Please your help.

HM

Message was edited by: Hector Miranda

Hello,

Can anybody post an answer, please?

I really need to know if the above configuration is correct or if I'm missing some other commands...

Thanks in advance,

Hector

Well, this is kind of frustrating....

Where you able to deploy your configuration successfully?  I need to do something very similar.

Hi Hector,

Your configuration seems to be correct.

Are you looking for confirmation only or do you experience any specific issues with this config? If so, please share some more details what is the actual problem and what are the symptoms.

The config is indeed correct.

Best regards,

Andras

Thank you, Andras!!

It was for confirmation before implementing it in the production network.

I'll grab any logs or issues, if they appear.

Thanks again!

Hector

Hi Hector,

Thanks for the reply. Please don't forget to rate helpful posts and mark this post as answered.

Best regards,

Andras

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card