cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

468
Views
0
Helpful
6
Replies
Beginner

VLAN issues - Catalyst 2960

Hi,
I am having issues with a large number of my VLAN interfaces. Even though interfaces and trunks have been configured and end devices plugged in upstream, they stay in “down” state and I cannot ping their associated gateway. As it stands the only way to activate the new interfaces is to carry out the following
...by adding one of the new VLANs to an access port on the core switch (Catalyst 2960xr), hey presto, the interface is UP and I can ping the gateway! Please see below command string depicting this process...
 
ABLECORE#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ABLECORE(config)#!
ABLECORE(config)#interface GigabitEthernet1/0/23
ABLECORE(config-if)# switchport access vlan 411
% Access VLAN does not exist. Creating vlan 411
ABLECORE(config-if)# switchport mode access
ABLECORE(config-if)#!
Jan  4 06:40:57.203: %SPANTREE_VLAN_SW-2-MAX_INSTANCE: Platform limit of 128 STP instances exceeded. No instance created for VLAN411 (port Gi1/0/28).
Jan  4 06:40:57.329: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan411, changed state to up 
 
This problem only started after programming the first 100 or so VLANs (210 in total). I have attached a copy of the sh VLAN and sh run for reference. My edge switching consist of SG and SF-300 small business switches. 
I would very much appreciate feedback on this issue.
6 REPLIES 6
VIP Advisor

consider using MST instead of

consider using MST instead of PVST

Please remember to rate useful posts, by clicking on the stars below.

Highlighted
Beginner

Many thanks for the reply.

Many thanks for the reply.

You will have to excuse my ignorance, but how will enabling MST solve this issue?

I am assuming by having the ability to map multiple VLANs to one spanning tree instance, the VLANs created after my initial spanning tree instances ran out, will activate once mapped under MST...

VIP Mentor

Hello,

Hello,

as fas as I remember, that is the default behavior for any Vlan interface, regardless of the number or STP instances. You need at least one port assigned to the Vlan in order for the Valn interface to become active.

Is that what you are asking ?

Beginner

Hi,

Hi,

Yes that is how I expect it to behave, and that was the case upto around 145 VLANs. Now that is not the case and I have no idea why.

I assign the access port on my edge switch as untagged, the VLAN is allowed on the trunk as tagged. I plug my laptop into the port in the correct IP range and I cannont ping the VLAN gateway.

If I add the same VLAN to a port on the Core L3 Switch, in this case the 2960, the vlan activates and I can now ping the gateway.

If I go back to the edge switch, plug my laptop into the previously configured port it works.

I am very bemused.

VIP Advisor

HelloDisable ip routing on

Hello
Disable ip routing on the edge switch give it a default-gateway
Make sure the vlan you are using is propagated to the edge switch

Note: Any vlans allowed to traverse an active trunk will active the L3 vlans without requiring a access port to be assigned to the vlan

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Many thanks Paul,

Many thanks Paul,

I shall give this ago once back on the project and I update with my progress.

Thanks again,

Nick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards