cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3555
Views
0
Helpful
6
Replies
Highlighted
Beginner

VLAN on 3com 2952 and Cisco 3750

HI,

Pls help.

I have setup both Vlans on 3com and cisco. but it seems they cant talk to each other.

ive setup both on trunking mode, what supposed to be the solution on this?

thank in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

So, the 3com switch is layer-2 only and the 3750 is layer-2 and 3?

I am not familiar with 3com config, but it appears that you have only enabled vlan 1 on the trunk port connecting to the 3750.  Can you also add vlan 3 and test again?

Is the vlan interface on the 3750 in up and up mode?

sh ip int bri vlan3

is interface gi1/0/1 in up and up mode

sh ip int bri gi1/0/1

how about the 3com interfaces?

HTH

View solution in original post

6 REPLIES 6
Highlighted
Hall of Fame Expert

What is the topology look like?

How are the switches connected?

Can you provide "sh run" from the 3750?

Highlighted

Topology is

Cisco 3750       connected to        3com

g1/0/1                   -----------          g1/0/1

I created VLAN 3 for each switch.

here is the SH RUN

#####

Cisco 3750

ip routing

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

interface GigabitEthernet1/0/2

switchport access vlan 3

spanning-tree portfast

interface Vlan3

ip address 10.3.0.1 255.255.0.0

ip route 0.0.0.0 0.0.0.0 10.0.0.137

3com 2952 Baseline

#

vlan 1

#

vlan 3

#

#

ip route-static 0.0.0.0 0.0.0.0 10.0.0.2

#

interface GigabitEthernet1/0/1

port link-type trunk

port trunk permit vlan 1

stp edged-port enable

#

interface GigabitEthernet1/0/2

port access vlan 3

stp edged-port enable

Did i miss something? thank pls help

Highlighted

So, the 3com switch is layer-2 only and the 3750 is layer-2 and 3?

I am not familiar with 3com config, but it appears that you have only enabled vlan 1 on the trunk port connecting to the 3750.  Can you also add vlan 3 and test again?

Is the vlan interface on the 3750 in up and up mode?

sh ip int bri vlan3

is interface gi1/0/1 in up and up mode

sh ip int bri gi1/0/1

how about the 3com interfaces?

HTH

View solution in original post

Highlighted

yup they are all up.. same as 3com switch.

The 3com switch uses web gui, it seems by default vlan1 is enabled on int g1/0/1.. let me try if I could add to permit vlan 3..

Highlighted

@Reza..

nice one that do the trick..

i just put the

port trunk permit vlan 1 to 3

then i can ping vlans on 3750..

Highlighted

Glad to help, and thanks for the rating

Good Luck Mark

Reza

Content for Community-Ad