cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

319
Views
0
Helpful
2
Replies
Highlighted
Beginner

VLAN routing in SG300

Hello,

I have a SG300 switch, configured as follow :

- L3 enabled

- VLAN 1 : 10.0.10.0/24 (switch IP : 10.0.10.2)

- VLAN 30 : 10.0.30.0/24 (switch IP : 10.0.30.1)

- Internet access : 10.0.10.1 (with VLAN 1)

- Defaut gateway (IP 0.0.0.0 - Prefix 0 - Remote type - Next hop 10.0.10.1 - Metric 1)

 

When connecting a PC in VLAN 1 : no problem to access the Internet.

When connecting a PC in VLAN 30 - Access (using 10.0.30.1 as gateway) :

- I can ping 10.0.30.1

- I can ping 10.0.10.2

- A cannot ping 10.0.10.1 !!

 

From the switch itself : I cannot ping 10.0.10.1 from VLAN 30.

 

Could you please help me to identify the issue ?

 

Thanks in advance.

2 REPLIES 2
VIP Advisor

Re: VLAN routing in SG300

Hi @Athena1390

 

Can you share the show running-config ?

 

 

 

-If I helped you somehow, please, rate it as useful.-

Beginner

Re: VLAN routing in SG300

Hi,

Thanks for the answer.

 

 

Slightly better, but not yet perfect.

 

Configuration is now : :

- Firmware 1.4.8.6 (latest)

- L3 enabled

- VLAN 1 : 10.0.10.0/24 (switch IP : 10.0.10.2)

- VLAN 10 : 10.10100.0/24 (switch IP : 10.10.10.2)

- Internet access : 10.0.10.1 (with VLAN 1)

- Defaut gateway (IP 0.0.0.0 - Prefix 0 - Remote type - Next hop 10.0.10.1 - Metric 1)

 

 

 

When connecting a PC in VLAN 1 : no problem to access the Internet.

When connecting a PC in VLAN 10 - Access (using 10.10.10.2 as gateway) :

- I can ping 10.0.10.1

- I cannot ping 8.8.8.8, route is stopped at 10.0.10.1 !!!

 

Running-config is :

config-file-header
CD3-SG300-52-01
v1.4.8.6 / R800_NIK_1_4_202_008
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
port jumbo-frame
vlan database
vlan 10
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
loopback-detection enable
errdisable recovery cause loopback-detection
no boot host auto-config
no boot host auto-update
bonjour interface range vlan 1
hostname SG300-52-01
line console
exec-timeout 30
exit
line ssh
exec-timeout 30
exit
line telnet
exec-timeout 30
exit
aaa authentication login authorization Console local
aaa authentication enable authorization Console enable
line console
login authentication Console
enable authentication Console
password da39a3ee5e6b4b0d3255bfef95601890afd80709 encrypted
exit
no passwords complexity enable
passwords aging 0
username cisco password encrypted 7af78c911d5b48bea1dc2449d9d89513abeb4be5 privilege 15
username admin-user password encrypted 181ef0bb04eecafb58201f556fa886f13a5693a0 privilege 15
ip ssh server
snmp-server server
snmp-server location ""
snmp-server contact ""
snmp-server community public ro view Default
ip http timeout-policy 1800
no ip http server
clock timezone BXL +1
clock summer-time web recurring eu
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp server 0.be.pool.ntp.org
sntp server 1.be.pool.ntp.org
sntp server 2.be.pool.ntp.org
sntp server 3.be.pool.ntp.org
ip name-server 10.0.10.31 8.8.8.8 8.8.4.4
!
interface vlan 1
ip address 10.0.10.2 255.255.255.0
no ip address dhcp
no ipv6 address autoconfig
no ipv6 enable
no ipv6 dhcp client stateless
!
interface vlan 10
name "VLAN Public"
ip address 10.10.10.2 255.255.255.0
!
interface gigabitethernet48
switchport mode access
switchport access vlan 10
!
exit
ip default-gateway 10.0.10.1

 

 

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards