cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
603
Views
5
Helpful
2
Replies
patramirezort
Beginner

Voice vlan issue with Grandstream 1625 phones

The company I work use Grand stream Phones 1625 model, I have noticed that phones do not work properly when the interface is been tagged with the voice vlan command (WS-C2960X-48TS-L). They recognized the gateway and receive an IP from voice vlan but when we test the line it produces a busy tone and unable to establish a phone connection. But If the port is tagged only for the voice vlan (in access and stand alone mode) works fine.

 

Below is the configuration (real vlans number were changed):

!
switchport access vlan 45    ---> Data vlan


switchport trunk native vlan 45

 

switchport mode trunk

 

switchport voice vlan 15     ---> Voice vlan

 

spanning-tree portfast edge
!

 

Switch is in RSTP mode and only 802.1Q is allowed (newer platform).

 

I appreciate any help to resolve the issue.

 

Thanks in advance,

Patricia

2 REPLIES 2
@mHadi
Beginner

hi,

only cisco phones are compatible with voice vlan config, because of CDP,

for example, this config:

sw access vl 10

sw voice vl 20

this config olny works with cisco phone ..

 

so, when you have third party phones, and if you want both data vlan to PC and Voice vlan to phone,

you must config your port as a Trunk port which contains both vlans, and make vlan data for PC a native vlan on trunk,

and then set manually  vlan voice in your phone setting, definitely it has vlan setting ..

 

assume vlan 10 is data-pc-vlan

vlan 20 is phone-voice-vlan

 

config like this:

sw mode trunk

sw trunk en dot1q

sw trunk allowed vlan all

sw trunk native vlan 10 >>(Data-PC-Vlan)<<

 

then go on your phone, set vlan id manually to 20 ..

 

so pc will send untagged traffic, which switch will tagging native vlan for it (Will go on Data-PC-Vlan)

and your phone will send tagged traffic which will go to the network (trunk port are allowed it to pass)

 

 

Hi, apologize for the late reply.

 

Apparently for the Grandstream phones the Vlan tagging for voice and data are different, on the Switch the port needs to be in trunk mode and placed in native mode (by using the Voice vlan):

 

Example: 

switchport trunk native vlan (phone vlan #)
switchport mode trunk

 

After this command the phone was manually configured with the data vlan and both works fine (data and voice).