cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
4792
Views
5
Helpful
20
Replies
abimadaro4462
Beginner

vPC & OSPF

Hello,

I have the following scenario, two nexus 9K are configured as vPC peers with HSRP, the upstream is connected to active/standby firewall with OSPF configured.

below is the configuration;

SW1 & SW2

----

router ospf 1
bfd
router-id 10.10.10.4
area 0.0.0.4 nssa no-summary

interface Vlan20
ip ospf dead-interval 3
ip ospf hello-interval 1
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.4
ip ospf bfd

 

interface Vlan20
hsrp 20
ip 20.20.20.1

 

vpc domain 10
peer-switch
role priority 100
peer-keepalive destination 10.10.10.2 source 10.10.10.1 vrf vpcvrf
peer-gateway
layer3 peer-router
auto-recovery
ip arp synchronize

interface port-channel1
vpc peer-link

 

Switch one neighbor is flapping between EXSTART and EXCHANG

Neighbor ID Pri State Up Time Address Interface
10.10.10.5 1 FULL/ - 00:25:17 20.20.20.3 Vlan20
10.20.10.10 1 EXCHANGE/ - 0.065025 20.20.20.6 Vlan20

 

Please advice if the above configuration is correct.

 

20 REPLIES 20

Hello

Are you running 9Ks?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Hello,
Yes I'm running 9Ks.

Hello

well then it seems L3 over vPC is now applicable however I would suggest if you can to have a separate L3 for you backup path between switches instead of using the and svi over peer-link



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Hello,
Thanks, I figured out what is the problem, I was trying to configure the OSPF network type as point to point while it should be in broadcast mode.

You are right, your setup is valid and supported assuming you have the required minimum software version on the N9K.

 

However within your vlan20 you have 3 OSPF neighbors so this is obviously no P2P network. As such the "ip ospf network point-to-point" configuration needs to be removed.

 

And you don't need hsrp there, it is just cluttering your configuration.

View solution in original post

Hello,
Thanks, this is correct, the network in this case should be broadcast not P2P.

Regards,