cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
755
Views
25
Helpful
25
Replies
Highlighted

vPC nexus ignore Inferior BPDU (STP Bug??)

Hi everyone,

I've encountered weird technical behavior of STP in our network as follow:

 

1) We have an Backbone Cat9300 switch that should be the Root Bridge in the RSTP domain, its priority and system-ID are the Lowest values - he is acting as a Root Bridge.

2) To the Cat9300-BB switch we connect 2 Nexus5500 switches through vPC.

3) to the Nexus5500 switches we connect another vPC to another Nexus5000 switches that also act as the Root Bridge but their priority and system-ID are higher than the Cat9300's.

 

The problem is that both Cat9300 act as the Root Bridge, and the Nexus5000 stack acts as the Root Bridge, but the Nexus5500 stacks between the BB and the Nexus5000 stack prefer the Nexus5000 stack as the Root Bridge.

Luckily our architecture doesn't create a loop right now, but it will do if our vPC HA links will fail.

 

I couldn't figure it out why this is happening and there aren't any BPDUFiltering, the RSTP configuration is plain basic with the Bridge Assurance features, Loop guard etc. no extra commands that could have make such behavior.

It just looks like the Nexus5500 stack ignore the BPDUs from the Cat9300 and they aren't compatible with each other, therefore the Nexus5500 doesn't recognize a BPDU message from the Cat9300 and it elect the link's type toward the Cat9300 as an edge-port instead of point-to-point, but in the "show spanning-tree" command the vPC port-channel's towards the Cat9300 type is displayed as P2p, not as an edge.

 

I wish some1 could explain this weird behavior to me, I will try to RSPAN that Link later to see if there is something wrong.

 

Here is the following topology:DOUBLE ROOT.PNG

25 REPLIES 25
Highlighted
VIP Advocate

 

 - This is an 'example bug' : https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvt72427/?rfs=iqvred  , I suspect it does not relate to your problem, but start by using  the current recommended software releases on all involved platforms.

 M.

Highlighted
Enthusiast

Hi,

 

Could you share:

1) the port configuration between C9300 and N5500

2) Spanning-tree's configuration on C9300 and N5500

Highlighted

Please see the above reply, I attached the configuration you asked for

Highlighted
Enthusiast

Nexus with vpc must both vpc peer elect as root ( one primary and other secondary) this come with root guard and this make any SW with high priority never become root.

this for design and I think it better not to change it

Highlighted

Hi MHM,

What do you mean by that?

We have 3 vpc stacks configured and connected to each other, and only 1 of them is acting as the Root Bridge.

From your statement I understand that each vpc stack should identify itself as the Root and ignore any of the other BPDUs which isn't the case.

 

Could you clarify yourself please?

 

Thanks you all very much

Highlighted

I will with you point by point,

making any any switch connect to both vpc peers as bridge is not recommend.

when two nexus peer form vpc they must be elect as bridge for this domain, the primary and secondary peer must be act as primary and secondary root.

So you want cat9k be as root is not happened because nexus to protect root it use root guard which make any sw connect to vpc not be root for this domain.

 

Highlighted

Thanks MHM,

I understand what you say, but it doesn't seem to be true.

I have 2 nexuses form vPC, they connect to another 2 nexuses in vPC, and the 2nd vPC is elected as the Root Bridge while the 1st vPC is connected both to 2nd vPC and to 9K but he will choose 2nd vPC as the Root Bridge, from what you stated - both nexuses should be elected as the Root therefore all the switches in the topology would be a "SELF ROOT" but in my scenario only 1 vPC is the Root and the 9K is also a Root.

Also, we didn't configured any root guard on any of our switches.

 

please see again the topology I attached.

 

 

I would add a configuration but its basically the simplest configuration you can think of:

 

 

CAT9K:

 

C9300-BackBone# show run int po50
Building configuration...

Current configuration : 158 bytes
!
interface Port-channel50
description **LACP TO VPC DOMAIN 5**
switchport trunk allowed vlan 101,134,200,201,250-254,1105,1150
switchport mode trunk
end

 

C9300-BackBone# show spanning-tree vlan 101

VLAN0101
Spanning tree enabled protocol rstp
Root ID Priority 20581
Address cc7f.76c9.c200
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 20581 (priority 20480 sys-id-ext 101)
Address cc7f.76c9.c200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/23 Desg FWD 4 128.23 P2p Edge
Gi1/0/24 Desg FWD 4 128.24 P2p Edge
Gi2/0/23 Desg FWD 4 128.119 P2p Edge
Gi2/0/24 Desg FWD 4 128.120 P2p Edge
Po1 Desg FWD 1 128.2281 P2p
Po2 Desg FWD 1 128.2282 P2p
Po5 Desg FWD 3 128.2285 P2p Peer(STP)
Po20 Desg FWD 3 128.2300 P2p Peer(STP)
Po24 Desg FWD 3 128.2304 P2p Peer(STP)
Po26 Desg FWD 3 128.2306 P2p Peer(STP)
Po50 Desg FWD 1 128.2330 P2p

 

C9300-BackBone# show run | section span
spanning-tree mode rapid-pvst
spanning-tree extend system-id
no spanning-tree vlan 194,252-253,341-352,500-503,510,600-624,626-628,630-655
no spanning-tree vlan 657-692,787,790-793,801,805-808,895-896,907,1102-1107
no spanning-tree vlan 1110,1114-1116,1119-1124,1126,1140-1141,1150,1161-1163
no spanning-tree vlan 1188,1191,1807-1808,1900-1904,1906-1907,2000-2005,3001
no spanning-tree vlan 3990,3992-3999
spanning-tree vlan 1 priority 8192
spanning-tree vlan 2-49,51-99,151,153-154,156-158,162-164,166 priority 24576
spanning-tree vlan 167-170,172-197,199,203-207,209-211,214-222 priority 24576
spanning-tree vlan 224-250,252-308,310,312-1000,1903 priority 24576
spanning-tree vlan 50,100-150,152,155,159-161,165,171,198,200 priority 20480
spanning-tree vlan 201-202,208,212-213,223,251,309,311 priority 20480
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
spanning-tree portfast
C9300-BackBone#
C9300-BackBone#


C9300-BackBone# show run | section root
C9300-BackBone#

 

 

 

 

 

1st vPC Nexus Primary:

 

Rack_3-10G# show run int po7

!Command: show running-config interface port-channel7
!Time: Wed Oct 28 09:46:15 2020

version 6.0(2)N2(1b)

interface port-channel7
description ** Connection to 9300-BB**
switchport mode trunk
switchport trunk allowed vlan 101,134,200-201,250-254,1105,1150
vpc 7

 


Rack_3-10G# show run int po6

!Command: show running-config interface port-channel6
!Time: Wed Oct 28 09:46:23 2020

version 6.0(2)N2(1b)

interface port-channel6
description **Trunk to 3rd Nexus vPC**
switchport mode trunk
speed 10000
vpc 6

 

Rack_3-10G# show run int po10

!Command: show running-config interface port-channel10
!Time: Wed Oct 28 09:46:25 2020

version 6.0(2)N2(1b)

interface port-channel10
description 2nd Nexus vPC (acting as Root)
switchport mode trunk
switchport trunk allowed vlan 101,134,200-201,250-254,1105,1150
vpc 10

 

Rack_3-10G# show run int po200

!Command: show running-config interface port-channel200
!Time: Wed Oct 28 09:46:29 2020

version 6.0(2)N2(1b)

interface port-channel200
description VPC
switchport mode trunk
spanning-tree port type network
vpc peer-link

 

Rack_3-10G# show spanning-tree vlan 101

VLAN0101
Spanning tree enabled protocol rstp
Root ID Priority 32869
Address 002a.6ad8.4e3c
Cost 1
Port 4105 (port-channel10)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32869 (priority 32768 sys-id-ext 101)
Address 8c60.4f37.a041
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po6 Desg FWD 1 128.4101 (vPC) P2p
Po7 Desg FWD 1 128.4102 (vPC) P2p
Po10 Root FWD 1 128.4105 (vPC) P2p
Po200 Desg FWD 1 128.4295 (vPC peer-link) Network P2p

 

 

Rack_3-10G# show run | section root
snmp-server enable traps bridge newroot
Rack_3-10G#

 

Rack_3-10G# show run | section span
spanning-tree vlan 250,252 priority 24576
spanning-tree vlan 251 priority 4096
spanning-tree vlan 253 priority 20480
spanning-tree port type network
Rack_3-10G#

 

 

 

 

 

 

 

1st vPC Nexus Secondary:

 

Rack_4-10G-2# show run int po6

!Command: show running-config interface port-channel6
!Time: Wed Oct 28 10:44:25 2020

version 7.0(4)N1(1)

interface port-channel6
description **3rd vPC nexuses**
switchport mode trunk
speed 10000
vpc 6

 

Rack_4-10G-2# show run int po7

!Command: show running-config interface port-channel7
!Time: Wed Oct 28 10:44:27 2020

version 7.0(4)N1(1)

interface port-channel7
description ** Connection To 9300-BB**
switchport mode trunk
switchport trunk allowed vlan 101,134,200-201,250-254,1105,1150
vpc 7

 

Rack_4-10G-2# show run int po10

!Command: show running-config interface port-channel10
!Time: Wed Oct 28 10:44:29 2020

version 7.0(4)N1(1)

interface port-channel10
description Connection to 2nd vPC (current Root - shouldnt be)
switchport mode trunk
switchport trunk allowed vlan 101,134,200-201,250-254,1105,1150
vpc 10

 

Rack_4-10G-2# show run int po200

!Command: show running-config interface port-channel200
!Time: Wed Oct 28 10:44:32 2020

version 7.0(4)N1(1)

interface port-channel200
description VPC
switchport mode trunk
spanning-tree port type network
vpc peer-link

 

 

Rack_4-10G-2# show spanning-tree vlan 101

VLAN0101
Spanning tree enabled protocol rstp
Root ID Priority 32869
Address 002a.6ad8.4e3c
Cost 2
Port 4295 (port-channel200)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32869 (priority 32768 sys-id-ext 101)
Address 8c60.4fc6.8841
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po6 Desg FWD 1 128.4101 (vPC) P2p
Po7 Desg FWD 1 128.4102 (vPC) P2p
Po10 Root FWD 1 128.4105 (vPC) P2p
Po200 Root FWD 1 128.4295 (vPC peer-link) Network P2p

 

 

 

Rack_4-10G-2# show run | section span
spanning-tree port type network
Rack_4-10G-2#

 

Rack_4-10G-2# show run | section root
snmp-server enable traps bridge newroot
Rack_4-10G-2#

 

 

 

 

 

 

2nd vPC Nexus Primary  + Current Root Bridge that shouldn't be the actual Root:

 

Metro014-10G# show run int po5

!Command: show running-config interface port-channel5
!Time: Wed Oct 28 10:01:59 2020

version 5.2(1)N1(4)

interface port-channel5
description ** Connection to 1st vPC Nexus**
switchport mode trunk
switchport trunk allowed vlan 101,134,200-201,250-254,1105,1150
vpc 5

 

Metro014-10G# show run int po100

!Command: show running-config interface port-channel100
!Time: Wed Oct 28 09:57:39 2020

version 5.2(1)N1(4)

interface port-channel100
description vPC-Connection-Nexus
switchport mode trunk
spanning-tree port type network
speed 10000
vpc peer-link

 

Metro014-10G# show vpc role

vPC Role status
----------------------------------------------------
vPC role : primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:0f
vPC system-priority : 32667
vPC local system-mac : 00:2a:6a:d8:4e:3c
vPC local role-priority : 500
Metro014-10G#

 

 

 

Metro014-10G# show spanning-tree vlan 101

VLAN0101
Spanning tree enabled protocol rstp
Root ID Priority 32869
Address 002a.6ad8.4e3c
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32869 (priority 32768 sys-id-ext 101)
Address 002a.6ad8.4e3c
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po5 Desg FWD 1 128.4100 (vPC) P2p
Po50 Desg FWD 1 128.4145 (vPC) P2p
Po51 Desg FWD 1 128.4146 (vPC) P2p
Po100 Desg FWD 1 128.4195 (vPC peer-link) Network P2p
Eth1/7 Desg FWD 2 128.135 P2p

 

 

Metro014-10G# show run | sec span
spanning-tree port type edge default
spanning-tree loopguard default
spanning-tree vlan 251,253-254 priority 24576
spanning-tree vlan 252 priority 49152
spanning-tree port type network
Metro014-10G#

 

Metro014-10G# show run | sec root
snmp-server enable traps bridge newroot
Metro014-10G#

 

 

 

 

2nd vPC Nexus Secondary  + Current Root Bridge that shouldn't be the actual Root:

 

Metro014-10G-2# show run int po5

!Command: show running-config interface port-channel5
!Time: Wed Oct 28 10:02:56 2020

version 7.0(4)N1(1)

interface port-channel5
description **Connection to 1st vPC nexus**
switchport mode trunk
switchport trunk allowed vlan 101,134,200-201,250-254,1105,1150
vpc 5


Metro014-10G-2# show run int po100

!Command: show running-config interface port-channel100
!Time: Wed Oct 28 10:02:59 2020

version 7.0(4)N1(1)

interface port-channel100
description Connection-Nexus
switchport mode trunk
spanning-tree port type network
speed 10000
vpc peer-link

 

 

Metro014-10G-2# show spanning-tree vlan 101

VLAN0101
Spanning tree enabled protocol rstp
Root ID Priority 32869
Address 002a.6ad8.4e3c
Cost 1
Port 4195 (port-channel100)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32869 (priority 32768 sys-id-ext 101)
Address 8c60.4fa7.5b01
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po5 Desg FWD 1 128.4100 (vPC) P2p
Po50 Desg FWD 1 128.4145 (vPC) P2p
Po51 Desg FWD 1 128.4146 (vPC) P2p
Po100 Root FWD 1 128.4195 (vPC peer-link) Network P2p
Eth1/7 Desg FWD 2 128.135 P2p

 

 

Metro014-10G-2# show run | section span
spanning-tree port type edge default
spanning-tree loopguard default
spanning-tree vlan 251-254 priority 24576
spanning-tree port type network
Metro014-10G-2#

 

 

Metro014-10G-2# show run | section root
snmp-server enable traps bridge newroot
snmp-server enable traps stpx root-inconsistency
Metro014-10G-2#

 

 

 

 

 

I Think i included every neccesary detail, I showed only vlan 101 , but all of the vlans included are showing exactly the save thing.

 

 

Thanks you very much for your help!

Highlighted

Hi,

 

Based on your information, if we don't think about the C9300-BackBone. The VLAN101 spanning-tree instance are converged between three pair of Nexus. All Nexus can receive and accept the inferior BPDU sent from Metro014-10G, so they all elect  Metro014-10G (002a.6ad8.4e3c) as root bridge in VLAN101 instance.

 

However, you are expecting more inferior BPDU sent from C9300-BackBone connecting to Rack_3-10G & Rack_4-10G-2 [Port-Channel 7/vpc 7], the BPDU should flood to other Nexus, and so C9300-BackBone should become the root bridge on VLAN101. But, in your case, it does not.

 

It's something wrong between C9300's Po 50 and Rack_3-10G / Rack_4-10G-2's Po7

Could you share:

 

- the commands "show spanning-tree interface Po50 detail" on C9300.

- the commands "show spanning-tree interface Po7 detail" on Rack_3-10G & Rack_4-10G-2

- are you connecting C9300 to Rack_3-10G / Rack_4-10G-2 directly? Any transparent device (E.g. transparent firewall) in between them?

 

 

 

 

 

Highlighted

Hi ngkin,

Thanks for your reply.

 

all of the switches are directly connected exactly in the way I posted except C9300 being a stack of 2 switches via StackWise:

 

C9300-BackBone# show switch detail
Switch/Stack Mac Address : cc7f.76c9.c200 - Local Mac Address
Mac persistency wait time: Indefinite
H/W Current
Switch# Role Mac Address Priority Version State
-------------------------------------------------------------------------------------
*1 Active cc7f.76c9.c200 2 V03 Ready
2 Standby cc7f.76b2.e680 1 V03 Ready

 

Stack Port Status Neighbors
Switch# Port 1 Port 2 Port 1 Port 2
--------------------------------------------------------
1 OK OK 2 2
2 OK OK 1 1

 

 

 

 

 

 

 

here I will ad what you requested with extra information about the 9300 stack:

 

C9300:

 

C9300-BackBone#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 28
Number of aggregators: 28

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/1/4(D) Te1/1/7(P) Gi2/1/4(D)
Te2/1/7(P)
2 Po2(SU) LACP Gi1/1/1(D) Gi1/1/2(D) Te1/1/8(P)
Gi2/1/1(D) Gi2/1/2(D) Te2/1/8(P)
3 Po3(SD) -
4 Po4(SD) -
5 Po5(SU) LACP Te1/1/2(P) Te2/1/2(P)
6 Po6(SD) -
7 Po7(SD) -
8 Po8(SD) -
9 Po9(SD) -
11 Po11(SD) -
12 Po12(SD) -
13 Po13(SD) LACP Gi2/0/22(D)
14 Po14(SD) LACP Gi2/0/21(D)
15 Po15(SD) -
16 Po16(SD) -
17 Po17(SD) -
18 Po18(SD) -
20 Po20(SU) LACP Gi1/0/46(D) Te1/1/1(P) Te2/1/1(P)
24 Po24(SU) LACP Gi1/0/3(P) Gi2/0/3(P) Gi2/0/48(D)
25 Po25(SU) LACP Gi1/0/8(P) Gi2/0/8(P)
26 Po26(SU) LACP Gi1/0/37(P) Gi2/0/37(P)
28 Po28(SD) LACP Gi2/0/10(D)
39 Po39(SU) LACP Gi2/0/28(P) Gi2/0/36(P)
40 Po40(SU) LACP Gi1/0/28(P) Gi1/0/36(P)
41 Po41(SU) LACP Gi1/0/27(P) Gi2/0/27(P)
42 Po42(SU) LACP Gi1/0/42(P) Gi2/0/42(P)
48 Po48(SD) LACP Gi1/0/1(D) Gi1/0/2(D) Gi2/0/1(D)
Gi2/0/2(D)
50 Po50(SU) LACP Gi1/1/3(D) Te1/1/3(P) Gi2/1/3(D)
Te2/1/3(P)

 

 

 

 

C9300-BackBone#show spanning-tree interface port-channel 50 detail
Port 2330 (Port-channel50) of VLAN0101 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 20581, address cc7f.76c9.c200
Designated bridge has priority 20581, address cc7f.76c9.c200
Designated port id is 128.2330, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 2806352, received 2806645

 

Port 2330 (Port-channel50) of VLAN0134 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 20614, address cc7f.76c9.c200
Designated bridge has priority 20614, address cc7f.76c9.c200
Designated port id is 128.2330, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 695039, received 695115

 

Port 2330 (Port-channel50) of VLAN0200 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 20680, address cc7f.76c9.c200
Designated bridge has priority 20680, address cc7f.76c9.c200
Designated port id is 128.2330, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 733926, received 734003

 

Port 2330 (Port-channel50) of VLAN0201 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 20681, address cc7f.76c9.c200
Designated bridge has priority 20681, address cc7f.76c9.c200
Designated port id is 128.2330, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 695039, received 695115

 

Port 2330 (Port-channel50) of VLAN0250 is root forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 24826, address 8c60.4f37.a041
Designated bridge has priority 24826, address 0023.04ee.be0a
Designated port id is 144.6, designated path cost 0
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 12, received 3359688

 

Port 2330 (Port-channel50) of VLAN0251 is root forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 4347, address 8c60.4f37.a041
Designated bridge has priority 4347, address 0023.04ee.be0a
Designated port id is 144.6, designated path cost 0
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 134, received 3359877

 

 

 

 

 

 

 

1st Nexus vPC Primary:

 

Rack_3-10G# show spanning-tree interface port-channel 7 detail

Port 4102 (port-channel7, vPC) of VLAN0101 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32869, address 002a.6ad8.4e3c
Designated bridge has priority 32869, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 2806863, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0134 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32902, address 002a.6ad8.4e3c
Designated bridge has priority 32902, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 695302, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0200 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32968, address 002a.6ad8.4e3c
Designated bridge has priority 32968, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 734200, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0201 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32969, address 002a.6ad8.4e3c
Designated bridge has priority 32969, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 695300, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0250 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 24826, address 8c60.4f37.a041
Designated bridge has priority 24826, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 3360016, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0251 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 4347, address 8c60.4f37.a041
Designated bridge has priority 4347, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 2
Link type is point-to-point by default
BPDU: sent 3360016, received 3

 

Port 4102 (port-channel7, vPC) of VLAN0252 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 24828, address 547f.eee9.03fc
Designated bridge has priority 24828, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 3360015, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0253 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 20733, address 8c60.4f37.a041
Designated bridge has priority 20733, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 3360015, received 0

 

Port 4102 (port-channel7, vPC) of VLAN1105 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 33873, address 002a.6ad8.4e3c
Designated bridge has priority 33873, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 734200, received 0

 

Port 4102 (port-channel7, vPC) of VLAN1150 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 33918, address 002a.6ad8.4e3c
Designated bridge has priority 33918, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 695301, received 0

 

 

 

 

 

 

 

 

 

 

1st Nexus vPC Secondary:

 

Rack_4-10G-2# show spanning-tree interface port-channel 7 detail

Port 4102 (port-channel7, vPC) of VLAN0101 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32869, address 8c60.4f37.a041
Designated bridge has priority 32869, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0134 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32902, address 002a.6ad8.4e3c
Designated bridge has priority 32902, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0200 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32968, address 002a.6ad8.4e3c
Designated bridge has priority 32968, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0201 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32969, address 002a.6ad8.4e3c
Designated bridge has priority 32969, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0250 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 24826, address 8c60.4f37.a041
Designated bridge has priority 24826, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0251 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 4347, address 8c60.4f37.a041
Designated bridge has priority 4347, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0252 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 24828, address 547f.eee9.03fc
Designated bridge has priority 24828, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN0253 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 20733, address 8c60.4f37.a041
Designated bridge has priority 20733, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN1105 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 33873, address 002a.6ad8.4e3c
Designated bridge has priority 33873, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

Port 4102 (port-channel7, vPC) of VLAN1150 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 33918, address 002a.6ad8.4e3c
Designated bridge has priority 33918, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 0
Link type is point-to-point by default
BPDU: sent 0, received 0

 

 

 

 

It looks very odd that our nexus just ignore those BPDU's like they are not compatible with each other which I asummed before (and I didn't had  time to SPAN that interface yet) , but LINK TYPE is displayed as P2P anyway so its very unlikely that the Nexus vPC thing that PO7 is an egde TYPE.

Highlighted

vPC5500 to vPC5500 is DCI.

vPC5500 to vPC5000 is double-sided vPC,

double-sided the DIS. (aggregate layer nexus is the root primary & secondary), and ACC. nexus is not elect as root.

 

Highlighted

Hi MHM,

I know a little bit about DC  but I'm not a DC network engineer, more of an  "Enterprise" one, your explanations and terminologics doesn't gives me any clue or any idea what could be the problem.

 

I would really appreciate if you could explain to me more preciously what's the problem as you seem to already explain how to "fix" it.

 

Thanks you very much of your time :]

 

 

Highlighted

I currently have no idea why BPDU is not seen on vPC Primary even they are connected directly. I also cannot reproduce the issue on lab.

 

C9300:

 

Port 2330 (Port-channel50) of VLAN0101 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.2330.
Designated root has priority 20581, address cc7f.76c9.c200
Designated bridge has priority 20581, address cc7f.76c9.c200
Designated port id is 128.2330, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 2806352, received 2806645

Primary's VPC

Port 4102 (port-channel7, vPC) of VLAN0101 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32869, address 002a.6ad8.4e3c
Designated bridge has priority 32869, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 2806863, received 0

 

Hope others could spot the issue that we missed.

Highlighted

Thanks for trying.

 

I couldn't capture the traffic, but using debugs it seems Nexus doesn't receive any BPDU - like its not recognizing the BPDU's.

when i issue "debug spanning-tree bpdu-rx interface port-channel 7" , the device displays messages received on PO6 or PO200 (for some reason....) but nothing on PO7.

 

the ports are up and working, there isn't a Unidirectional link between the devices.

Highlighted

Port 4102 (port-channel7, vPC) of VLAN0101 is designated forwarding
Port path cost 1, Port priority 128, Port Identifier 128.4102
Designated root has priority 32869, address 002a.6ad8.4e3c
Designated bridge has priority 32869, address 8c60.4f37.a041
Designated port id is 128.4102, designated path cost 1
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 2806863, received 0


If this is  primary vPC which is root, check the secondary vPC
will see that the BPDU will increase, check this and reply to me.

Content for Community-Ad