ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
615
Views
0
Helpful
10
Replies
Highlighted

VPC Peer Links

I have 2 Nexus 5548s and 2 Nexus 91380s that I am setting up a VPC peer link on.  I am having a bit of trouble figuring out exactly how to do this as I rarely use VPCs.  Below are the configurations I have for the switches, any help or suggestions finalizing this is much appreciated.  I believe that the last thing I need to do is get the vpc peer link set on the port channel from the 2 91380s, but if not please let me know.

 

Nexus 5548 *.*.*.8

vpc domain 12
  role priority 1000
  system-priority 1000
  peer-keepalive destination 10.18.65.9

 

Nexus 5548 *.*.*.9

vpc domain 12
  role priority 1000
  system-priority 1000
  peer-keepalive destination 10.18.65.8

 

Nexus 91380 *.*.*.15

interface port-channel16
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  spanning-tree port type network
  vpc peer-link

N93180-C4-2-2# sh run int Eth1/44-46

interface Ethernet1/44
  description Link_to_sw-C4-1-2-5548-A
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  channel-group 16 mode active
  no shutdown

interface Ethernet1/45
  description Link_to_sw-C4-1-2-5548-A
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  channel-group 16 mode active
  no shutdown

interface Ethernet1/46
  description Link_to_sw-C4-1-2-5548-A
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  channel-group 16 mode active
  no shutdown

vpc domain 12
  role priority 1000
  system-priority 1000
  peer-keepalive destination 10.18.65.16

 

N93180-C4-2-2# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 12
Peer status                       : peer link is down
vPC keep-alive status             : Suspended (Destination IP not reachable)
Configuration consistency status  : failed
Per-vlan consistency status       : success
Configuration inconsistency reason: Consistency Check Not Performed
Type-2 inconsistency reason       : Consistency Check Not Performed
vPC role                          : none established
Number of vPCs configured         : 0
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Disabled (due to peer configuration)
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po16   up  

 

Nexus 91380 *.*.*.16


interface port-channel15
  description Link_to_sw-C4-2-2-C93180A
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  spanning-tree port type network
  vpc peer-link

 

N93180-C4-2-2# sh run int Eth1/44-46

interface Ethernet1/44
  description Link_to_sw-C4-1-2-5548B
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  channel-group 15 mode active
  no shutdown

interface Ethernet1/45
  description Link_to_sw-C4-1-2-5548B
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  channel-group 15 mode active
  no shutdown

interface Ethernet1/46
  description Link_to_sw-C4-1-2-5548B
  switchport mode trunk
  switchport trunk allowed vlan 951,1938
  channel-group 15 mode active
  no shutdown

vpc domain 12
  role priority 1000
  system-priority 1000
  peer-keepalive destination 10.18.65.15


N93180-C4-2-2# sh vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 12
Peer status                       : peer link is down
vPC keep-alive status             : Suspended (Destination IP not reachable)
Configuration consistency status  : failed
Per-vlan consistency status       : success
Configuration inconsistency reason: Consistency Check Not Performed
Type-2 inconsistency reason       : Consistency Check Not Performed
vPC role                          : none established
Number of vPCs configured         : 0
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Disabled (due to peer configuration)
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po15   up     -

 

 

 

So as I said above the final step of this would be setting up the port channel and setting the vpc peer link to the Nexus 5548 from the 91380s which are Eth1/1 and Eth1/2.

10 REPLIES 10
Highlighted
VIP Mentor

Re: VPC Peer Links

You looking to setup a enhanced vPC, for that you need different domain name for Nexus 5K ( domain 12 for 5K domain 13 for 9K)

 

when you building vPC order of command order very important.

 

1. lets build separate 5K vpc

2. now build 9K vpc

 

check is both working. if they working

 

then have connection between 5K and 9K - all should go 1 Port-channel and vPC.

 

attached document for reference.

 

 

 

BB
*** Rate All Helpful Responses ***
Highlighted

Re: VPC Peer Links

Thank you for the reply, the pdf is not loading for some reason, probably due to the work laptop restrictions.  I wanted to make sure I followed what you said.

Set up the 5k Domain, 12 on both nexus 5k, then set up the 9k domain of 13 for both of them.  Each destination should be pointing back to each other (5k to 5k, 9k to 9k) and then once I have done that 1 port channel should be set up on all 4 devices (ex: po50) and set as the channel-group 50 mode active for all interfaces that need to be in this vpc peer link (ports 1/1-2 on the nexus 5ks) and ports 1/44-46, 6 total interfaces on the 9k, 4 total interfaces on the 5k.

Again, thanks in advance for any advice

Highlighted
VIP Mentor

Re: VPC Peer Links

Do you still have issue ? if so here is high level config

 

5K1 ------(1/1-2 vpc peer link)----------5K1

 

9K1 ------(1/4-46 vpc peer link)----------9K2

 

 

attached quick diagram

BB
*** Rate All Helpful Responses ***
Highlighted

Re: VPC Peer Links

What do you mean vpc only in the diagram from all interfaces other than. The peer link?

 

I have the 2 5k interfaces set as a vpc domain (domain 12  for 5m) pointing to each other with the destination.  I have the same on the 9ks (domain 13), I then have a port channel (30) set up that I am setting all other interfaces connecting to the switches for this as channel group 30 mode active on the 5ks and 9ks.

 

Hopefully that helps explain it.  I will be setting this configuration up tomorrow and hope to have it all thought out and set before then.

Highlighted
VIP Mentor

Re: VPC Peer Links

PO 30 between 5K - 9K ( all 4 connection to be under PO-30 ) - this what i mean by vPC only.

 

check the config and post full configuration to verify

 

also post after any changes 

 

show vpc - both 5k and 9K

 

show port-channel summary interface port-channel 30 from 5K and 9K to check

 

Note : make sure you have vpc peerlink up on both 5K and 9K before you connection or bring Portchannel 30.

 

 

 

BB
*** Rate All Helpful Responses ***
Highlighted

Re: VPC Peer Links

I have attached all of the configs for the 4 switches that are dealing with this VPC/Enhanced VPC.  I am still having some issue though.  I hope this is better than pasting all the configs here in a confusing manor

Nexus 5ks show vpc up and working, the Nexus 9ks show it not up and working but both were configured the same.

 

I am having issues with lacp too that I am confused about.  I have tried passive, I have tried active and I have tried no lacp suspend-individual yet still getting suspended interfaces.  These issues are showing up on Nexus 5k .9 and Nexus 9k .16.

 

Any help resolving this quickly is greatly appreciated as I have to have this up and running by the end of my day (2.5 hours from now)

Highlighted

Re: VPC Peer Links

In addition to the doc I uploaded here is the sh port channel summary you asked for:

 

Nexus 5k *.*.*.8 Port Channel Sum
COUSOC-L-SFSW01-N5448-C4-1-2# sh port-channel summary interface port-channel 30
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
30    Po30(SU)    Eth      LACP      Eth1/1(I)    Eth1/2(I)    Eth1/3(I)
                                     Eth1/4(I)    Eth1/5(P)    Eth1/6(s)
                                     Eth1/7(I)
COUSOC-L-SFSW01-N5448-C4-1-2# sh port-channel summary interface port-channel 31
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
31    Po31(SU)    Eth      LACP      Eth1/27(P)   Eth1/28(P)


Nexus 5k*.*.*.9 Port Channel Sum

COUSOC-L-SFSw02-N5448-C4-1-2# show port-channel summary interface port-channel 30
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
30    Po30(SD)    Eth      LACP      Eth1/1(I)    Eth1/2(I)    Eth1/3(I)
                                     Eth1/4(I)    Eth1/5(s)    Eth1/6(s)
                                     Eth1/7(I)

COUSOC-L-SFSw02-N5448-C4-1-2# show port-channel summary interface port-channel 31
-------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
31    Po31(SU)    Eth      LACP      Eth1/27(P)   Eth1/28(P)

 

Nexus 9k*.*.*.15 Port Channel Sum
COUSOC-L-SFSW01-N93180-C4-2-2# show port-channel summary interface port-channel 30
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
30    Po30(SU)    Eth      LACP      Eth1/47(P)   Eth1/48(s)

COUSOC-L-SFSW01-N93180-C4-2-2# show port-channel summary interface port-channel 31
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
31    Po31(SU)    Eth      LACP      Eth1/44(P)   Eth1/45(P)   Eth1/46(P)

 

.Nexus 9k*.*.*.16 Port Channel Sum

COUSOC-L-SFSW02-N93180-C4-2-2# show port-channel summary interface port-channel 30
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
30    Po30(SD)    Eth      LACP      Eth1/47(s)   Eth1/48(s)

COUSOC-L-SFSW02-N93180-C4-2-2# show port-channel summary interface port-channel 31
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------
31    Po31(SU)    Eth      LACP      Eth1/44(P)   Eth1/45(P)   Eth1/46(P)

Highlighted
Hall of Fame Expert

Re: VPC Peer Links

vPC keep-alive status             : Suspended (Destination IP not reachable)

On the 9ks, what physical port are using for vPC-keep alive? It is usually the out-of-band management port.

HTH

 

Highlighted

Re: VPC Peer Links

vPC keep-alive status : Suspended (Destination IP not reachable) that means the somehow your routing is not working.

Here, by default Management VRF is chosen to route. So please check what VRF you are using in order to route the keepalive link traffic.

You can check if any firewall in between that might be blocking the default port UDP / 3200 used by the keepalive process.

 

Mode of operations for vPC

* domain name

* bring the peer keep-alive link

* peer link

* check for the consistency behavior.

* bring the members ports

 

Highlighted
VIP Mentor

Re: VPC Peer Links

Hello


@Hogan.BrendanT1 wrote:

PC domain id                     : 12
Peer status                       : peer link is down
vPC keep-alive status             : Suspended (Destination IP not reachable)
Configuration consistency status  : failed


Suggest you create a peer keepalive link and put this is a vrf, Also append peer switch command  so to have both cores the same stp priority 


core 1

conf t
vrf context VPC-Keepalive
vpc domain 12
peer-switch
peer-keepalive destination 10.18.65.9 source 10.18.65.10 vrf VPC-Keepalive
role priority 1

 

int xx
vrf member VPC-Keepalive
ip address 10.18.65.9/30

 

core2

conf t
vrf context VPC-Keepalive
vpc domain 12
peer-switch
peer-keepalive destination 10.18.65.10 source 10.18.65.9 vrf VPC-Keepalive

 

int xx
vrf member VPC-Keepalive
ip address 10.18.65.10/30

 

Both switches

spanning-tree vlan 1-x priority xxx

 

interface x/x
description vpc peer-link int x/x
channel-group 1 mode active

 

interface x/x
description vpc peer-link int x/x
channel-group 1 mode active

 

interface port-channel1
description vpc PC peer-link
switchport mode trunk
switchport trunk allowed vlan x-x
spanning-tree port type network
vpc peer-link



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Content for Community-Ad