Showing results for 
Search instead for 
Did you mean: 

VTP Oddities Between IOSXE and NXOS

Hi Everyone, 

 I've got an issue that no amount of Googling and research has turned up a solution for and I was hoping someone here would be able to provide some assistance. I have a 3850 stack acting as the VTP server. Connected to that are two Nexus 3Ks and off of those is a downstream 3650 configured as a VTP client. The two Nexus' are, as is default with those devices, running in VTP Transparent mode. All switches are members of the same VTP domain, with matching VTP passwords and VTP versions (I have verified this multiple times).


The issue: The downstream 3650 is not getting VTP updates from the 3850 stack and therefore its VLAN database is not dynamically updating as it should. I did some debugging (debug sw-vlan vtp packet) on the 3850 and the downstream 3650 and then added and removed a VLAN on the 3850. No VTP packets/events are triggered on the downstream 3650 but, strangely, the VLAN is also not created on the 3850 VTP server. On the 3850 the following message is generated:


unable to set em_id:6657 for vlan 300

unable to set em_id:6657 for vlan 301

unable to set em_id:6657 for vlan 302

unable to set em_id:6657 for vlan 303

unable to set em_id:6657 for vlan 304

 and so on and so on..........

I have found absolutely nothing pertaining to this error anywhere online and now I am just sitting here scratching my head like W.......T.......F.......?

Is this a bug or is there something else going on? I cannot reboot these devices currently as they are in a production environment.

Thanks for any assistance! 

VIP Mentor

Re: VTP Oddities Between IOSXE and NXOS

Could be a bug , check the release notes of your software versions your running , go to the caveats sections, it lists all known bugs ,
is the VTP feature turned on in NX-OS config , maybe it wont pass updates without that ? i dont use VTP we keep it all transparent so havent come across this issue

Re: VTP Oddities Between IOSXE and NXOS


 VTP feature is enabled. I will check the release notes and try and determine if the issue is in fact related to a bug. 



Hall of Fame Expert

Re: VTP Oddities Between IOSXE and NXOS


a conflict with internal used Vlans to create routed ports should not happen as those Vlans are taken from extended Vlan range.

You can check this

show vlan internal usage


as suggested by Mark you may need to enable the VTP feature on the Nexus to make them pass the VTP messages, but this does not explain the error you see on the C3850 VTP server.


How many Vlans are already defined in VTP ?

show vtp status


It is likely a bug I would not expect the C3850 to have limitations in the number of Vlans in VTP databae.


Hope to help




Re: VTP Oddities Between IOSXE and NXOS

HI Giuseppe and thank you for the response. We are nowhere near the max allowed number of VLANs. I think there are around 25-30 VLANs in the current configuration. I am also leaning toward the bug explanation. I completely rebuilt the VLAN database on the VTP server and even tried changing all devices to VTP v3 and I am still getting the same error. Also, the VTP feature is enabled on the Nexus switches. 

VIP Advisor

Re: VTP Oddities Between IOSXE and NXOS


Could be worth try deleting the vlan.dat from flash , reloading the switches and testing again, thats if you haven't already done it.?

kind regards

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
VIP Mentor

Re: VTP Oddities Between IOSXE and NXOS



not sure if you have already tried that, but if you configure VTPv3, on the 3850, try to use the 'force' keyword:


3850#vtp primary force


The 3650 client switch (if configured for VTPv3 also) should get a message informing the switch that the primary server has been configured, do you see that message (on the console or in the logs) ?

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards