cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2572
Views
0
Helpful
17
Replies
Highlighted
Beginner

WAP571 PoE+ Issue with 2960-X Switch

Site has multiple WAP571 access points (5 total) deployed each connected to a 2960X-24S-L switch. The WAP571 devices are the only devices connected to the 2960X. The WAP571 devices are all running the latest firmware -- 1.0.1.10. The 2960X is running 15.2(2) E6.

 

Every WAP571 device connects to the 2960X and boots properly but each AP is only obtaining 15W from the switch. The APs are unable to negotiate for 802.3at power from the switch which is preferable for the WAP571 devices. I have connected the WAP571 devices to an external PoE+ injector and they work fine with the injector obtaining 30W as expected but this is of course not the optimal solution.

 

There have been various posts about 802.3at negotiation issues between 2960X switches and various Cisco APs but there seems to be no solution. Recommendations in other threads have ranged from setting power inline static max 30000, setting power inline 2x-mode or disabling LLDP power management on the specific switch ports to which the APs are attached. None of these had any effect on the WAP571 devices with the 2960X switch with each AP still drawing only 15W confirmed by examining the switch using show power inline and also the Status page of each of the WAP571 devices. The switch reports each WAP571 as an IEEE PD class 4 device. Interestingly, when using power inline port max 30000, the switch reports 30W being delivered to the WAP571 but the AP still reports on its status page that is powered via 802.3af and not 802.3at.

 

Does anyone have any recommendations or know of a specific fix that will enable the WAP571 APs to work properly with the 2960X switch and obtain the maximum power on their respective ports? I have examined the release notes for the 2960X and found nothing that suggests this issue has been addressed in a subsequent release to 15.2(2) E6. The WAP571 devices are all current on the latest firmware release. The switch is rated for 370W and no other devices are using the switch so the switch has ample capacity to provide full power to the APs. Any help would be appreciated.

17 REPLIES 17
Highlighted
Rising star

Hi,

Have you tried rebooting the switch? That helped me once with different model switch.

HTH,
Meheretab
HTH,
Meheretab
Highlighted

 

Yes, re-booted the switch several times during the testing process. Have tried everything I can think of with LLDP, Bonjour, port power settings, cable length (Cisco recommended at one point it might work with cables longer than 50 feet), etc. all without any luck. Using a 3rd party 802.3at injector with the WAP571 worked just fine as expected. I just find it odd that two Cisco products (premium level commercial grade products) can't play well together.

Highlighted
Beginner

Hi Mate,
try to Disable the CDP and run it on LLDP only.
Highlighted

 

Thanks for the recommendation. I do not believe that the WAP571 supports CDP, only LLDP, but I will disable CDP on the 2960X and see if that makes any difference. You can enable and disable LLDP on the WAP571 but there is no setting for CDP and the 2960X reports no CDP neighbors so I do not believe the WAP571 utilizes CDP.

 

Using the debug ilpower powerman command on the switch, you can observe the PoE negotiation between the WAP571 and 2960X and see that the WAP571 is requesting 25.5W but is only able to obtain 15W from the switch (the debug message indicates the LLDP request for power fails but does not elaborate on the reason). At first, I thought the WAP571 might be the device at fault but now I suspect an issue with the 2960X. I attached a Fluke LinkRunner to the switch and configure it for Class 4 PoE testing requesting 25.5W from the switch. It was also only able to obtain 15W from the switch -- same problem as the WAP571.

 

All PoE ports on the 2960X were set to auto for testing. In further testing, I found that if I configured the port for static PoE using power inline static, the LinkRunner was able to negotiate and obtain 25.5W and that the WAP571 was able to obtain more than 15W. From what I can tell on the specifications for the WAP571, its maximum current draw is 18W so the 17W it is currently using might mean that it is getting the power it needs from the switch. It will run with 15W but that is not the optimal amount of power for the WAP571 if you want to use both ethernet interfaces and all radios at full power.

 

I am not sure why setting the ports to static for PoE works but auto and LLDP negotiation do not work properly. As I said earlier, I am leaning toward the 2960X as the problem and not the devices at this point but I plan to continue testing and examining the debug output from the 2960X for further clues.

Highlighted

Hi reesejacobs ,
I didn't stated correctly - yes please try to disable the CDP on the switch.
I have a similar issue but the catalyst is stating that its provides 17 W to the WAP.
The WAP needs peak power of 18W //25,5 are requested only at the startup.
Also please take a look if your switch is declaring Class 4 PoE , which should means an At Standard. Id its class 1-2 those are Af - and you need to change it.
If you are still experiencing issues, you could try use the WAP with a single Radio and it will run on Af 15,4 as well.

Best of luck !

Highlighted

The 2960X is definitely declaring as a Class 4 PSE -- I can verify this by examining the LLDP requests and responses between the switch and both the WAP571 and Fluke LinkRunner. As I said, once I configure the 2960X ports for static power, the WAP571 is able to obtain 17W and the LinkRunner is able to negotiate for 25.5W. With the power setting on the switch at the port level set to auto, none of the Class 4 devices requesting 25.5W are able to obtain that amount of power from the 2960X. The WAP571 only seems to report the minimal required elements of the LLDP protocol but the LinkRunner reports both the mandatory and optional protocol components. Following the LinkRunner LLDP negotiation for power with the port set to static, you can see that the LinkRunner is classified as a Class 4 PD requesting 25.5 and that the 2960X is classified as a Class 4 PSE. The LLDP neighbor detail for the LinkRunner confirms both the switch and device are configured correctly and that the power negotiation was successful.

 

Note also that on this 24-port 2960X PoE switch, it is rated for 370W and I believe is only capable of providing the maximum 30W on ports 1-12. All testing with the WAP571 and other devices have used ports in the range 1-12.

 

The 17W you are seeing for the WAP571 on your Catalyst is consistent with what I am seeing on the 2960X with the port power setting on static. The WAP571 seems to be operating fine. Interestingly, when you login to the management interface for the WAP571, it will warn you if the device is connected to an 802.3af PSE. The WAP571 does not report the amount of power it has obtained only whether its power source is 802.3af or 802.3at. Even when the 2960X port is set to static power and the WAP571 has obtained 17W, the WAP571 still reports its power source as 802.3af. I am not sure if the WAP571 is making the determination of power source based on the power level it has obtained or the response from the LLDP protocol.

 

Just to add some more intrigue to the issue, I disabled PoE on the switch port to which the WAP571 was connected and instead connected an 802.3at power injector inline. The WAP571 management interface reported it was connected to an 802.3at power source and it was quite happy. Since the management interface does not report the power draw for the WAP571, I was not able to confirm the actual amount of power it was drawing from the 802.3at power injector.

 

Lastly, I have tried varying cable lengths between the WAP571 and the 2960X from 1 meter to 70 meters and the cable length does not make any difference. Cable type is CAT6 and has been verified as capable of delivering 25.5W PoE using various non-Cisco test & verification devices.

Highlighted

Has anyone solved this problem?
I have the same error with WAP571 and WS-C2960X-24PD-L

Highlighted

hi, yes you have to enable lldp to the 2960. the wap is using lldp instead of the cdp protocol to negotiate the power settings.
by default lldp is not running on the 2960.
to enable go to config mode and issue the lldp run command to enable lldp on all ports

Highlighted

Hi,

 

I had a similar problem with a few 3802 (minimum 30W) and 3560-x switch.

In my case, the switch was capable of 802.3at or (POE+) only when was configured with 2 power supplies (1x1100W + 1x750W/ 2 x 1100W). While the switch was configured with only one PS (1100W), the APs were sucking only 15.4, but no other errors was shown in the logs, the APs were joining the controller but with the radios down.

 

You may want to check the specs, regarding the POE capabilities with different PS.

I suggest leaving only 3 APs connected, and see how it goes.

 

Kind regards,

Neo

 

 

 

 

Highlighted

WS-C2960X-24PD-L can not add a power supply
I tried with 1x WPA571 - works only on 802.3af :(

Highlighted

According to table 10 from https://www.cisco.com/c/en/us/products/collateral/switches/catalyst-2960-x-series-switches/data_sheet_c78-728232.html  your switch should be able to provide 30W per port for 12 APs.

 

Check the running-config and look for a line similar to power inline consumption default 15400.

 

Thanks,

 

Highlighted

Yes I know.

WAP571 on ports 7,8  

I set static

 

sh power inline

Module Available Used Remaining
(Watts) (Watts) (Watts)
------ --------- -------- ---------
1 370.0 60.0 310.0
Interface Admin Oper Power Device Class Max
(Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Gi1/0/1 auto off 0.0 n/a n/a 30.0
Gi1/0/2 auto off 0.0 n/a n/a 30.0
Gi1/0/3 auto off 0.0 n/a n/a 30.0
Gi1/0/4 auto off 0.0 n/a n/a 30.0
Gi1/0/5 auto off 0.0 n/a n/a 30.0
Gi1/0/6 auto off 0.0 n/a n/a 30.0
Gi1/0/7 static on 30.0 Ieee PD 4 30.0
Gi1/0/8 static off 30.0 n/a n/a 30.0
Gi1/0/9 auto off 0.0 n/a n/a 30.0
Gi1/0/10 auto off 0.0 n/a n/a 30.0
Gi1/0/11 auto off 0.0 n/a n/a 30.0
Gi1/0/12 auto off 0.0 n/a n/a 30.0
Gi1/0/13 auto off 0.0 n/a n/a 30.0
Gi1/0/14 auto off 0.0 n/a n/a 30.0
Gi1/0/15 auto off 0.0 n/a n/a 30.0
Gi1/0/16 auto off 0.0 n/a n/a 30.0
Gi1/0/17 auto off 0.0 n/a n/a 30.0
Gi1/0/18 auto off 0.0 n/a n/a 30.0
Gi1/0/19 auto off 0.0 n/a n/a 30.0
Gi1/0/20 auto off 0.0 n/a n/a 30.0
Gi1/0/21 auto off 0.0 n/a n/a 30.0
Gi1/0/22 auto off 0.0 n/a n/a 30.0
Gi1/0/23 auto off 0.0 n/a n/a 30.0
Gi1/0/24 auto off 0.0 n/a n/a 30.0

 

On auto

sh power inline

Gi1/0/7 auto on 15.4 Ieee PD 4 30.0
Gi1/0/8 auto off 0.0 n/a n/a 30.0

 

 

 

Highlighted

I do not have any additional information to report since the original post. The only workaround that comes close to a solution was to set inline power to static and with LLDP enabled the WAP571 devices were able to obtain 17W from the 2960X switch instead of the usual 15W on the default settings. However, when you login to the WAP571 devices, they still report they are powered via 802.3af and not 802.3at. The only success I have had with the WAP571 believing it is powered by 802.3at is by using an external 802.3at power injector (non-Cisco) to power the WAP571. Note that the specifications on the WAP571 indicate it draws a maximum of 18W so the 17W reported with power inline set to static is close to the maximum current draw of the WAP571 but apparently the WAP571 is still not convinced it is powered by 802.3at at least when powered from a C2960X switch.

 

A firmware update for the WAP571 was released over the weekend but apparently it only addresses the key reuse security issue with nothing in the release notes regarding PoE. I am not aware of any updates to the C2960X switches that would impact this problem.

Highlighted
Beginner

Hi There, 

I have the same issue with a 2960S switch running 15.0(2)SE11 and a WAP571E running 1.0.1.11 and also three WAP361-E-K9 V01 access points running 1.1.0.9.

The access point is identifying itself as a class 4 device and is stating that the power source is 802.3af and not 802.3at. 

I have tried numerous switch and access point firmwares. I have also tried the other suggestions around LLDP TLVs and 2x mode for power with no success. I would think it is just a matter of waiting until there is a firmware update for the switch/access point. 

I resorted to picking up a cheap TP-Link T1500G-10PS as a temporary measure for 802.3at supply to the access points which are now getting correct power.

 

Regards,

Jonathan

Content for Community-Ad