cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
499
Views
0
Helpful
4
Replies
josephschung
Beginner

WCCP and S160

I am trying to redirect web-cache to one S160 from a 2811 router.

The WCCP is configured as below.

ip wccp web-cache redirect-list IP password cisco

interface FastEthernet0/1
ip address 192.168.42.2 255.255.255.0
ip wccp web-cache redirect in
ip access-list extended IP
permit tcp any host 2.2.2.2 eq www

The WCCP result is listed below.

R1#sh ip wccp web det

WCCP Client information:

WCCP Client ID:          192.168.43.43

Protocol Version:        2.0

State:                   Usable

Initial Hash Info:       00000000000000000000000000000000

                         00000000000000000000000000000000

Assigned Hash Info:      FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                         FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

Hash Allotment:          256 (100.00%)

Packets s/w Redirected:  0

Connect Time:            00:03:26

Bypassed Packets

  Process:               0

  Fast:                  0

  CEF:                   0

  Errors:                0

R1#sh ip wccp web det   view

    WCCP Routers Informed of:

2.2.2.2

    WCCP Clients Visible:

192.168.43.43

    WCCP Clients NOT Visible:

-none-

R1#sh ip wccp web

Global WCCP information:

    Router information:

Router Identifier:                   2.2.2.2

Protocol Version:                    2.0

    Service Identifier: web-cache

Number of Service Group Clients:     1

Number of Service Group Routers:     1

ip access-list extended IP

permit tcp any host 2.2.2.2 eq www

Total Packets s/w Redirected:        0
  Process:                           0

  Fast:                              0

  CEF:                               0

Service mode:                        Open

Service access-list:                 -none-

Total Packets Dropped Closed:        0

Redirect access-list:                IP

Total Packets Denied Redirect:       0

Total Packets Unassigned:            0

Group access-list:                   -none-

Total Messages Denied to Group:      0

Total Authentication failures:       4

Total Bypassed Packets Received:     0

R1#sh ip access-lists

Extended IP access list IP

    10 permit tcp any host 2.2.2.2 eq www (1386 matches)

It seems WCCP is working. But, I do not understand why "Total Packets s/w Redirected" is zero. Is there any way to further check the issue?

Thanks!

4 REPLIES 4
rlima
Cisco Employee

Hi Joseph,

Based on the outputs below can you check if the "total authentication failures"  is incrementing?

IF this is incrementing it means that the WCCP password configured in the router and in the WCCP client are not matching and therefore no redirection will happen.

You can also check it in more details enabling two debug commands below off business  hours:

debug ip wccp packets

debug ip wccp events

R1#sh ip wccp web

Global WCCP information:

    Router information:

Router Identifier:                   2.2.2.2

Protocol Version:                    2.0

    Service Identifier: web-cache

Number of Service Group Clients:     1

Number of Service Group Routers:     1

ip access-list extended IP

permit tcp any host 2.2.2.2 eq www

Total Packets s/w Redirected:        0
  Process:                           0

  Fast:                              0

  CEF:                               0

Service mode:                        Open

Service access-list:                 -none-

Total Packets Dropped Closed:        0

Redirect access-list:                IP

Total Packets Denied Redirect:       0

Total Packets Unassigned:            0

Group access-list:                   -none-

Total Messages Denied to Group:      0

Total Authentication failures:       4

Total Bypassed Packets Received:     0

Regards

Rubens

Thanks Rubens for your advice.

Even though I remove the password, the router still does not do the redirection. Any other idea?

Thanks!

Hi Joseph,

Can you send me the output of the following commands please?

1.show      ip wccp

2.show      ip wccp interface detail

3.show ip wccp <service>service

4.show      ip wccp <service> detail

5.show access-list IP

Also were  you able to enable the WCCP debug commands?  If so, can  you send me the output of the "show logging"  please?

Thank you

Rubens

Sorry that I have some previous captured log only. I do not have access to the equipment at the movement.

==================


R1#sh ip wccp web-cache
Global WCCP information:
    Router information:
Router Identifier:                   2.2.2.2
Protocol Version:                    2.0

    Service Identifier: web-cache
Number of Service Group Clients:     1
Number of Service Group Routers:     1
Total Packets s/w Redirected:        0
  Process:                           0
  Fast:                              0
  CEF:                               0
Service mode:                        Open
Service access-list:                 -none-
Total Packets Dropped Closed:        0
Redirect access-list:                IP
Total Packets Denied Redirect:       0
Total Packets Unassigned:            0
Group access-list:                   -none-
Total Messages Denied to Group:      0
Total Authentication failures:       0
Total Bypassed Packets Received:     0

R1#sh ip wccp web det
WCCP Client information:
WCCP Client ID:          192.168.43.43
Protocol Version:        2.0
State:                   Usable
Initial Hash Info:       00000000000000000000000000000000
                         00000000000000000000000000000000
Assigned Hash Info:      FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
                         FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
Hash Allotment:          256 (100.00%)
Packets s/w Redirected:  0
Connect Time:            00:22:51
Bypassed Packets
  Process:               0
  Fast:                  0
  CEF:                   0
  Errors:                0

R1#sh ip wccp web det
WCCP Client information:
WCCP Client ID:          192.168.43.43
Protocol Version:        2.0
State:                   Usable
Initial Hash Info:       00000000000000000000000000000000
                         00000000000000000000000000000000
Assigned Hash Info:      FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
                         FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
Hash Allotment:          256 (100.00%)
Packets s/w Redirected:  0
Connect Time:            00:23:46
Bypassed Packets
  Process:               0
  Fast:                  0
  CEF:                   0
  Errors:                0

R1#sh ip debug           debug ip wccp eve
WCCP events debugging is on
R1#s debug ip wccp eve   pac
WCCP packet info debugging is on
R1#
R1#
R1#
R1#
R1#
R1#
*Feb  7 08:32:48.751: WCCP-EVNT:S00: Assignment wait timer started
*Feb  7 08:32:48.751: WCCP-EVNT:S00: Built new router view: 0 routers, 1 usable WCCP clients, change # 00000003
*Feb  7 08:32:48.751: WCCP-EVNT:S00: Router 2.2.2.2 removed.
*Feb  7 08:32:48.751: WCCP-EVNT:S00: Assignment wait timer started
*Feb  7 08:32:48.751: WCCP-EVNT:S00: Built new router view: 0 routers, 0 usable WCCP clients, change # 00000004
R1#
*Feb  7 08:32:48.751: %WCCP-1-SERVICELOST: Service web-cache lost on WCCP client 192.168.43.43
R1#
R1#
R1#
R1#debug ip wccp pacevepacevesh ip wccp web det
No information is available for the service.

R1#
R1#
R1#
R1#sh ip wccp web det
No information is available for the service.

R1#
*Feb  7 08:33:38.751: WCCP-EVNT:S00: Assignment wait timer expired
*Feb  7 08:33:38.811: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000093
R1#
*Feb  7 08:33:47.895: %WCCP-5-SERVICEFOUND: Service web-cache acquired on WCCP client 192.168.43.43
R1#
*Feb  7 08:33:47.895: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000093
*Feb  7 08:33:47.895: WCCP-EVNT:S00: Assignment wait timer started
*Feb  7 08:33:47.895: WCCP-EVNT:S00: Built new router view: 1 routers, 1 usable WCCP clients, change # 00000005
*Feb  7 08:33:47.895: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000094
R1#
*Feb  7 08:33:53.911: WCCP-EVNT:S00: Assignment wait timer stopped
*Feb  7 08:33:53.911: WCCP-EVNT:S00: Built new router view: 1 routers, 1 usable WCCP clients, change # 00000005
*Feb  7 08:33:53.915: WCCP-PKT:S00: Received valid Redirect_Assignment packet from 192.168.43.43 w/rcv_id 00000094
R1#
*Feb  7 08:33:57.923: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000094
*Feb  7 08:33:57.923: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000095
R1#
*Feb  7 08:34:07.919: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000095
*Feb  7 08:34:07.919: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000096
R1#
R1#
R1#
R1#
R1#
R1#sh ip wccp web det
WCCP Client information:
WCCP Client ID:          192.168.43.43
Protocol Version:        2.0
State:                   Usable
Initial Hash Info:       00000000000000000000000000000000
                         00000000000000000000000000000000
Assigned Hash Info:      FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
                         FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
Hash Allotment:          256 (100.00%)
Packets s/w Redirected:  0
Connect Time:            00:00:40
Bypassed Packets
  Process:               0
  Fast:                  0
  CEF:                   0
  Errors:                0

R1#
*Feb  7 08:34:17.915: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000096
*Feb  7 08:34:17.915: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000097
R1#
R1#
R1#
R1#
R1#
*Feb  7 08:34:27.907: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000097
*Feb  7 08:34:27.907: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000098
R1#
*Feb  7 08:34:37.907: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000098
*Feb  7 08:34:37.907: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 00000099
R1#
R1#
R1#
R1#
R1#sh ip wccp
Global WCCP information:
    Router information:
Router Identifier:                   2.2.2.2
Protocol Version:                    2.0

    Service Identifier: web-cache
Number of Service Group Clients:     1
Number of Service Group Routers:     1
Total Packets s/w Redirected:        0
  Process:                           0
  Fast:                              0
  CEF:                               0
Service mode:                        Open
Service access-list:                 -none-
Total Packets Dropped Closed:        0
Redirect access-list:                IP
Total Packets Denied Redirect:       0
Total Packets Unassigned:            0
Group access-list:                   -none-
Total Messages Denied to Group:      0
Total Authentication failures:       0
Total Bypassed Packets Received:     0

R1#
*Feb  7 08:34:47.903: WCCP-PKT:S00: Received valid Here_I_Am packet from 192.168.43.43 w/rcv_id 00000099
*Feb  7 08:34:47.903: WCCP-PKT:S00: Sending I_See_You packet to 192.168.43.43 w/ rcv_id 0000009A