cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
237
Views
0
Helpful
2
Replies
Sam Brynes
Beginner

What do the "udld enable" and "udld aggressive" global config commands do?

Judging from the descriptions, they should enable UDLD by default (in normal or aggressive mode) on all fiber ports on the switch, unless there is other UDLD configuration on it.

 

 

udld ?
aggressive Enable UDLD protocol in aggressive mode on fiber ports except where locally configured
enable Enable UDLD protocol on fiber ports except where locally configured
message Set UDLD message parameters

 

 

I did a "udld aggressive" global config command and went to check the UDLD status on the fiber interface (which FYI has no cable attached to it). Why is UDLD showing disabled even though I enabled it in the global config mode?

 

 

 

sh run | i udld
udld aggressive
udld message time 5

 

 

 

 

 

 

sh run int gi0/48
Building configuration...

Current configuration : 146 bytes
!
interface GigabitEthernet0/48
switchport access vlan 1000
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
end

SWITCH-2960G(config)#

 

SWITCH-2960G(config)#do sh run all | b interface[ ]GigabitEthernet0/48
interface GigabitEthernet0/48
switchport
switchport access vlan 1000
switchport mode access
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
no mab
mls qos cos 0
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
cdp tlv location
cdp tlv server-location
cdp tlv app
spanning-tree portfast disable
spanning-tree portfast trunk
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!

 

sh udld gi0/48

Interface Gi0/48
---
Port enable administrative configuration setting: Disabled
Port enable operational state: Disabled
Current bidirectional state: Unknown

 

 

 

sh int gi0/48
GigabitEthernet0/48 is down, line protocol is down (notconnect)
Hardware is Gigabit Ethernet, address is 64d9.895e.43b0 (bia 64d9.895e.43b0)
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX SFP
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

2 REPLIES 2
sofiane7704
Beginner

UDLD Enable just detects if a link becomes Unidirectional  while UDLD detects and shuts down the interface if is sends UDLD packets but does not receive any.

luis_cordova
VIP Advisor

Hi @Sam Brynes 

 

I think the problem is that the interface is DOWN.
Try connecting the interface and configuring UDLD at both ends of the link.
I leave this guide about UDLD:

https://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/10591-77.html

 

Regards