cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
270
Views
15
Helpful
6
Replies
Highlighted
Beginner

Why i can't PING the SVI of VLAN 20?

Dears,

 

I have created a small lab using my real gear to configure an intervlan routing , i can ping my gateway but i can't ping the svi of the other vlan , also i get reply from 10.1.1.5 which is ip out of both subnets , from where did this IP came from?

Intervlan - Routing.jpg

 

C:\Users\Za>ping 10.0.0.5

Pinging 10.0.0.5 with 32 bytes of data:
Reply from 10.0.0.5: bytes=32 time<1ms TTL=128
Reply from 10.0.0.5: bytes=32 time<1ms TTL=128
Reply from 10.0.0.5: bytes=32 time<1ms TTL=128
Reply from 10.0.0.5: bytes=32 time<1ms TTL=128
Ping statistics for 10.0.0.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\Za>ping 10.0.0.1

Pinging 10.0.0.1 with 32 bytes of data:
Reply from 10.0.0.1: bytes=32 time<1ms TTL=255
Reply from 10.0.0.1: bytes=32 time=1ms TTL=255
Reply from 10.0.0.1: bytes=32 time=1ms TTL=255
Reply from 10.0.0.1: bytes=32 time=1ms TTL=255

Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\Users\Za>ping 10.0.1.1

Pinging 10.0.1.1 with 32 bytes of data:
Request timed out.
Reply from 10.1.1.5: Destination host unreachable.
Request timed out.
Request timed out.

Ping statistics for 10.0.1.1:
Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),

================================================================================
SW-CORE#show run
Building configuration...

Current configuration : 1332 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW-CORE
!
!
no aaa new-model
ip subnet-zero
ip routing
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4

!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 10.0.0.1 255.255.255.0
!
interface Vlan20
ip address 10.0.1.1 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 5 15
!
!
end

SW-CORE#show vlan br

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gi0/1
Gi0/2
10 Sales active
20 HR active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup


====================================================

SW1-ACCESS#show run
Building configuration...

Current configuration : 1177 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1-ACCESS
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!

interface Vlan1
no ip address
no ip route-cache
shutdown
!
ip http server
!
line con 0
line vty 5 15
!
!
end

SW1-ACCESS#show vlan br

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/3, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
Fa0/16, Fa0/17, Fa0/18, Fa0/19
Fa0/20, Fa0/21, Fa0/22, Fa0/23
Fa0/24
10 Sales active Fa0/1
20 HR active Fa0/2
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
SW1-ACCESS#

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Guru

Re: Why i can't PING the SVI of VLAN 20?

 

Have you set the default gateway on your PC to be 10.0.0.1 ? 

 

In addition there does not seem to be any trunk configuration on fa0/4 on either switch ie., it should be - 

 

int fa0/4
switchport trunk encapsulation dot1q <-- may not be needed
switchport mode trunk
switchport trunk allowed vlan 10,20 <-- optional

 

Jon

View solution in original post

6 REPLIES 6
Highlighted
VIP Advisor

Re: Why i can't PING the SVI of VLAN 20?

Hi there,

On the core switch please can you share the following output:

sh ip int br

sh int trunk

sh spanning vlan 20

 

cheers,

Seb.

Highlighted
Beginner

Re: Why i can't PING the SVI of VLAN 20?

Hello Seb,

Thanks a lot for your assist , kindly find the output as per below:-


===============================

SW-CORE#show ip int br
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES unset administratively down down
Vlan10 10.0.0.1 YES manual up up
Vlan20 10.0.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset down down
FastEthernet0/2 unassigned YES unset down down
FastEthernet0/3 unassigned YES unset down down
FastEthernet0/4 unassigned YES unset up up
FastEthernet0/5 unassigned YES unset down down
FastEthernet0/6 unassigned YES unset down down
FastEthernet0/7 unassigned YES unset down down
FastEthernet0/8 unassigned YES unset down down
FastEthernet0/9 unassigned YES unset down down
FastEthernet0/10 unassigned YES unset down down
FastEthernet0/11 unassigned YES unset down down
FastEthernet0/12 unassigned YES unset down down
FastEthernet0/13 unassigned YES unset down down
FastEthernet0/14 unassigned YES unset down down
FastEthernet0/15 unassigned YES unset down down
FastEthernet0/16 unassigned YES unset down down
FastEthernet0/17 unassigned YES unset down down
FastEthernet0/18 unassigned YES unset down down
FastEthernet0/19 unassigned YES unset down down
FastEthernet0/20 unassigned YES unset down down
FastEthernet0/21 unassigned YES unset down down
FastEthernet0/22 unassigned YES unset down down
FastEthernet0/23 unassigned YES unset down down
FastEthernet0/24 unassigned YES unset down down
GigabitEthernet0/1 unassigned YES unset down down
GigabitEthernet0/2 unassigned YES unset down down
SW-CORE#
SW-CORE#
SW-CORE#show int trunk

Port Mode Encapsulation Status Native vlan
Fa0/4 auto n-802.1q trunking 1

Port Vlans allowed on trunk
Fa0/4 1-4094

Port Vlans allowed and active in management domain
Fa0/4 1,10,20

Port Vlans in spanning tree forwarding state and not pruned
Fa0/4 1,10,20
SW-CORE#
SW-CORE#
SW-CORE#
SW-CORE#show span vlan 20

VLAN0020
Spanning tree enabled protocol ieee
Root ID Priority 32788
Address 0014.6a28.e840
Cost 19
Port 6 (FastEthernet0/4)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32788 (priority 32768 sys-id-ext 20)
Address 0019.5520.5200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/4 Root FWD 19 128.6 P2p

SW-CORE#
Highlighted
VIP Advisor

Re: Why i can't PING the SVI of VLAN 20?

As @Jon Marshall  says, check the gateway on the PC.

Also, confirm your PC has a /24 subnet mask configured too.

Highlighted
Beginner

Re: Why i can't PING the SVI of VLAN 20?

Hello Seb,

Thanks a lot , the gateway has been set and the intervlan routing worked.
Highlighted
Hall of Fame Guru

Re: Why i can't PING the SVI of VLAN 20?

 

Have you set the default gateway on your PC to be 10.0.0.1 ? 

 

In addition there does not seem to be any trunk configuration on fa0/4 on either switch ie., it should be - 

 

int fa0/4
switchport trunk encapsulation dot1q <-- may not be needed
switchport mode trunk
switchport trunk allowed vlan 10,20 <-- optional

 

Jon

View solution in original post

Highlighted
Beginner

Re: Why i can't PING the SVI of VLAN 20?

Hello Jon,

Wow , i couldn't find the default gateway when i checked the NIC Card however i was sure that it's already been there , thanks for pointing this out , the ping now works.

C:\Users\Zamalek>ping 10.0.1.1

Pinging 10.0.1.1 with 32 bytes of data:
Reply from 10.0.1.1: bytes=32 time<1ms TTL=255
Reply from 10.0.1.1: bytes=32 time<1ms TTL=255
Reply from 10.0.1.1: bytes=32 time=1ms TTL=255
Reply from 10.0.1.1: bytes=32 time<1ms TTL=255
Content for Community-Ad