cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Community

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


193
Views
20
Helpful
11
Replies
Highlighted
Contributor

Why service-policy is not generated after using auto qos voip?

In SW3560, after the command "auto qos voip cisco-phone" is typed under the interface, the expected service-policy is not generated in interface level and global level. Please see the below.
i reviewed document, which suggests remove the command and retype it. after i did it, the service-policy still cannot appear. What is issue? Thank you
 
 
 
interface GigabitEthernet0/1
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0 
 queue-set 2
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone 
end
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33 
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos 
11 REPLIES
VIP Mentor

Re: Why service-policy is not generated after using auto qos voip?

Hello,

 

is this the full port configuration:

 

interface GigabitEthernet0/1
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone

 

According to the guidelines, you can enable auto-QoS on static, dynamic-access, voice VLAN access, and trunk ports. Add either 'switchport mode access' or 'switchport voice vlan' to the port. What is the port used for anyway ?

Contributor

Re: Why service-policy is not generated after using auto qos voip?

Thank you so much for your reply. The interface is used for user pc and ip phone. I am trying to test Qos in lab before pushing it to network. so i forgot to add data vlan and voice vlan. 

 

So maybe after adding data vlan and voice vlan, the service-policy will get created? i am going to add these two vlan next day for test. Thank you!

VIP Mentor

Re: Why service-policy is not generated after using auto qos voip?

In theory that should work. Let us know the results...

VIP Advisor

Re: Why service-policy is not generated after using auto qos voip?

I could be wrong here but on the 3560s from memory its IOS so it doesn't actually add the service policy to the interface on a layer 2 interfaces it just applys the qos , it does on IOS-XE with auto qos on a 3650 it creates full maps then applies it to each individual interface that has auto enabled

You can check your qos is working with show mls qos interface gx/x statistics

also in your post your best off using DSCP if available rather than COS and set the uplink to trust DSCP too , most new phones etc send in DSCP now
VIP Expert

Re: Why service-policy is not generated after using auto qos voip?

I recall (?) on that series, once auto QoS commands have been triggered, they are not regenerated unless you completely remove all of them from the device. This, I believe, was allow you to "customize" the auto QoS generated commands after they are installed the first time.
Contributor

Re: Why service-policy is not generated after using auto qos voip?

i removed all configuration and add auto qos and vlan for voice and data at interface. the policy-map was not generated

VIP Expert

Re: Why service-policy is not generated after using auto qos voip?

How did you remove all the config? Reason I ask, I don't recall exactly what I've done in the past to reset the auto QoS regeneration trigger, but if you're in a position to try it, erase the startup config (you can save a copy under a different file name) and reboot. See if that then allows for a reset of auto QoS. (You can then [later] either copy it to startup or merge it with running and re-save.)

BTW, auto QoS generation might also require QoS be enabled.
Contributor

Re: Why service-policy is not generated after using auto qos voip?

Yes i erased start-config in nvram and reload it. then confirm all are gone. after that, i tested auto qos. all results are same as last time. tomorrow i will test it again

VIP Advisor

Re: Why service-policy is not generated after using auto qos voip?

my 3560s dont contain policy's either running qos interface or global as i was saying in earlier post i dont think they do in general
I just tested it on a fresh non qos 3560 to be sure same results no policies ingterface or global but qos is working fine

I dont think you have any issue
#show auto qos interface fa0/12
FastEthernet0/12
auto qos trust


Model number : WS-C3560V2-48PS-S
* 1 52 WS-C3560V2-48PS

interface FastEthernet0/12
switchport access vlan 4
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
spanning-tree portfast

sh mls qos interface f0/12 statistics
FastEthernet0/12 (All statistics are in packets)

dscp: incoming
-------------------------------

0 - 4 : 14477 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 697966
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 2239979 0 0 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
VIP Expert

Re: Why service-policy is not generated after using auto qos voip?

And mls qos was enabled before entering an interface auto QoS command too, correct?

What specific 3560 model and what IOS is running on it?
VIP Advisor

Re: Why service-policy is not generated after using auto qos voip?

Hi
i tested it on this

xxxxxx#sh ver | i 3560 | image
Cisco IOS Software, C3560 Software (C3560-IPBASEK9-M), Version 15.0(2)SE11, RELEASE SOFTWARE (fc3)
ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(50r)SE, RELEASE SOFTWARE (fc1)
System image file is "flash:/c3560-ipbasek9-mz.150-2.SE11.bin"

Just to eb sure ive removed teh MLS globally and from interface level and reapplied auto qos

defaulted back to this


interface FastEthernet0/9
switchport access vlan 4
switchport mode access
spanning-tree portfast

Then reapplied just auto , it comes out same as this reapplying the MLS too but still no policy, this is what i always see like MLS takes pref on an MLS QOS type switch

interface FastEthernet0/12
switchport access vlan 4
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast

This compared to my 36s IOS-XE which generate the actual interface policies and class maps , i though MLS switches never do that

interface GigabitEthernet1/0/20
description xde-ap1
switchport access vlan 5
switchport trunk native vlan 5
switchport mode trunk
auto qos trust dscp
spanning-tree portfast trunk
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

On a switch where it fully uses Auto Qos instead of MLS you can run the full command check against the interface but on MLS you need to run show mls qos interface gx/x stati

#sh policy-map interface g1/0/3
GigabitEthernet1/0/3

Service-policy input: AutoQos-4.0-Trust-Dscp-Input-Policy

Class-map: class-default (match-any)
13101961642 packets
Match: any
QoS Set
dscp dscp table AutoQos-4.0-Trust-Dscp-Table

CreatePlease to create content
Content for Community-Ad