cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
720
Views
0
Helpful
4
Replies

Whyt can't we see remote network in eigrp ?

lowfell
Participant
Participant

I am a host in vlan 6  (9400)

ip address 10.32.253.2

!

interface Vlan6
description ***  Data Vlan ***
ip address 10.32.253.1 255.255.255.240

!
!

router eigrp 100
bfd interface Vlan266
bfd interface Vlan267
network 10.32.253.0 0.0.0.0
network 10.32.253.16 0.0.0.0
network 10.32.253.32 0.0.0.0
network 10.32.253.48 0.0.0.0
network 10.32.254.1 0.0.0.0
network 10.32.254.6 0.0.0.0
network 10.32.254.10 0.0.0.0
network 10.32.254.13 0.0.0.0
passive-interface default
no passive-interface Vlan266
no passive-interface Vlan267
!

 

 

@@@@@@@@@@@@@@@@

the address I'm trying to reach is 172.16.4.4 his gateway is 172.16.4.1

I can ping both  addresses from my switch but not from the end devices 

!
!
Here is my route

!

#sho ip route 172.16.4.4
Routing entry for 172.16.4.0/22
Known via "eigrp 100", distance 90, metric 3072, type internal
Redistributing via eigrp 100
Last update from 10.32.254.9 on Vlan267, 00:02:03 ago
Routing Descriptor Blocks:
10.32.254.9, from 10.32.254.9, 00:02:03 ago, via Vlan267
Route metric is 3072, traffic share count is 1
Total delay is 20 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
* 10.32.254.5, from 10.32.254.5, 00:02:03 ago, via Vlan266
Route metric is 3072, traffic share count is 1
Total delay is 20 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

!

 


HERE IS WHAT THE REMOTE SIDE LOOKS LIKE

host ip 172.16.4.4 255.255.252.0


interface Vlan5
description *** REMOTE_Data_Vlan ***
no shutdown
no ip redirects
ip address 172.16.6.176/22
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 5
authentication text REDACTED
preempt
priority 200
ip 172.16.4.1

!
!

#


LOCAL# show ip route 10.32.253.2
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

Route not found
!
!
!
!

 

Here is his FULL routing table, it looks like he can't see all of my routes

!

show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

10.32.100.0/28, ubest/mbest: 1/0, attached
*via 10.32.100.12, Vlan970, [0/0], 5d02h, direct
10.32.100.12/32, ubest/mbest: 1/0, attached
*via 10.32.100.12, Vlan970, [0/0], 5d02h, local
10.32.100.14/32, ubest/mbest: 1/0, attached
*via 10.32.100.14, Vlan970, [0/0], 5d02h, hsrp
10.32.200.248/29, ubest/mbest: 1/0, attached
*via 10.32.200.252, Vlan920, [0/0], 5d02h, direct
10.32.200.252/32, ubest/mbest: 1/0, attached
*via 10.32.200.252, Vlan920, [0/0], 5d02h, local
10.32.200.254/32, ubest/mbest: 1/0, attached
*via 10.32.200.254, Vlan920, [0/0], 5d02h, hsrp
10.32.254.0/30, ubest/mbest: 1/0
*via 10.32.254.10, Vlan267, [90/130816], 00:00:19, eigrp-100, internal
10.32.254.4/30, ubest/mbest: 4/0
*via 10.32.254.10, Vlan267, [90/3072], 00:00:19, eigrp-100, internal
*via 10.255.0.12, Vlan999, [90/3072], 00:00:29, eigrp-100, internal
*via 10.255.1.220, Vlan255, [90/3072], 00:00:29, eigrp-100, internal
*via 10.255.254.10, Vlan254, [90/3072], 00:00:29, eigrp-100, internal
10.32.254.8/30, ubest/mbest: 1/0, attached
*via 10.32.254.9, Vlan267, [0/0], 00:00:26, direct
10.32.254.9/32, ubest/mbest: 1/0, attached
*via 10.32.254.9, Vlan267, [0/0], 00:00:26, local
10.100.4.0/22, ubest/mbest: 1/0, attached
*via 10.100.7.252, Vlan700, [0/0], 5d02h, direct
10.100.7.252/32, ubest/mbest: 1/0, attached
*via 10.100.7.252, Vlan700, [0/0], 5d02h, local
10.100.7.254/32, ubest/mbest: 1/0, attached
*via 10.100.7.254, Vlan700, [0/0], 5d02h, hsrp
10.101.0.0/21, ubest/mbest: 1/0, attached
*via 10.101.7.252, Vlan705, [0/0], 5d02h, direct
10.101.7.252/32, ubest/mbest: 1/0, attached
*via 10.101.7.252, Vlan705, [0/0], 5d02h, local
10.101.7.254/32, ubest/mbest: 1/0, attached
*via 10.101.7.254, Vlan705, [0/0], 5d02h, hsrp
10.218.3.0/24, ubest/mbest: 1/0, attached
*via 10.218.3.252, Vlan310, [0/0], 5d02h, direct
10.218.3.252/32, ubest/mbest: 1/0, attached
*via 10.218.3.252, Vlan310, [0/0], 5d02h, local
10.218.3.254/32, ubest/mbest: 1/0, attached
*via 10.218.3.254, Vlan310, [0/0], 5d02h, hsrp
10.218.100.0/24, ubest/mbest: 1/0, attached
*via 10.218.100.252, Vlan252, [0/0], 5d02h, direct
10.218.100.252/32, ubest/mbest: 1/0, attached
*via 10.218.100.252, Vlan252, [0/0], 5d02h, local
10.218.100.254/32, ubest/mbest: 1/0, attached
*via 10.218.100.254, Vlan252, [0/0], 5d02h, hsrp
10.218.101.0/24, ubest/mbest: 1/0, attached
*via 10.218.101.252, Vlan800, [0/0], 5d02h, direct
10.218.101.252/32, ubest/mbest: 1/0, attached
*via 10.218.101.252, Vlan800, [0/0], 5d02h, local
10.218.101.254/32, ubest/mbest: 1/0, attached
*via 10.218.101.254, Vlan800, [0/0], 5d02h, hsrp
10.235.200.0/26, ubest/mbest: 1/0, attached
*via 10.235.200.61, Vlan802, [0/0], 5d02h, direct
10.235.200.61/32, ubest/mbest: 1/0, attached
*via 10.235.200.61, Vlan802, [0/0], 5d02h, local
10.235.200.62/32, ubest/mbest: 1/0, attached
*via 10.235.200.62, Vlan802, [0/0], 5d02h, hsrp
10.235.201.0/26, ubest/mbest: 1/0, attached
*via 10.235.201.61, Vlan803, [0/0], 5d02h, direct
10.235.201.61/32, ubest/mbest: 1/0, attached
*via 10.235.201.61, Vlan803, [0/0], 5d02h, local
10.235.201.62/32, ubest/mbest: 1/0, attached
*via 10.235.201.62, Vlan803, [0/0], 5d02h, hsrp
10.235.202.0/28, ubest/mbest: 1/0, attached
*via 10.235.202.13, Vlan804, [0/0], 5d02h, direct
10.235.202.13/32, ubest/mbest: 1/0, attached
*via 10.235.202.13, Vlan804, [0/0], 5d02h, local
10.235.202.14/32, ubest/mbest: 1/0, attached
*via 10.235.202.14, Vlan804, [0/0], 5d02h, hsrp
10.235.203.0/28, ubest/mbest: 1/0, attached
*via 10.235.203.13, Vlan805, [0/0], 5d02h, direct
10.235.203.13/32, ubest/mbest: 1/0, attached
*via 10.235.203.13, Vlan805, [0/0], 5d02h, local
10.235.203.14/32, ubest/mbest: 1/0, attached
*via 10.235.203.14, Vlan805, [0/0], 5d02h, hsrp
10.235.204.0/27, ubest/mbest: 1/0, attached
*via 10.235.204.29, Vlan806, [0/0], 5d02h, direct
10.235.204.29/32, ubest/mbest: 1/0, attached
*via 10.235.204.29, Vlan806, [0/0], 5d02h, local
10.235.204.30/32, ubest/mbest: 1/0, attached
*via 10.235.204.30, Vlan806, [0/0], 5d02h, hsrp
10.235.210.0/28, ubest/mbest: 3/0
*via 10.255.0.12, Vlan999, [90/3072], 4d03h, eigrp-100, internal
*via 10.255.1.220, Vlan255, [90/3072], 4d03h, eigrp-100, internal
*via 10.255.254.10, Vlan254, [90/3072], 4d03h, eigrp-100, internal
10.252.0.16/28, ubest/mbest: 1/0, attached
*via 10.252.0.29, Vlan982, [0/0], 5d02h, direct
10.252.0.29/32, ubest/mbest: 1/0, attached
*via 10.252.0.29, Vlan982, [0/0], 5d02h, local
10.252.0.32/28, ubest/mbest: 1/0, attached
*via 10.252.0.44, Vlan979, [0/0], 5d02h, direct
10.252.0.44/32, ubest/mbest: 1/0, attached
*via 10.252.0.44, Vlan979, [0/0], 5d02h, local
10.252.0.46/32, ubest/mbest: 1/0, attached
*via 10.252.0.46, Vlan979, [0/0], 5d02h, hsrp
10.253.10.0/28, ubest/mbest: 1/0, attached
*via 10.253.10.12, Vlan500, [0/0], 5d02h, direct
10.253.10.12/32, ubest/mbest: 1/0, attached
*via 10.253.10.12, Vlan500, [0/0], 5d02h, local
10.253.10.14/32, ubest/mbest: 1/0, attached
*via 10.253.10.14, Vlan500, [0/0], 5d02h, hsrp
10.253.10.16/28, ubest/mbest: 1/0, attached
*via 10.253.10.28, Vlan503, [0/0], 5d02h, direct
10.253.10.28/32, ubest/mbest: 1/0, attached
*via 10.253.10.28, Vlan503, [0/0], 5d02h, local
10.253.10.30/32, ubest/mbest: 1/0, attached
*via 10.253.10.30, Vlan503, [0/0], 5d02h, hsrp
10.253.10.64/26, ubest/mbest: 1/0, attached
*via 10.253.10.124, Vlan501, [0/0], 5d02h, direct
10.253.10.124/32, ubest/mbest: 1/0, attached
*via 10.253.10.124, Vlan501, [0/0], 5d02h, local
10.253.10.126/32, ubest/mbest: 1/0, attached
*via 10.253.10.126, Vlan501, [0/0], 5d02h, hsrp
10.253.10.128/26, ubest/mbest: 1/0, attached
*via 10.253.10.188, Vlan502, [0/0], 5d02h, direct
10.253.10.188/32, ubest/mbest: 1/0, attached
*via 10.253.10.188, Vlan502, [0/0], 5d02h, local
10.253.10.190/32, ubest/mbest: 1/0, attached
*via 10.253.10.190, Vlan502, [0/0], 5d02h, hsrp
10.253.11.0/28, ubest/mbest: 1/0, attached
*via 10.253.11.13, Vlan599, [0/0], 5d02h, direct
10.253.11.13/32, ubest/mbest: 1/0, attached
*via 10.253.11.13, Vlan599, [0/0], 5d02h, local
10.253.11.14/32, ubest/mbest: 1/0, attached
*via 10.253.11.14, Vlan599, [0/0], 5d02h, hsrp
10.253.12.0/24, ubest/mbest: 1/0, attached
*via 10.253.12.252, Vlan504, [0/0], 5d02h, direct
10.253.12.252/32, ubest/mbest: 1/0, attached
*via 10.253.12.252, Vlan504, [0/0], 5d02h, local
10.253.12.254/32, ubest/mbest: 1/0, attached
*via 10.253.12.254, Vlan504, [0/0], 5d02h, hsrp
10.253.15.0/24, ubest/mbest: 1/0, attached
*via 10.253.15.254, Vlan505, [0/0], 5d02h, direct
10.253.15.254/32, ubest/mbest: 1/0, attached
*via 10.253.15.254, Vlan505, [0/0], 5d02h, local
10.254.0.0/24, ubest/mbest: 1/0, attached
*via 10.254.0.252, Vlan200, [0/0], 5d02h, direct
10.254.0.252/32, ubest/mbest: 1/0, attached
*via 10.254.0.252, Vlan200, [0/0], 5d02h, local
10.254.0.254/32, ubest/mbest: 1/0, attached
*via 10.254.0.254, Vlan200, [0/0], 5d02h, hsrp
10.254.2.0/24, ubest/mbest: 1/0, attached
*via 10.254.2.252, Vlan250, [0/0], 5d02h, direct
10.254.2.252/32, ubest/mbest: 1/0, attached
*via 10.254.2.252, Vlan250, [0/0], 5d02h, local
10.254.2.254/32, ubest/mbest: 1/0, attached
*via 10.254.2.254, Vlan250, [0/0], 5d02h, hsrp
10.254.4.0/23, ubest/mbest: 1/0, attached
*via 10.254.5.252, Vlan201, [0/0], 5d02h, direct
10.254.5.252/32, ubest/mbest: 1/0, attached
*via 10.254.5.252, Vlan201, [0/0], 5d02h, local
10.254.5.254/32, ubest/mbest: 1/0, attached
*via 10.254.5.254, Vlan201, [0/0], 5d02h, hsrp
10.254.6.0/23, ubest/mbest: 1/0, attached
*via 10.254.7.252, Vlan202, [0/0], 5d02h, direct
10.254.7.252/32, ubest/mbest: 1/0, attached
*via 10.254.7.252, Vlan202, [0/0], 5d02h, local
10.254.7.254/32, ubest/mbest: 1/0, attached
*via 10.254.7.254, Vlan202, [0/0], 5d02h, hsrp
10.254.8.0/23, ubest/mbest: 1/0, attached
*via 10.254.9.252, Vlan203, [0/0], 5d02h, direct
10.254.9.252/32, ubest/mbest: 1/0, attached
*via 10.254.9.252, Vlan203, [0/0], 5d02h, local
10.254.9.254/32, ubest/mbest: 1/0, attached
*via 10.254.9.254, Vlan203, [0/0], 5d02h, hsrp
10.254.10.0/23, ubest/mbest: 1/0, attached
*via 10.254.11.252, Vlan204, [0/0], 5d02h, direct
10.254.11.252/32, ubest/mbest: 1/0, attached
*via 10.254.11.252, Vlan204, [0/0], 5d02h, local
10.254.11.254/32, ubest/mbest: 1/0, attached
*via 10.254.11.254, Vlan204, [0/0], 5d02h, hsrp
10.254.12.0/23, ubest/mbest: 1/0, attached
*via 10.254.13.252, Vlan205, [0/0], 5d02h, direct
10.254.13.252/32, ubest/mbest: 1/0, attached
*via 10.254.13.252, Vlan205, [0/0], 5d02h, local
10.254.13.254/32, ubest/mbest: 1/0, attached
*via 10.254.13.254, Vlan205, [0/0], 5d02h, hsrp
10.254.14.0/23, ubest/mbest: 1/0, attached
*via 10.254.15.252, Vlan206, [0/0], 5d02h, direct
10.254.15.252/32, ubest/mbest: 1/0, attached
*via 10.254.15.252, Vlan206, [0/0], 5d02h, local
10.254.15.254/32, ubest/mbest: 1/0, attached
*via 10.254.15.254, Vlan206, [0/0], 5d02h, hsrp
10.254.16.0/23, ubest/mbest: 1/0, attached
*via 10.254.17.252, Vlan207, [0/0], 5d02h, direct
10.254.17.252/32, ubest/mbest: 1/0, attached
*via 10.254.17.252, Vlan207, [0/0], 5d02h, local
10.254.17.254/32, ubest/mbest: 1/0, attached
*via 10.254.17.254, Vlan207, [0/0], 5d02h, hsrp
10.254.20.0/23, ubest/mbest: 1/0, attached
*via 10.254.21.252, Vlan209, [0/0], 5d02h, direct
10.254.21.252/32, ubest/mbest: 1/0, attached
*via 10.254.21.252, Vlan209, [0/0], 5d02h, local
10.254.21.254/32, ubest/mbest: 1/0, attached
*via 10.254.21.254, Vlan209, [0/0], 5d02h, hsrp
10.254.22.0/23, ubest/mbest: 1/0, attached
*via 10.254.23.252, Vlan210, [0/0], 5d02h, direct
10.254.23.252/32, ubest/mbest: 1/0, attached
*via 10.254.23.252, Vlan210, [0/0], 5d02h, local
10.254.23.254/32, ubest/mbest: 1/0, attached
*via 10.254.23.254, Vlan210, [0/0], 5d02h, hsrp
10.254.24.0/23, ubest/mbest: 1/0, attached
*via 10.254.24.252, Vlan211, [0/0], 5d02h, direct
10.254.24.252/32, ubest/mbest: 1/0, attached
*via 10.254.24.252, Vlan211, [0/0], 5d02h, local
10.254.24.254/32, ubest/mbest: 1/0, attached
*via 10.254.24.254, Vlan211, [0/0], 5d02h, hsrp
10.255.0.0/28, ubest/mbest: 1/0, attached
*via 10.255.0.13, Vlan999, [0/0], 5d02h, direct
10.255.0.13/32, ubest/mbest: 1/0, attached
*via 10.255.0.13, Vlan999, [0/0], 5d02h, local
10.255.0.14/32, ubest/mbest: 1/0, attached
*via 10.255.0.14, Vlan999, [0/0], 5d02h, hsrp
10.255.0.16/28, ubest/mbest: 1/0, attached
*via 10.255.0.29, Vlan994, [0/0], 5d02h, direct
10.255.0.29/32, ubest/mbest: 1/0, attached
*via 10.255.0.29, Vlan994, [0/0], 5d02h, local
10.255.0.30/32, ubest/mbest: 1/0, attached
*via 10.255.0.30, Vlan994, [0/0], 5d02h, hsrp
10.255.0.80/28, ubest/mbest: 1/0, attached
*via 10.255.0.93, Vlan998, [0/0], 5d02h, direct
10.255.0.93/32, ubest/mbest: 1/0, attached
*via 10.255.0.93, Vlan998, [0/0], 5d02h, local
10.255.0.94/32, ubest/mbest: 1/0, attached
*via 10.255.0.94, Vlan998, [0/0], 5d02h, hsrp
10.255.0.112/28, ubest/mbest: 1/0, attached
*via 10.255.0.125, Vlan989, [0/0], 5d02h, direct
10.255.0.125/32, ubest/mbest: 1/0, attached
*via 10.255.0.125, Vlan989, [0/0], 5d02h, local
10.255.0.126/32, ubest/mbest: 1/0, attached
*via 10.255.0.126, Vlan989, [0/0], 5d02h, hsrp
10.255.0.176/28, ubest/mbest: 1/0, attached
*via 10.255.0.188, Vlan985, [0/0], 5d02h, direct
10.255.0.188/32, ubest/mbest: 1/0, attached
*via 10.255.0.188, Vlan985, [0/0], 5d02h, local
10.255.0.190/32, ubest/mbest: 1/0, attached
*via 10.255.0.190, Vlan985, [0/0], 5d02h, hsrp
10.255.0.192/26, ubest/mbest: 1/0, attached
*via 10.255.0.252, Vlan984, [0/0], 5d02h, direct
10.255.0.252/32, ubest/mbest: 1/0, attached
*via 10.255.0.252, Vlan984, [0/0], 5d02h, local
10.255.0.254/32, ubest/mbest: 1/0, attached
*via 10.255.0.254, Vlan984, [0/0], 5d02h, hsrp
10.255.1.0/24, ubest/mbest: 1/0, attached
*via 10.255.1.221, Vlan255, [0/0], 5d02h, direct
10.255.1.221/32, ubest/mbest: 1/0, attached
*via 10.255.1.221, Vlan255, [0/0], 5d02h, local
10.255.1.254/32, ubest/mbest: 1/0, attached
*via 10.255.1.254, Vlan255, [0/0], 5d02h, hsrp
10.255.254.0/28, ubest/mbest: 1/0, attached
*via 10.255.254.11, Vlan254, [0/0], 5d02h, direct
10.255.254.11/32, ubest/mbest: 1/0, attached
*via 10.255.254.11, Vlan254, [0/0], 5d02h, local
172.16.4.0/22, ubest/mbest: 1/0, attached
*via 172.16.6.176, Vlan5, [0/0], 5d02h, direct
172.16.4.1/32, ubest/mbest: 1/0, attached
*via 172.16.4.1, Vlan5, [0/0], 5d02h, hsrp
172.16.6.176/32, ubest/mbest: 1/0, attached
*via 172.16.6.176, Vlan5, [0/0], 5d02h, local
172.18.4.0/22, ubest/mbest: 1/0, attached
*via 172.18.7.252, Vlan2, [0/0], 5d02h, direct
172.18.4.1/32, ubest/mbest: 1/0, attached
*via 172.18.4.1, Vlan2, [0/0], 5d02h, hsrp
172.18.7.252/32, ubest/mbest: 1/0, attached
*via 172.18.7.252, Vlan2, [0/0], 5d02h, local
172.30.4.0/22, ubest/mbest: 1/0, attached
*via 172.30.7.252, Vlan3, [0/0], 5d02h, direct
172.30.4.1/32, ubest/mbest: 1/0, attached
*via 172.30.4.1, Vlan3, [0/0], 5d02h, hsrp
172.30.7.252/32, ubest/mbest: 1/0, attached
*via 172.30.7.252, Vlan3, [0/0], 5d02h, local
172.30.9.0/24, ubest/mbest: 1/0, attached
*via 172.30.9.252, Vlan102, [0/0], 5d02h, direct
172.30.9.1/32, ubest/mbest: 1/0, attached
*via 172.30.9.1, Vlan102, [0/0], 5d02h, hsrp
172.30.9.252/32, ubest/mbest: 1/0, attached
*via 172.30.9.252, Vlan102, [0/0], 5d02h, local
172.32.4.0/22, ubest/mbest: 1/0, attached
*via 172.32.7.252, Vlan4, [0/0], 5d02h, direct
172.32.4.1/32, ubest/mbest: 1/0, attached
*via 172.32.4.1, Vlan4, [0/0], 5d02h, hsrp
172.32.7.252/32, ubest/mbest: 1/0, attached
*via 172.32.7.252, Vlan4, [0/0], 5d02h, local


WHY CAN'T HE SEE MY 10.32.253.2 ??????

1 Accepted Solution

Accepted Solutions

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

at first glance it looks like you’ve entered the network addresses of the subnets and not the host address ranges in the eigrp process 

 

it needs to be either - example 

10.32.253.0 0.0.0.7 = /28

or

10.32.253.1 0.0.0.0 = specific  host /32


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

4 Replies 4

lowfell
Participant
Participant

Hello all. Could it be the "passive-interface default" command that is stopping him seeing my networks and if I used.

#no Passive-interface on the interface I want him to see then he should have visibility?

 

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

at first glance it looks like you’ve entered the network addresses of the subnets and not the host address ranges in the eigrp process 

 

it needs to be either - example 

10.32.253.0 0.0.0.7 = /28

or

10.32.253.1 0.0.0.0 = specific  host /32


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Ok, to fix this we did this.

 

This was the existing.

router eigrp 100

network 10.32.253.0 0.0.0.0

The interface address was

10.32.253.1 255.255.255.240

THIS DID NOT WORK

 

TO fix it we changed the EIGRP to

router eigrp 100

network 10.32.253.1 0.0.0.0

 

and Hey presto! everything started working

 

Thanks for your help Paul.

 

Thanks again Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers