cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
671
Views
0
Helpful
14
Replies
Highlighted
Participant

Windows hosts etherchannel fail on second line card

Hello,

 

I have an odd issue which I have not been able to solve via TAC or otherwise.  When I connect a VMWare ESX host or a Cisco switch to our 4507R+E SUP 7L-E switch using etherchannel and plug one cable into line card 1 and one cable into line card 2 I can form an etherchannel where both ports are active.

 

However when I try and do the same thing with a Windows Server I cannot form any etherchannel connection on the 2nd line card.  For example

 

Windows Server --- 2 cables --- 1 cable in line card 1, 1 cable in line card 2 - The connection to line card 2 is suspended in the etherchannel with an error that says LACP is not enabled on remote port. 

 

Another example:

 

Windows Server --- 2 cables --- 2 cables in line card 1.  This works just fine.

 

Another example:

 

Windows Server --- 2 cables --- 2 cables into line card 2.  Both connections fail.

 

I'm wondering if this is an unknown bug with the 4507 switch or perhaps something that the switch does differently on line card 2 than on line card 1?

 

Both of the line cards are WS-X4648-RJ45V+E. 

 

To recap.  When connecting etherchannel to a Windows Host from the 4507, any connection on line card 2 fails.  However any other type of host such as a Cisco switch or a VMware Host has no issues making an etherchannel across line cards.

 

Dan.

14 REPLIES 14
Highlighted
VIP Collaborator

Re: Windows hosts etherchannel fail on second line card

Hello,

Its necessary enable NIC TEAM on windows server, look link below to know how to do it;

https://social.technet.microsoft.com/wiki/pt-br/contents/articles/13026.nic-teaming-no-windows-server-2012-time-de-interfaces-de-rede.aspx

 

 

please, input here current configuration of your ETHERCHANNEL in switch.

Jaderson Pessoa
*** Rate All Helpful Responses ***
Highlighted
Participant

Re: Windows hosts etherchannel fail on second line card

Yes, I have teaming enabled already.  But it only establishes a connection when the host is connected to the 1st line card.

Highlighted
VIP Collaborator

Re: Windows hosts etherchannel fail on second line card

What version of your IOS?
Jaderson Pessoa
*** Rate All Helpful Responses ***
Highlighted
Participant

Re: Windows hosts etherchannel fail on second line card

Cisco IOS Software, IOS-XE Software, Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSALK9-M), Version 03.06.08.E RELEASE SOFTWARE (fc1)

Highlighted
VIP Collaborator

Re: Windows hosts etherchannel fail on second line card

What version of your Supervisor Engine?
Jaderson Pessoa
*** Rate All Helpful Responses ***
Highlighted
VIP Collaborator

Re: Windows hosts etherchannel fail on second line card

@dan.letkeman hello,

 

 

you have stayed in oldest version of IOS, i suggest you to upgrade it. I had the same issue in the past in to a client, after upgrade IOS i had no issue again.

 

 

Look it for recent version: https://software.cisco.com/download/home/283289791/type/282046477/release/3.11.0E

Jaderson Pessoa
*** Rate All Helpful Responses ***
Highlighted
Participant

Re: Windows hosts etherchannel fail on second line card

I can give this a try.

Highlighted
Hall of Fame Guru

Re: Windows hosts etherchannel fail on second line card

 

Have you tried a static team ie. no LACP. 

 

Jon

Highlighted
Participant

Re: Windows hosts etherchannel fail on second line card

No, LACP works fine as long as I don't use the second line card when connecting a Windows Host.

 

The issue is not getting LACP to work with the host, the issue is that is doesn't work when the second line card is involved.  If someone has time to LAB this up, I would interested to know if they have the same issue.

Highlighted
VIP Mentor

Re: Windows hosts etherchannel fail on second line card

We have some implementation we do not see as this issue,

 

what is the version of windows server , can you post the setup of network config. also what is the interface card.

 

post the show version and interface config here to understand.

 

BB
*** Rate All Helpful Responses ***
Highlighted
Participant

Re: Windows hosts etherchannel fail on second line card

Server 2012 R2 and Server 2016.  HPE DL380 Gen8 and HPE DL378 Gen10.

 

interface Port-channel34
switchport
switchport trunk native vlan 500
switchport trunk allowed vlan 500
switchport mode trunk

 

interface GigabitEthernet1/43
switchport trunk native vlan 500
switchport trunk allowed vlan 500
switchport mode trunk
channel-group 34 mode active

interface GigabitEthernet1/44
switchport trunk native vlan 500
switchport trunk allowed vlan 500
switchport mode trunk
channel-group 34 mode active

 

As you can see this configuration works.  However if I move the cable from g1/44 to g2/44 it will fail.


windows-team-nic-config.png

Highlighted
VIP Collaborator

Re: Windows hosts etherchannel fail on second line card

I think that configuration is not the problem. as i said earlier, maybe it is IOS version.
Jaderson Pessoa
*** Rate All Helpful Responses ***
Highlighted
Participant

Re: Windows hosts etherchannel fail on second line card

Yes, although TAC could not find any issue with the IOS.  I suspect it also could be Windows Server OS.

Highlighted
VIP Mentor

Re: Windows hosts etherchannel fail on second line card

We have 6500 for redudency we always connect to each port to different blade

 

if you only need VLAN 500 Allowed. try below config.

 

interface Port-channel34

switchport

 switchport access vlan 500

 switchport mode access

 

 

interface GigabitEthernet2/44
switchport access vlan  500
channel-group 34 mode active

interface GigabitEthernet1/44
switchport access vlan 500
channel-group 34 mode active

 

 

 

BB
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad