cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
180
Views
0
Helpful
4
Replies
Highlighted
Beginner

Wired MAC flapping between two ports

Hi everyone,

 

Here is my topo:

  SW4----------(T1/0/6)SW3(T1/0/9)----------SW2

                                           | (T1/0/11 Block)            |

                                           |-------------------SW1

 

Here are the flapping log:

*May 15 09:29:36.244: %SW_MATM-4-MACFLAP_NOTIF: Host 2c31.242d.a1e4 in vlan 81 is flapping between port Te1/0/6 and port Te1/0/9
*May 15 16:52:47.180: %SW_MATM-4-MACFLAP_NOTIF: Host 2c31.242d.a1e4 in vlan 81 is flapping between port Te1/0/6 and port Te1/0/9
*May 15 18:57:10.113: %SW_MATM-4-MACFLAP_NOTIF: Host 2c31.242d.a1e4 in vlan 81 is flapping between port Te1/0/6 and port Te1/0/9
*May 15 21:26:56.198: %SW_MATM-4-MACFLAP_NOTIF: Host 2c31.242d.a1e4 in vlan 81 is flapping between port Te1/0/6 and port Te1/0/9
*May 15 22:23:05.032: %SW_MATM-4-MACFLAP_NOTIF: Host 2c31.242d.a1e4 in vlan 81 is flapping between port Te1/0/6 and port Te1/0/9

SW1 is the gateway.

SW1#sho int vlan 81
Vlan81 is up, line protocol is up
Hardware is Ethernet SVI, address is 2c31.242d.a1e4 (bia 2c31.242d.a1e4)

 

SW3#sho spanning-tree vlan 81

VLAN0081
Spanning tree enabled protocol ieee
Root ID Priority 4177
Address 2c31.242d.a180
Cost 8001
Port 9 (TenGigabitEthernet1/0/9)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 49233 (priority 49152 sys-id-ext 81)
Address 00aa.6e03.7580
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Uplinkfast enabled

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/0/6 Desg FWD 3004 128.6 P2p
Te1/0/9 Root FWD 8000 128.9 P2p
Te1/0/11 Altn BLK 10000 128.11 P2p

I don't understand why the MAC 2c31.242d.a1e4 flapping between SW2 and SW4..

 


Can someone please assist in directing me in the correct direction to deal with it

Thanks a lot

Everyone's tags (1)
4 REPLIES 4
VIP Collaborator

Re: Wired MAC flapping between two ports

Appears you have some spanning tree issue. Might be best to provide the switch configs to better help figure out what is going on.

Regards

Beginner

Re: Wired MAC flapping between two ports

Thank you for your reply.
SW3:
interface TenGigabitEthernet1/0/9
switchport mode trunk
spanning-tree link-type point-to-point
spanning-tree cost 8000
ip dhcp snooping trust
!
interface TenGigabitEthernet1/0/11
switchport mode trunk
spanning-tree link-type point-to-point
spanning-tree cost 10000
ip dhcp snooping trust
!
interface TenGigabitEthernet1/0/6
switchport mode trunk
storm-control broadcast level 2.00
storm-control multicast level 2.00
auto qos trust
spanning-tree link-type point-to-point
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
!
VIP Collaborator

Re: Wired MAC flapping between two ports

I was hoping more for the full configs of all the switches. Not much to tell with what you posted. If possible, please provide text files of the configs.

Other than that, if I'm reading the diagram correctly that was in your original post, there is a loop in your topology between SW1, 2 & 3. If you were to eliminate one of these links, the flapping should stop. Probably between SW1 & 2 would be my first choice.

Thanks

Beginner

Re: Wired MAC flapping between two ports

How does spt look for vlan 81 on SW4? Does it have any path to SW1 other than via SW3?
Have you tried to trace the MAC from SW4 when its flapping?
CreatePlease to create content
Content for Community-Ad