cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
180
Views
15
Helpful
9
Replies
Enthusiast

witches connected to my isr 2911 router take the time from ntp server

how to let 2 switches connected to my isr 2911 router take the time from ntp server 

this is the configuration of my ntp server on router but on switches time is not  updating from router its different :

for the router gatewate interface to lan ( i have sub interfaces for different vlans) 

 

also if there are any recommended config to ntp please share also 

 

ntp master
ntp update-calendar
ntp server 0.eg.pool.ntp.org

 

design:

 

router isr 2911----------switch (cisco catalyst 2960 x 24 gige poe 370w 4x1g sfp lan base)-------sw(cisco catalyst 2960 x 24 gige poe 370w 4x1g sfp lan base)

amr alrazzaz
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: witches connected to my isr 2911 router take the time from ntp server

@amralrazzaz 

How it goes with you ? time is also showing correct on Router and Switch ?

 

 

 

- plz mark solution as accepted and helpful if it worked with you. It will help others also who is seeking solution for similar queries.

View solution in original post

9 REPLIES 9
Highlighted

Re: witches connected to my isr 2911 router take the time from ntp server

Hi,

 

Can you specify ntp source interface on Router.

 

Make sure this interface is reachable from the switch management interface or vlan SVI defined in the switch.

 

On the switch,  add ntp server with the Router interface address which you added as ntp source.

 

On the switch, verify ntp association by using show ntp status

Highlighted
Enthusiast

Re: witches connected to my isr 2911 router take the time from ntp server

i have subinterfaces for different vlan  so which sub interface or interface should i assign for it ntp to make sure switches and all other devices take form router same as below :

interface GigabitEthernet0/0
description connected to local NW-INTERVLAN
no ip address
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/0.2
description FACE-client-LAN
encapsulation dot1Q 2
ip address 192.168.2.207 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.9
description printers
encapsulation dot1Q 9
ip address 192.168.3.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.12
description badge-reader
encapsulation dot1Q 12
ip address 192.168.12.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.20
description WIFI-OFFICE
encapsulation dot1Q 20
ip address 192.168.4.207 255.255.255.0
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.50
description Server
encapsulation dot1Q 50
ip address 192.168.13.207 255.255.255.0
!
interface GigabitEthernet0/0.55
description native
encapsulation dot1Q 55 native
ip address 192.168.5.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.200
description voice
encapsulation dot1Q 200
ip address 192.168.6.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.201
description WAN TRANSIT
encapsulation dot1Q 201
ip address 192.168.10.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.230
description CCTV
encapsulation dot1Q 230
ip address 192.168.9.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.240
description NarrowCasting
encapsulation dot1Q 240
ip address 192.168.11.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.250
description MGMT
encapsulation dot1Q 250
ip address 192.168.7.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.912
description WIFI-Guest
encapsulation dot1Q 912
ip address 192.168.8.207 255.255.255.0
ip access-group in_guest_traffic in
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1
description connected to ISP
ip address 192.168.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

 

amr alrazzaz
Highlighted

Re: witches connected to my isr 2911 router take the time from ntp server

Ntp source interface gi0/0.250 seems to be a good choice since it is subnet dedicated for management.

 

Further, Do you have reachability to thisninterface from switch ? If not you can create Vlan SVI 250 on the switches 

Highlighted
Enthusiast

Re: witches connected to my isr 2911 router take the time from ntp server

interface GigabitEthernet0/0.250
description MGMT
encapsulation dot1Q 250
ip address 192.168.7.207 255.255.255.0
ip nat inside
ip virtual-reassembly in
this is what i have in one switch 

 

interface Vlan250
description MGMT
ip address 192.168.7.10 255.255.255.0

 

so whats the exact command should i put for both router and switch?? ( is it like below?? ) :

router:

 

 

ntp master
ntp update-calendar
ntp server 0.eg.pool.ntp.org

ntp source GigabitEthernet0/0.250

 

and on switch :

 

ntp source Vlan250

ntp server 192.168.7.207

 

amr alrazzaz
Highlighted

Re: witches connected to my isr 2911 router take the time from ntp server

your configuration looking good now. your ntp should start working fine on switch.

 

can you check output of below at Router and switch?

 

show ntp status

show ntp association

Highlighted
Enthusiast

Re: witches connected to my isr 2911 router take the time from ntp server

SW1#show ntp as
SW1#show ntp associations

address ref clock st when poll reach delay offset disp
~10.38.0.162 .INIT. 16 - 1024 0 0.000 0.000 15937.
~10.80.160.183 .INIT. 16 - 1024 0 0.000 0.000 15937.
~10.80.160.188 .INIT. 16 - 1024 0 0.000 0.000 15937.
*~192.168.7.207 127.127.1.1 8 57 64 377 1.045 14.754 1.979
~10.38.0.216 .INIT. 16 - 1024 0 0.000 0.000 15937.
* sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured
SW1#show ntp st
SW1#show ntp status
Clock is synchronized, stratum 9, reference is 192.168.7.207
nominal freq is 286.1023 Hz, actual freq is 286.0906 Hz, precision is 2**17
reference time is E1EE8473.64ABB20E (16:04:35.393 EET Wed Feb 12 2020)
clock offset is 14.7540 msec, root delay is 1.04 msec
root dispersion is 18.19 msec, peer dispersion is 1.97 msec
loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000040619 s/s
system poll interval is 64, last update was 64 sec ago.
SW1#

 

EGCAI01#show clock
16:04:38.169 EET Wed Feb 12 2020
EGCAI01#show ntp st
EGCAI01#show ntp status
Clock is synchronized, stratum 8, reference is 127.127.1.1
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**21
ntp uptime is 78716400 (1/100 of seconds), resolution is 4000
reference time is E1EE847C.F73F6FE6 (16:04:44.965 EET Wed Feb 12 2020)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.30 msec, peer dispersion is 0.23 msec
loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000000 s/s
system poll interval is 16, last update was 6 sec ago.

 

amr alrazzaz
Highlighted

Re: witches connected to my isr 2911 router take the time from ntp server

The above output indicates that time is synchronized now. You can further verify it by issuing show clock command on switch and router.

Highlighted
Enthusiast

Re: witches connected to my isr 2911 router take the time from ntp server

also it better to assign the ntp server on the g0/0 connected to lan switch or g0/1 connected to isp was router ?

amr alrazzaz
Highlighted

Re: witches connected to my isr 2911 router take the time from ntp server

@amralrazzaz 

How it goes with you ? time is also showing correct on Router and Switch ?

 

 

 

- plz mark solution as accepted and helpful if it worked with you. It will help others also who is seeking solution for similar queries.

View solution in original post

CreatePlease to create content
Content for Community-Ad