cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1431
Views
0
Helpful
4
Replies

WS-C2960G-8TC-L | "Hardware not supported by this firmware" error

MohamedRoushdy
Beginner
Beginner

Hello,

I wanted to upgrade the IOS image of my lab switch, (it's a lab switch, but it's important to us). the image that was running is: C2960 Software (C2960-LANBASEK9-M), Version 12.2(44)SE6, RELEASE SOFTWARE (fc1).

 

I've tried the following two images, assuming that number 2 is the official one, as I got it from Cisco website using the product part number, however, it didn't work and got me the same error message "Hardware is not supported by this firmware".

  • c2960sm-lanbasek9-mz.122-55.SE.bin
  • c2960c405-universalk9-mz.150-2.SE2.bin

I used the xmodem to transfer the files to the flash. The switch is out of service now, so, what's missing?

4 Replies 4

Reza Sharifi
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hi,

Does your switch have enough DRAM and flash (64/32) for this image?

HTH

Hi, the issue was that I used a wrong image for the model, this image worked fine :c2960-lanbasek9-mz.150-2.SE4.bin:.

 

Problem solved.

 

Thank you,

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

IOS file for the 2960G-8TC can be found HERE.

Thanks, but I've used this and it didn't work, but this one worked with me "c2960-lanbasek9-mz.150-2.SE4.bin". The trick is with the "ED" and "MD" code for the switch, the image you've provided is for "MD" switches, however, mine is "ED". Thanks again,

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers