Showing results for 
Search instead for 
Did you mean: 

WS-C3750X-24 Stack won't go past 15.2(1)E2


I have a stack of two WS-C3750X-24T-S switches in a stack that will not update past 15.2(1)E2.


I have tried the following versions:

  • c3750e-universalk9-mz.152-4.E.bin
  • c3750e-universalk9-mz.152-4.E10.bin


I have attached a text file with the console output.


They load the new ios into RAM and then falls back to loading the existing ios, which works. If the old ios wasnt on the switch anymore, it would attempt to load the new ios once more and then fail with 'Boot Process Failed' and put me at the 'switch:' prompt.


The switches are from 2017 so are not 'old' switches and we have never had a problem with them that would indicate a hardware fault. We managed to nurse the switch up from 15.0 to 15.2(1)E2 but we had to go to the latest 15.0 and then move to 15.2(1)E2.


What is going on here?



16 Replies 16

VIP Community Legend VIP Community Legend
VIP Community Legend

Can you post below output :


show version

show switch


show run | in boot



***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Please see attached file containing the output.

@AvidPontoon1 wrote:
System image file is "flash:/c3750e-universalk9-mz.152-1.E2.bin"

What happens when you try to upgrade the IOS using the TAR file?

The flash only contains one IOS file, 15.2(1)E2.


I did try and and the same issue occurred. We have tried this with another stack now and it’s doing the same thing.

Forcing one of the switches into rommon mode and using a USB to load the new .bin file, the switch loads it. Says ‘executing…’ and then ‘Boot process failed…’ and I’m back at the switch: prompt.

Any ideas? This is happening on 2 stacks of the same switches now.

@AvidPontoon1 wrote:
I did try and and the same issue occurred.

No, you did not. 

Someone COPIED the BIN file from one stack to another.  This method is no longer recommended because there is no way of determining if the files are NOT CORRUPTED.  

Using the TAR file, one can use the script 

archive download-sw tftp://<TFTP_IP_ADDRESS>/filename.tar

This command alone will do all the work: 

  1. Extract the files
  2. Change the boot variable string
  3. Do a quick verification check to ensure the files are not corrupt.


You are setting a snapshot of the switch at this point in time. Yesterday I tried the archive method and this didn’t work. The MD5 hashes have all been verified also. The state the switches are in at the moment is a standalone BIN file has been placed on the flash. Yesterday this was not the case.

BOTH standalone and tar archives have been used. Neither will boot the switches.

Go to the Device Coverage Checker and verify if the appliances are genuine or not.


Both switches from each of the two stacks appear when I enter the serial numbers.

@AvidPontoon1 wrote:
 10  drwx         512  Mar 30 2011 15:45:24 +01:00  dc_profile_dir

Something does not look right. 

Upgrade the switch again using the TAR file. 
Reboot the switch.  Post the entire boot-up process.

See attached output.

Try 15.0(2)SE12 it will work?

That does work, however is not the latest version. We were on that version prior to upgrading to 15.2(1)E2

@AvidPontoon1 wrote:

That does work, however is not the latest version. We were on that version prior to upgrading to 15.2(1)E2

Ok, I know what is going on. 

I have seen this exact, same behaviour twice already in this forum.

Contact Cisco TAC and organize for an RMA.

NOTE:  Do not waste any time.  The last date for hardware support for the 3650X/3750X is 31 October 2021.

First i found some issue here on your stacking here.


1. make sure you setup one of the switch as master using priority here, if not who ever come first he will be master.

2. i do not see the new image here ? in the flash have you copied. (it should be available all switches  in the stac.

3. have you dont this back (config.text.backup) or created automatically ?



here is the steps : (example do as per your environment flash)


 Upload the image into the flash:

 copy tftp: flash: c3750e-universalk9-mz.152-4.E.bin
 copy tftp: flash1: c3750e-universalk9-mz.152-4.E.bin


verify /md5 flash:/c3750e-universalk9-mz.152-4.E.bin


(config)boot system switch all flash:c3750e-universalk9-mz.152-4.E.bin





***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers