cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
770
Views
0
Helpful
6
Replies

WS-C3850-24S 10gigX4 bundle uplink drops

HADNET_KELIFA
Level 1
Level 1

Hello Team,

 

I have HA pairs of C9800-40-K9 in SSO.. both units are connected to primary and secondary core each on 40G fiber uplink.  when I test failover it take forever to switch active to standby. As a work around, we were able to fix the problem by shutting down the one10g interface of the four fiber uplinks. Then failover happened instantly. The controller is now

connected at 30G instead of 40G. The core switches are WS-C3850-24S models.

 

I have a few more sites with WS-C3850-24S core switches. Is there any known technical bugs with same issue that I need to put into consideration. Please advise if there is a workaround to fix the issue.

 

Thanks,

6 Replies 6

Hi,

 

please explain the way you did the test failover. is it device power shut or other method?

 

use below guide to verify everything is designed in correct way.

 

https://www.cisco.com/c/en/us/support/docs/wireless/catalyst-9800-series-wireless-controllers/213915-configure-catalyst-9800-wireless-control.html#anc7

 

rate this and mark as answer, if resolved your concern

Please rate this and mark as solution/answer, if this resolved your issue
Good luck
KB

Hi Kasun, 

SSO redundancy setup has no problem. however the failover from primary to secondary unit is taking forever. FYI secondary unit is connected to secondary L3 switch. the only way to do temp fix is, either by bouncing the secondary L3 switch uplink interface or shutting down one of the 10G port in 40G bundle in the L3 switch.

Default gateway check feature is not available in releases prior to 17.X.X in 9800 WLC's. So if you are running any 16.X.X flavor it is expected that you bounce one of the upstream ports to induce the failover immediately. 

If you are running 17.X.X in 9800 then it may be possible that you did not configure the RMI interface. RMI interface does the default gateway check. Also check the peer timeout values and retries. Even with default gateway check enabled failover may take up to 10sec in case of gateway non-reachability.

Please refer the below document for more info.

https://www.cisco.com/c/dam/en/us/td/docs/wireless/controller/9800/17-3/deployment-guide/c9800-ha-sso-deployment-guide-rel-17-3.pdf

Also post a rough diagram of how your devices connected to upstream switches, along with how you conducted the failover test. Learning this would allow us to provide you with accurate suggestions.

 

Not relevant, but  WS-C3850-24S is 1G ports in the fixed chassis, are you using a 10G NIM module to connect your WLC?

 

Leo Laohoo
Hall of Fame
Hall of Fame

What firmware is the switch running on?

03.06.06E

I've heard of that bug.  Don't remember it. 
Read the 3.6.6 Release Notes.  It is there.

(Plus it takes one to two hours to upgrade the IOS-XE of the 3850-12XS/24XS, CSCvq53573.)

Review Cisco Networking for a $25 gift card