Showing results for 
Search instead for 
Did you mean: 

C60 software downgrade


I upgraded a C60 codec to TC 5.1.5 without a release key . I tried to downgrade it to TC 4.1 but it will not downgrade. Any suggestions on how to downgrade? The reason I do not have a release key for TC 5.1.5 is because the compnay is having a dispute aboot the service contract. So in the meantime I need to get this codec up and running. Thanks

8 Replies 8


Also when I try to downgrade I get the error message that the "signature verification failed." How can I correct that or turn off the need for signature verification?

The problem is solved? I have a problem C20 downgrade 5.1.13 to 3.1.15.

Help me!

It's highly recommended that you upgrade your C20 to software version TC7.3.3.

If your C20 is covered by an active service contract you can get the software from the Cisco Software Page and release key from the Cisco Licencing tool.

If your endpoint does not have an active service contract, you can contact the TAC and request a TC7 release key as per the "Customers Without Service Contracts" section of this security advisory: Cisco-sa-20150320-openssl.


Please remember to mark helpful responses and to set your question as answered if appropriate.


I haven't tried myself to downgrade from TC5.1.5, so not sure if the error message you're getting is normal or not. But to workaround the problem, enable the root account first and use the "selectsw" command to boot on previous image software, which might still have TC4. More details are available on this forum if needed.

Tomonori Taniguchi
Cisco Employee
Cisco Employee

Have you tried swapping software slot?

C60 have two software slot and you may swap active software slot to revert back previous software version.

  1. Login as root, i.e., ssh root@or use ssh terminal software (same method available when connecting Endpoint from console).
  2. Execute the command: selectsw
  3. The Codec will now list the two images and tell you which one is active
  4. Check feedback and select image: selectsw image1(if feedback is “image2 [ACTIVE] [SELECTED]”) or selectsw image2(if feedback is “image2 [ACTIVE] [SELECTED]”)
  5. Reboot the system, reboot
  6. Codec will automatically restart with previous sw version of Codec had

BTW, possibly TC4.1 software you have locally corrupted so maybe you want to double check MD5 checksum.

Or download TC4.1 software from Cisco Site once again making sure you have working software.

When I entered the command selectsw , the reply was  Image1 active selected. I did not get another entry to choose from.

Hmm, no luck then!

Try to downgrade to TC5.0 first and then further down.TC5.1 has a strict check of the version number in the package and that could be the issue.

Old TC sw versions can be found on Tandberg FTP:

Have you tried to download software by using SCP file transfer method?

This is other method for software upgrade/downgrade.

Here is step with recommend application.

  1. Open WinSCP and establish the connection with C60 (WinSCP is free software and downloadable from internet) For WinSCP session, you need to login as "root" user and default password is "TANDBERG".
  2. Rename C60 software to "pkg" and upload it to /upgrade folder
  3. Wait for completion of file transfer. Software upgrade automatically start after completion of file transfer
  4. Wait for completion of software upgrade (you may monitor upgrade progress by SSH to C60 or have console connection)
  5. Open SSH and establish the connection with C60 login as "root" user then execute "reboot" command to restart C60.

C60 should now boot up with latest software version.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers