cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
623
Views
0
Helpful
5
Replies

Dual Entries in Jabber Phonebook

RAMEEZ RAHIM
Beginner
Beginner

Issue: Seeing 2 entries for Jabber users - 1 with their Findme address and other with their Device Address

Fineme Address Pattern: {username}@example.com

Device Address Pattern: {username}.jabber@example.com

I have a Phonebook source of type "Cisco TMS Provisioning Directory". It is binded to 1 particular user directory of TMS-PE.

If i do view contacts here, i see only 1 SIP contact with Fineme Address Pattern: {username}@example.com. This is expected.

Now this Phonebook source is connected to a Phone book.

If i do view contacts here, i see 2 SIP contact. 1 with Fineme Address Pattern: {username}@example.com and other with Device Address Pattern: {username}.jabber@example.com.

So, if users serach for a user on phonebook. They are presented with 2 phonebook entries - which is confusing.

Observation:

This dual entry is seen only on searches for user names which are provisioned. If we search for any user name who has not been provisioned in the recent past, we see only 1 entry for SIP.

So, for any user who has been provisioned in the past - we see both Findme address and Device address in the Phonebook.

Is this a expected behavior..? Any way to avoid this.

Note:

TMS 13.2.1

1 Accepted Solution

Accepted Solutions

Hi

You might have to create a new phonebook source and phonebook and set this setting before you link it to the phonebook as the information might already be stored in the existing phonebook.

/Magnus

View solution in original post

5 Replies 5

Magnus Ohm
Cisco Employee
Cisco Employee

Hi Rameez

Are we talking TMAgent Legacy or TMSPE?

This is normal behavior but the difference in TMSAgent and TMSPE is that in TMSPE you can turn it off. If you go to the phonebook source (provisioning source) you can click the advanced settings and untick the "import provisioned devices". That will resolve your issue. But if you are running TMSAgent, this is not possible. Then you will see multiple devices as these are imported automatically without any option to turn it off.

Best Regards

Magnus Ohm

Hi magnus,

I am running TMSPE. I will try this and update.

Thanks for your response.

Hi

You might have to create a new phonebook source and phonebook and set this setting before you link it to the phonebook as the information might already be stored in the existing phonebook.

/Magnus

Got it working

Great, glad I could help.

/Magnus

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: