Showing results for 
Search instead for 
Did you mean: 

DX80 USB Headset issues

Michel Tosu

I have a DX80 and while everything is working perfectly, one annoying bug (and a dealbreaker for me) is that when i end a call on the DX80 the headset immediately starts to ring when tha call has ben hung up. It keeps ringing until i unplug the USB from the DX80 and plug it back in. Unfortunately that only solves it until the next time i end a call.

Anyone else with the same issue?


I have a Jabra Evolve 80 MS stereo headset and my DX80 firmware is the latest.

3 Replies 3


Hi Michel

Today, I have tested this with the same with the same devices without any issue and I was surprised, that call control via the control unit works, even it´s the MS Version.

I´ve used the following software versions:

DX80: sipdx80.10-2-3-33

Evolve 80 Stereo MS: 1.27.0 with HW-Revision C






The DECT wireless headset is also simply a USB headset. I plugged it into my mac

and it worked as a generic audio/in device with volume control.

So thx to USB which can be very generic ;-)


There are some bugs around USB, like

Try to use the bug search, maybe you find something else.


That mentioned bug lists 10-3 as a fixed version, so maybe your problem is addressed there as well.


The latest version of the endpoint firmware is cmterm-dx80.10-2-3-33, I would

at least test with that if it behaves better in your scenario.


I am not sure how 3rd party USB headsets are handled, but anyhow, 

if you have a valid service contract try to ask TAC if you do not get a better answer here.



Please remember to rate helpful responses and identify


I'm running the latest version that is available to me on the Cisco website. I have looked through the bug search saw those bugs on USB stuff and also some bugs for specific Jabra headsets so I'm hoping that the next version of the DX80 software will help. Otherwise i will open a case.


I have purchased the UC version (instead of the MS) of the control link device but that didn't help either. Also, my colleague doesn't have the same issue on hos DX80 even though he has the same headset version. He can even use my headset on his unit without these issues. I'm starting to think that there is something wrong with my unit since we're on the same SW version and i have tried factory resetting my unit. But we'll see, I will update the thread.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers