cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
666
Views
5
Helpful
7
Replies

Migrating TMS 13.2 up to 15.0 Steps

Support Gurus,

Have a customer that is finally ready to upgrade their old TMS Appliance to current release and I just want to pass by someone that I am doing the best set of steps.  I know it is going to be painful.

Running 13.2.1 on a Windows 2003 serer with 2 gig of RAM.

1)  Building a new 13.2.1 server on Windows 2008 R2 server

2) Backup the current 13.2.1 server

3) Restore to new server

4) Upgrade to 13.2.2 with PE on box

5) Request new license key for 15.0 and 14.0 releases

6) I thnik that I can upgrade from 13.2.2 to 15.0 since this is not affected by the time zone change issues.

7) Once at 15.0, on this intermediate server I can back up TMS and TMSPE and reinstall on the final platform that is Windows 2012 R2.

 

Does this seem like the right steps?

Thanks

7 Replies 7

Patrick Sparkman
VIP Alumni
VIP Alumni

You'd only need a key if you planned to upgrade or downgrade to 14, but since it appears you don't need to worry about any of the time zone procedures that are mentioned in TMS 14 you can skip it and just get a release key for version 15. 

Because you're already running TMS 13.2 you could go ahead and migrate to TMSPE 1.0 per the TMSPE 1.0 Deployment Guide. Once you do that, you could go ahead and migrate to TMS 15 on the Windows 2012 server. Since the most recent versions of TMS don't include SQL, leaving the customer to install it themselves, you can import the 13.2 database into the SQL instance you installed on new 2012 server. Once you migrate the database, do a clean install of TMS 15 pointing to the 13.2 database, this will upgrade the older version database during the install.

As you migrate to TMSPE, be sure that they are running a version of VCS that supports PE, in case they are running an older version of VCS as well. 

Patrick,

Running into a "minor" problem in trying to restore the tmsng database from the 2003 backup file into the sql express 2005 database. 

Doing this based on the doc  http://www.cisco.com/c/en/us/support/docs/conferencing/telepresence-management-suite-tms-version-14/117896-technote-tms-00.html that I used the cli to make the backup file.

The error is

Msg 213, Level 16, State 7, Server WIN2008STANDARD\SQLTMS, Line 1
Column name or number of supplied values does not match table definition.
Msg 3013, Level 16, State 1, Server WIN2008STANDARD\SQLTMS, Line 1
RESTORE FILELIST is terminating abnormally.
Msg 8114, Level 16, State 12, Server WIN2008STANDARD\SQLTMS, Line 1
Error converting data type varchar to nvarchar.

 

What am I missing?

Patrick, Found my first problem was that I was using the 2005 cli instead of the 2008 cli command.  That worked.

But I am running into a problem where I am trying to migrate all of the users into TMSPE and it is failing.

The error message below indicates that there is an access issue.  I am attaching the log from the last attempt.  I am logged in on an administrator account on the server.  The one thing I am wondering is that the old database on the 2003 server had sa/TANDBERG as the database access and the new 2008 has sa/TANDBERG#1

Could this be my problem and is there a way around it?

Thanks

You probably are, but make sure you're running the correct version of Java for TMSPE 1.0 just in case.  I saw another thread where someone had the same issue, open Command Prompt as Administrator and navigate to the TMSPE directory, try and launch the migration tool that way, see Mangus' answer here: tmspe-migration-failed-access-deny.

Patrick,

That got past the Access Denied issue.  But It is saying that there is a new problem:

INFO  - Exporting data from OpenDS
ERROR - Export ldif error output:
ERROR - Ldif export failed

Mangus indicates at the end of the thread that there may be a way to access it through the OpenDS db via the OpenDS Control Panel.  Can you point me to where I can find out about this information?

Thanks

I've never came across that error before, and don't know anything about the OpenDS Control Panel.  It looks like part of the log you provided is missing, is that the entire section where it errors out, anything after it that might help point to a specific issue?  I tried searching the forums, there wasn't much info regarding what little snippet of log you provided, one person said they had success enabling the Provisioning Extension within TMS before performing the migration, if that helps.

Patrick,

Let me try it again and capture the log. 

I am wondering if the issue might be that the old server was named tms and this interum server is called windows2008 and that is causing the issue?