cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
773
Views
0
Helpful
9
Replies

Overlap Receiving Issues / No busy signal

Hello,

I have a problem with overlap receiving at german ISDN if the called extension is busy. The extension are configured with huntstop channel.

As described in this document my incoming calls working fine:

https://supportforums.cisco.com/docs/DOC-25562.

But if someone is calling a extension which is busy the incoming caller hear only silence.

I already debugged it and I can see that the isdn call is connected(to the telco) before all digits are received and after the CME identified the extension and see that the line is busy it is to late to send a ISDN busy packet back to the provider.

The result is that the call is somewhere lost in the CME.

I found another document which describes the problem:

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a0080111b58.shtml#busytone.

Does anyone have a solution for this? Perhaps can I generate a busy tone instead of the isdn message packet.  Or is it possible to route this call to my hunt-group or to another extension?

best regards

Christian

- Please rate helpful posts -
9 Replies 9

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

You should configure so that all the digtis are received before the call is connected. That will allow CME to send the subscriber busy message.

Hi Paolo,

can you tell me which parameter I need to modify for that?

interface BRI0/1/1

description ISDN AA

no ip address

isdn switch-type basic-net3

isdn overlap-receiving T302 6000

isdn point-to-point-setup

isdn incoming-voice voice

isdn sending-complete

isdn static-tei 0

trunk-group ISDN

best regards

Christian

- Please rate helpful posts -

You need to look at dial-peers, transalation rules, etc.

Hi,

that's the dial-peer and translation-rule

dial-peer voice 5 pots

trunkgroup ISDN

translation-profile incoming ISDN

incoming called-number 4568[0-9][0-9]

fax rate disable

voice translation-profile ISDN

translate calling 2

translate called 1

voice translation-rule 1

rule 1 /^4568\(..\)/ /\1/

rule 2 /^45680/ /80/

rule 3 /^.*$/ /80/

!

voice translation-rule 2

rule 1 /^\(.*\)/ /0\1/

Don't know where I can delay the system to wait for the digits to send busy signal.

best regards

- Please rate helpful posts -

One would need to see debug isdn q931 and debug dialpeer output.

Also you should apply the translation under voice-port or trunk group, not dial-peer.

I attached a debug.

1st part of the debug

One active call (connected to Ext. 28, simulating the busy)

From: 1705672222

to: 456828

One call in (should hear busy, but only silence)

From: 6181456634

To: 456828

####

2nd part of the debug

One active call (connected to Ext. 28, simulating the busy)

From: 6181456634

To: 456828

One call in (hear busy, everything fine)

From: 1705672222

to: 456828

regards

Christian

- Please rate helpful posts -

To have a readable trace , would need only the debugs asked above and nothing more.

Otherwise you can contact Cisco TAC for support.

Hi Paolo,

sorry that is the only debug I have at the moment. Because the problem happens only from particular lines I don't have the option to the test it agian for the next time.

regards

Christian

- Please rate helpful posts -

Yes, it happens only when calling from analog fixed lines, that generate overlap dialing.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: