cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
620
Views
5
Helpful
1
Replies

Room Kit Pro - Briefing Main Macro?

Oliver Holton
Beginner
Beginner

Hi, 


I have a few Room kit Pro's with a Projector screen at the front with a Quad Camera next to it and a reference screen at the back of the room with a P60, the Codec has been placed in Class room mode. See https://help.webex.com/en-us/n4522teb/Set-up-Classroom-on-Cisco-Webex-Room-Devices 

 

There is a feature in Class room mode that and they do this Split screen mode when in local presenter mode,  But we have found this "split screen" mode not very useful at all,  there will be some one at a lectern (presenter Track camera) and if some one starts talking in the audience (speaker track camera), it compiles both camera feeds in to a side by side view.

The issues is this activates way too often, so if someone moves some paper in the room it shows them and the presenter to the far end.

 

I have already made a button and a simple macro to dialable Speaker Track (which disables "split screen" mode) thus making a local presenter mode. but re-enabling Speaker Track for Q&A does not enable split screen mode again.

The only way to re-enable it, is to press remote presenter mode and then Local Presenter mode. (this is not ideal for end users)

 

On the live logs from CLI (log output on) of the device when i push local presenter mode i can see:

"User macros/Briefing_Main/internal/xows about to execute command '/Experimental/SpeakerTrack/BackgroundMode/Enable' from localhost."

and when I press remote presenter it runs:

 

"User macros/Briefing_Main/internal/xows about to execute command '/Experimental/SpeakerTrack/BackgroundMode/Disable' from localhost."

 

So i tried incorporating this in to my macro using "xCommand Experimental SpeakerTrack BackgroundMode Enable" but this gives me an error:

 

"User macros/SpeakerTrack/api/xows failed to execute command '/Experimental/SpeakerTrack/BackgroundMode <removed for privacy>' from localhost."

 

of if i run it from the CLI i get :

xCommand Experimental SpeakerTrack BackgroundMode Enable
*r Result (status=Error):
*r Result Reason: "Unknown command"
*r Result XPath: "/Experimental/SpeakerTrack/BackgroundMode/Enable"
** end

ERROR
CuilApp[1]: User infrastructure/api/tshell failed to execute command '/Experimental/SpeakerTrack/BackgroundMode/Enable' from xxx.xxx.xxx.xxx"

 

Then if i run the same command via the Developer API section on the Web Interface the command works. I don't understand why this works and how can i run it via a Macro?

 

What i want is a fourth option that is a "True Local Presenter Mode" and an option to turn on Q&A with the press of a button. or to have the default state to be this "True Local Presenter Mode" and the fourth option to be Q&A mode.

 

Can someone help? any advice is welcomed. 

 

Cheers

Oliver

1 Reply 1

Oliver Holton
Beginner
Beginner

I ended up making my own solution for this, its not pretty but it works. See attached 

Let me know your thoughts. 
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers