cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3574
Views
0
Helpful
24
Replies

Software install on E20 via serial cable

hazel.archer
Beginner
Beginner

Hi folks

I am trying to fix and E20 that won't boot.  I have managed to obtaint the appropriate serial cable and can log into it as root using teraterm, but am stuck as to what to do next.  Any ideas what the appropriate console commands are?

Thanks

24 Replies 24

OK,

at this point you need to login as admin and do :

[dderidde-ex90-home:~] $ tsh

Welcome to dderidde.ex90.home

TANDBERG Codec Release TC5.1.5.-Beta1 (TEST SW, r296765)

SW Release Date: 2012-10-15, 12:50, m

OK

systemtools  rootsettings on cisco

OK

This will kick you out of the shell, so you need to relogin, but now as root and password cisco [or whatever password you choose after the keyword "on" above].

Remove those 2 files :

[dderidde-ex90-home:~] $ rm /user/noboot

[dderidde-ex90-home:~] $ rm /user/nostart

Reboot and all should work.

When I try to log in as admin I get the following

login: admin

tshell: Failed to connect to TAN

Thanks

Hazel

After reload, I would hope the default root password in TE4.1.1 would be "" or TANDBERG. Can we try these. If that does not work, can I give you a call to try and enable root in different way?

Thanks!

Danny.

The only other alternative I see is to break into u-boot when the system starts.

When the system starts you should see :

yaffs: Mounting /flash

yaffs: restored from checkpoint

Hit any key to stop autoboot:  0

Before this point enter a key so the booting stops. The system should give you a prompt like "snoopy#" or so.

Enter the command :

setenv othbootargs allowroot

and then do boot.

root should be allowed then as login so we can finally remove the files

/user/noboot

/user/nostart

Danny.

> login: admin

> tshell: Failed to connect to TAN

This seem Cisco E20 application is still not ready (at least when you access system).

Do you see menu on E20 now?

Default password for admin access should be empty therefore you should able to access Cisco E20 application by using “admin” account without entering password.

If E20 is not up and running, can you post boot console log once again?

The main application does not get started due to presence of file /user/nostart.Need

to get into root and deoete that file. Do we have default root password in TC4.1.1 ?

hazel.archer
Beginner
Beginner

High folks

To avoid confusion - I managed to get the pkg file uploaded before I got the message about adding the touch/noboot file.  Hence it is not there.  However the system still fails to start.

Please see the latest log below.  (Although I am coming to the conclusion that it is really broken!)

Many thanks

Hazel

U-Boot 2010.06-36-svn243194 (Jan 20 2011 - 15:28:21)

I2C:   ready

DRAM:  256 MiB

Flash: 4 MiB

NAND:  HW ECC on 1024 MiB

RTC:   2012-10-17 (Wednesday) - Time:  8:33:22

Snoopy

       Rev: G

       SN: A1AA02A00080

       Object level:        MAC: 00:50:60:04:05:67

ARM Clock :- 337MHz

DSP Clock :- 675MHz

DDR Clock :- 310MHz

Net:   Ethernet PHY: Marvell

DaVinci EMAC

Hold down '4' and '6' when power up to toggle image

Press '4' two times to toggle image, press '6' to abort

yaffs: Mounting /flash

Hit any key to stop autoboot:  0

lcdpower: 1

lcdbacklight:1

Copy /flash/active/rootfs to 0x87000000...      [DONE]

Copy /flash/active/kernel to 0x85000000...      [DONE]

save exit: isCheckpointed 1

## Booting kernel from Legacy Image at 85000000 ...

   Image Name:   Linux-2.6.35.9-118

   Created:      2011-12-02   9:09:56 UTC

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    2351240 Bytes = 2.2 MiB

   Load Address: 80008000

   Entry Point:  80008000

   Verifying Checksum ... OK

## Loading init Ramdisk from Legacy Image at 87000000 ...

   Image Name:   TANDBERG rootfs

   Created:      2011-12-02   9:33:22 UTC

   Image Type:   ARM Linux RAMDisk Image (gzip compressed)

   Data Size:    8004059 Bytes = 7.6 MiB

   Load Address: 00000000

   Entry Point:  00000000

   Verifying Checksum ... OK

   Loading Kernel Image ... OK

OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Linux version 2.6.35.9-118 (hgb@prentice.rd.tandberg.com) (gcc version 4.5.2 (crosstool-NG-1.9.2) ) #1 PREEMPT Fri Dec 2 10:09:46 CET 2011

CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177

CPU: VIVT data cache, VIVT instruction cache

Machine: DaVinciHD Tandberg Snoopy

Memory policy: ECC disabled, Data cache writeback

DaVinci dm6467_rev1.x variant 0x0

Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 41910

Kernel command line: basemount=yaffs2@/dev/mtdblock1 mem=165M@0x80000000 console=ttyS0,115200 eth=00:50:60:04:05:67 mainboard=0x06 u-boot=2010.06-36

PID hash table entries: 1024 (order: 0, 4096 bytes)

Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)

Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)

Memory: 165MB = 165MB total

Memory: 154740k/154740k available, 14220k reserved, 0K highmem

Virtual kernel memory layout:

    vector  : 0xffff0000 - 0xffff1000   (   4 kB)

    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)

    DMA     : 0xff000000 - 0xffe00000   (  14 MB)

    vmalloc : 0xca800000 - 0xfea00000   ( 834 MB)

    lowmem  : 0xc0000000 - 0xca500000   ( 165 MB)

    modules : 0xbf000000 - 0xc0000000   (  16 MB)

      .init : 0xc0008000 - 0xc002b000   ( 140 kB)

      .text : 0xc002b000 - 0xc0437000   (4144 kB)

      .data : 0xc0452000 - 0xc0484040   ( 201 kB)

Hierarchical RCU implementation.

        RCU-based detection of stalled CPUs is disabled.

        Verbose stalled-CPUs detection is disabled.

NR_IRQS:245

Console: colour dummy device 80x30

Calibrating delay loop... 168.34 BogoMIPS (lpj=841728)

pid_max: default: 32768 minimum: 301

Mount-cache hash table entries: 512

CPU: Testing write buffer coherency: ok

DaVinci: 43 gpio irqs

NET: Registered protocol family 16

bio: create slab at 0

SCSI subsystem initialized

usbcore: registered new interface driver usbfs

usbcore: registered new interface driver hub

usbcore: registered new device driver usb

vpif vpif: vpif probe success

Switching to clocksource timer0_1

musb_hdrc: version 6.0, cppi-dma, host, debug=0

musb_hdrc musb_hdrc: MUSB HDRC host driver

musb_hdrc musb_hdrc: new USB bus registered, assigned bus number 1

hub 1-0:1.0: USB hub found

hub 1-0:1.0: 1 port detected

musb_hdrc musb_hdrc: USB Host mode controller at fec64000 using DMA, IRQ 13

NET: Registered protocol family 2

IP route cache hash table entries: 2048 (order: 1, 8192 bytes)

TCP established hash table entries: 8192 (order: 4, 65536 bytes)

TCP bind hash table entries: 8192 (order: 3, 32768 bytes)

TCP: Hash tables configured (established 8192 bind 8192)

TCP reno registered

UDP hash table entries: 256 (order: 0, 4096 bytes)

UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)

NET: Registered protocol family 1

RPC: Registered udp transport module.

RPC: Registered tcp transport module.

RPC: Registered tcp NFSv4.1 backchannel transport module.

Trying to unpack rootfs image as initramfs...

Freeing initrd memory: 7816K

squashfs: version 4.0 (2009/01/31) Phillip Lougher

Installing knfsd (copyright (C) 1996 okir@monad.swb.de).

msgmni has been set to 317

alg: No test for stdrng (krng)

io scheduler noop registered (default)

Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled

serial8250.0: ttyS0 at MMIO 0x1c20000 (irq = 40) is a ST16654

console [ttyS0] enabled

serial8250.0: ttyS1 at MMIO 0x1c20400 (irq = 41) is a ST16654

serial8250 serial8250.0: unable to register port at index 2 (IO0 MEM1c20800 IRQ42): -22

brd: module loaded

physmap platform flash device: 00400000 at 42000000

physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank

Amd/Fujitsu Extended Query Table at 0x0040

physmap-flash.0: Swapping erase regions for top-boot CFI table.

number of CFI chips: 1

cmdlinepart partition parsing not available

RedBoot partition parsing not available

NAND device: Manufacturer ID: 0xec, Chip ID: 0xd3 (Samsung NAND 1GiB 3,3V 8-bit)

Scanning device for bad blocks

Bad eraseblock 635 at 0x000009ec0000

Bad eraseblock 663 at 0x00000a5c0000

Bad eraseblock 1171 at 0x0000124c0000

Bad eraseblock 2278 at 0x000023980000

Bad eraseblock 2295 at 0x000023dc0000

Bad eraseblock 2344 at 0x000024a00000

Bad eraseblock 2482 at 0x000026c80000

Bad eraseblock 2908 at 0x00002d700000

Bad eraseblock 3281 at 0x000033440000

Bad eraseblock 3935 at 0x00003d7c0000

Bad eraseblock 3971 at 0x00003e0c0000

Creating 1 MTD partitions on "davinci_nand.1":

0x000000000000-0x000040000000 : "NAND"

davinci_nand davinci_nand.1: controller rev. 2.2

Initializing USB Mass Storage driver...

usbcore: registered new interface driver usb-storage

USB Mass Storage support registered.

input: cradle_sense as /devices/virtual/input/input0

rtc-ds1307 1-0068: rtc core: registered m41t00 as rtc0

i2c /dev entries driver

Linux video capture interface: v2.00

vpif_display vpif_display fpga-: vpif_display vpif_display fpga- driver registered

vpif_display vpif_display: DM646x VPIF display driver initialized

vpif_capture vpif_capture fpga-: vpif_capture vpif_capture fpga- driver registered

vpif_capture vpif_capture: registered sub device fpga_subdev

vpif_capture vpif_capture: DM646x VPIF capture driver initialized

snoopyfb0: Framebuffer at 0x87001000, mapped to 0xc7001000, size 1920k

snoopyfb0: Framebuffer registered on snoopy card

watchdog watchdog: heartbeat 60 sec

usbcore: registered new interface driver hiddev

usbcore: registered new interface driver usbhid

usbhid: USB HID core driver

oprofile: hardware counters not available

oprofile: using timer interrupt.

netem: version 1.2

u32 classifier

    Performance counters on

TCP cubic registered

Initializing XFRM netlink socket

NET: Registered protocol family 10

IPv6 over IPv4 tunneling driver

NET: Registered protocol family 17

NET: Registered protocol family 15

emac-mii: probed

rtc-ds1307 1-0068: setting system clock to 2012-10-17 08:34:03 UTC (1350462843)

Freeing init memory: 140K

INIT: version 2.86 booting

Mounting filesystems

loop: module loaded

CMEMK module: built on Dec  2 2011 at 10:10:06

  Reference Linux version 2.6.35

  File /data/sata/branches/os/linux/cmem/_build/snoopy.arm/work/linuxutils_2_25_04_10/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c

allocated heap buffer 0xcf000000 of size 0xae000

cmemk initialized

input: serial_mcasp_driver as /devices/virtual/input/input1

video_dsp_driver: DspCom: IRQ: 45

yaffs: dev is 32505857 name is "mtdblock1" rw

yaffs: passed flags ""

SQUASHFS error: Xattrs in filesystem, these will be ignored

eth0: attached PHY driver [Marvell 88E6121] (mii_bus:phy_addr=1:01, id=1410cb1)

ADDRCONF(NETDEV_UP): eth0: link is not ready

Trying 1000/FULL

Trying 10/HALF

Trying 10/HALF

INIT: Entering runlevel: 2

Trying 10/HALF

login: Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

Trying 10/HALF

login: admin

tshell: Failed to connect to TAN

login: Trying 10/HALF

Trying 10/HALF

Can I give you a call? I think it would be easier.

Got on the phone with Hazel and entered the system in u-boot mode by hitting key when booting up.

Set the u-boot environment to get into root :

setenv otherbootargs allowroot

So we could finally login to the system via root. admin did not work because the E20 crashed.

We looked at the /var/log/eventlog/all.log file and noticed one of the DSPs is not responding : hardware issue. Not possible to fix this but RMA the unit. Sorry for this...

[Snoopy:/var/log/eventlog] $ cat all.log
Oct 17 11:58:04 (none) main: FPGA programmed OK
Oct 17 11:58:04 (none) main: Product information
Oct 17 11:58:04 (none) main: Snoopy
Oct 17 11:58:04 (none) main: Board revision: G
Oct 17 11:58:04 (none) main: Thread LedTask has TID 1746
Oct 17 11:58:04 (none) main: TE4.1.1.273710
Oct 17 11:58:04 (none) main: SVN Revision 273710
Oct 17 11:58:04 (none) main: Serial number: A1AA02A00080
Oct 17 11:58:04 (none) main: Program audio dsps [1]
Oct 17 11:58:13 (none) osd: WARNING :  Cannot parse value [ "" ] in "Config/Video/Selfview" to boolean. Treating it as "false".
Oct 17 11:58:13 (none) osd: WARNING :  TState has no desktop set
Oct 17 11:58:13 (none) osd: WARNING :  TState has no desktop set
Oct 17 11:58:15 (none) main: shmemLoadDsp: Program video dsp
Oct 17 11:58:17 (none) main: shmemLoadDsp: Program video dsp finished
Oct 17 11:58:17 (none) video: DSP ID 1
Oct 17 11:58:17 (none) video: Product information
Oct 17 11:58:17 (none) video: Snoopy
Oct 17 11:58:17 (none) video: Board revision: G
Oct 17 11:58:17 (none) main: Thread persistDb has TID 1763
Oct 17 11:58:18 (none) main: Thread persistDb has TID 1764
Oct 17 11:58:18 (none) video: fsm_procSetup: Open Interprocessor comm devs.
Oct 17 11:58:18 (none) video: shmemdsp: Waiting for arm to init shmem area. (119)
Oct 17 11:58:18 (none) main: Thread ShmemRx has TID 1765
Oct 17 11:58:19 (none) video: shmemdsp: Waiting for arm to init shmem area. (118)
Oct 17 11:58:20 (none) video: fsm_procSetup: Initialize data structures.
Oct 17 11:58:20 (none) video: fsm_procSetup: Create all FSM tasks[6].
Oct 17 11:58:20 (none) video: fsm_procSetup: Check for system synchronization.
Oct 17 11:58:20 (none) video: registerAndWaitForNotify: Sending id = SYSTEM_VIDEO0(1) (16777216)
Oct 17 11:58:20 (none) video: Wait for timeout, or incoming message
Oct 17 11:58:28 (none) main: uhpihost: Can't boot dsp 0
Oct 17 11:58:28 (none) main: uhpihost: Can't boot all dsps
Oct 17 11:58:29 (none) main: Received signal SIGSEGV (11) in thread 0x4082a4c0, TID 1713
Oct 17 11:58:29 (none) main: Illegal memory access at: 0xebffffb2
Oct 17 11:58:29 (none) main: Registers:
Oct 17 11:58:29 (none) main: R0:     4010414c R1:   ebffffb2 R2:    bea1569c R3:   000000c8
Oct 17 11:58:29 (none) main: R4:     40100000 R5:   bea1569c R6:    ebffffb2 R7:   bea1569c
Oct 17 11:58:29 (none) main: R8:     bea156c8 R9:   ffffbd0c R10:   bea156cc FP:   bea199e4
Oct 17 11:58:29 (none) main: PC:     400e8864 IP:   400e8818 SP:    bea15640 LR:   400e9790
Oct 17 11:58:29 (none) main: ERR:    00000005 CPSR: 60000010 FAULT: ebffffb2 TRAP: 0000000e
Oct 17 11:58:29 (none) main: OLDMSK: 00000000

Many thanks for all the help - much appreciated.

Hazel

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: