Showing results for 
Search instead for 
Did you mean: 

SX20 and ISDN Link with TC6

Adrian Lazar
Level 1
Level 1

Hi guys,

I have recently upgraded an SX20 and ISDN Link to the new TC6 and after the upgrade I cannot make ISDN calls anymore.

I can see and manage the ISDN Link from the SX20 configuration web page but the status of the ISDN Link is: Error , SIP not registered.

I am using H323 in the network and I only use SIP between the SX20 and ISDN Link and with the old version I was able to receive and make calls. Now when I try to dial ISDN using the new TC6 interface the endpoint says that it does not find the ISDN Link.

Thank you for your assistance,


1 Accepted Solution

Accepted Solutions

Patrick Pettit
Cisco Employee
Cisco Employee

Hi Adrian, Valentin.  Theres something going on with Outbound enabled on the Link and Codec for this, and we have two CDETS open on them.  SIP service is still required to be enabled on the Codec with Link and Link itself.  Codec uses Links local IPV6 to register to the Link itself.  Even though the xstatus sip on the codec shows its inactive etc, the codec is still sending SIP REGISTER messages to the Link device for registration.  Link is running a SIP FWD process in which is handling the request.  Sorta like a mini SIP registrar if you will.  Codec will send REGISTER message using Link's local IPV6 address.  Example message is below with 200 Ok.

77582.64 SipPacket   PacketDump: Proto: SIP, Name: REGISTER sip:[0000::000:0000:0000:cd39]:15070 SIP/2.0, Direction: Outgoing, RemoteAddress:[0000::000:0000:0000:cd39]:15070, GroupEntity: b27d07c1f5f298c492db68040b320ca6, Time: 77582634, Content: !!!<

77582.64 SipPacket   REGISTER sip:[0000::000:0000:0000:cd39]:15070 SIP/2.0

77582.64 SipPacket   Via: SIP/2.0/TLS [fe80::250:60ff:fe83:c52a]:5061;branch=z9hG4bK45a7681a50ebbdc5b98e2f91bff6b438.1;rport

77582.64 SipPacket   Call-ID: b27d07c1f5f298c492db68040b320ca6

77582.64 SipPacket   CSeq: 47083 REGISTER

77582.64 SipPacket   Contact:


77582.64 SipPacket   From: ;tag=116a994ac2281c72

77582.64 SipPacket   To:

77582.64 SipPacket   Max-Forwards: 70

77582.64 SipPacket   Route: <>


77582.64 SipPacket   User-Agent: TANDBERG/518 (TC6.0.0.876266)

77582.64 SipPacket   Expires: 3600

77582.64 SipPacket   Authorization: Digest nonce="d9605a7da8be22af8c0e7f52b3de4a5f5125fcd3", realm="MARCIE", qop=auth, username="djkvvknn", uri="sip:[0000::000:0000:0000:cd39]

", response="3b27b753cb9bcf38cc2431b767bce643", algorithm=MD5, nc=00000002, cnonce="84addca2a68f6c5f9b657a94653a4bae"

77582.64 SipPacket   Supported: replaces,100rel,timer,gruu,path,outbound

77582.64 SipPacket   Content-Length: 0

77582.64 SipPacket

77582.64 SipPacket   >!!!


77582.65 SipPacket   SIP/2.0 200 OK

77582.65 SipPacket   Via: SIP/2.0/TLS [fe80::250:60ff:fe83:c52a]:5061;branch=z9hG4bK45a7681a50ebbdc5b98e2f91bff6b438.1;rport=41246;received=0000::000:0000:0000:c52a

77582.65 SipPacket   Call-ID: b27d07c1f5f298c492db68040b320ca6

77582.65 SipPacket   CSeq: 47083 REGISTER

77582.65 SipPacket   From: ;tag=116a994ac2281c72

77582.65 SipPacket   To: ;tag=e84d13204776ebc2

77582.65 SipPacket   Server: fwd

77582.65 SipPacket   Contact: ;+sip.instance=""

77582.65 SipPacket   Content-Length: 0

77582.65 SipPacket

77582.65 SipPacket   >!!!


I removed my own addresses, so you get the picture here. 

Same goes for Link.  Link will send REGISTER to itself as well. 

Even though your using H320 as dial out protocol, the messaging between the codec and the Link device is still SIP as the outbound call is still SIP from the codec to the Link even though you chose H320. 

You can see all this going on whilst running: log ctx sippacket debug 9 and log output on to see the messaging going back and forth between the devices.  This is why SIP Service on the codec can not be disabled.

The outbound being enabled on both devices and it not registering like what Adrian encountered is odd. So issue has been filed and is under investigation.

CSCue57128 -SIP in strange state when connecting to ISDN Link (Codec)

CSCue73049 -Enabling SIP outbound on ISDN Link causes it to lose registration (Link)

These are new, so viewability may not be there yet.

If you see an issue with Link not being able to register, check to see if SIP outbound is enabled on Link.  If so, disable and boot.

Do the same on the codec as well.  Turn off SIP Outbound and reboot.  There may be some instances you don't see this, so the investigation is ongoing with the above two bug ID's.

Hope this helps.



View solution in original post

22 Replies 22

Patrick Pettit
Cisco Employee
Cisco Employee

Hi Adrian.  With TC6, you can pair it to the ISDN Link Module running IL 1.1.  Is the system paired to the device? If you choose SIP and place the call with x-h320Number URI, does it still make the call out? I do believe when choosing ISDN, you have to be paired with the Link Module for this to work.  Are you running IL1.1 and is the system paired to the module?



Hi Patrick,

Yes, I am running IL 1.1 and the SX20 is paired with the ISDN Link but I cannot make calls using either the web interface or the Touch.

As I was saying above the status of the ISDN Link in the web interface of the SX20 is : Error, SIP not registered, I'm not sure how to troubleshoot this message.



Hi Adrian.  Sorry about that.  So diagnostic page on SX20 shows the below?

If you can entertain me for a moment, and enable SIP on the SX20 (if not enabled), but don't fill out the rest of the fields like proxy etc, does this error go away? When you choose H320 from the webpage, does the call make it out? 



Hi Patrick,

The error in the Diagnostics is simillar to yours:


ISDN Link status

The link status is Error: SIP NOT registered.

SIP is enabled on the SX20 NetworkServices and the rest of the fields are not filled.



Thanks Adrian.  Investigating.  If its possible, would you be able to provide xcon and xstat from SX20 and Link Module while in this state?  You can send via email if you wish to if you prefer. 



Hi Adrian,

Do you have the same error if you disable SIP on codec ?

Sent from Cisco Technical Support iPad App

Hi Valentin,

Yes, the error is the same. Anyway I believe SIP must remain enabled because it is used by the SX20 to communicate with the ISDN Link.




I have absolutly the same problem as Adrian, only difference is that I am using

a C40 codec instead of the SX20.

And I have this problem since updating the devices before it worked fine.



Hi Adrian,

do you use the TC6 or the TCNC6 - because I am using TCNC6 because of our license key.



HI Klaus.  I've been working with Adrian via email about this.  If you want, can you post the exact error that your seeing? 

What is the exact error that the Link Module is indicating? 

If you can for me, on the codec and the Link Module, can you disable SIP Outbound on both the Link and Codec and reboot both and let us know what happens?